Thread Tools
Sep 22, 2018, 10:18 AM
Registered User
SuperCal's Avatar
Discussion

Esc's won't initialize


Hi everyone,

I'm using a Vector in my quadcopter and the esc's won't initialize when i plug the battery in. It has been flown before and everything seemed ok. I've tried everything I can think of, even tried running a different Vector and still no luck. The esc's work fine when plugged directly into the receiver though. Any ideas would be appreciated...

Thanks in advance... Calvin
Sign up now
to remove ads between posts
Sep 24, 2018, 08:28 AM
JohnET's Avatar
Hello,

Have you reviewed the log file to see if there is an error? Some errors will not allow the system to arm. Otherwise I suggest recalibrating the ESCs and re-running the RX Wizard. Also, a change in your radio could cause the issue and it may be a good idea to create a new model in your radio. If you cant get it working please open a support ticket and provide your log and config files.

Regards, John


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Tarot 2D Gimbal won't initialize CrimsonCup Multirotor Drone Talk 1 Feb 15, 2016 02:28 PM
Question ESC won't initialize JGallo Power Systems 6 Feb 14, 2016 10:30 AM
Discussion ESC won't initialize? SDScuba Car Talk 1 Nov 12, 2007 10:11 AM
Help! HiModel 18/22A ESC Won't Initialize bevers01 Power Systems 0 Sep 12, 2006 09:32 PM
Help! ESC won't initialize kharrison Power Systems 3 May 14, 2006 12:58 AM