Shop our Airplanes Products Drone Products Sales
Thread Tools
Sep 17, 2018, 11:15 AM
Registered User
Discussion

Vector OSD Menu not activating (X8R/X9D)


I'm using an FrSky Taranis X9D plus transmitter with X8R receiver, connected to regular EagleTree Vector.

This is with a quad configuration. I can get the drone into the air and perform flight. I get the OSD display transmitted to my EV800D FPV display on power up (i.e. camera video overlaid with horizon marker, altitude, engine speeds, etc.). All that is working nicely.

When I use my MODE switch on the X9D, the OSD display shows the mode changes (2D Hold to 2D NoHold). Sub-mode and Gain switches are also working (they respond on the Vector Windows utility dialog, when I connect via USB).

My issue is getting to the Vector calibration menu. I can't activate the Vector menu via the OSD. I've tried flipping MODE 2-4 times, or 7 times, etc. I've tried switching slowly and quickly.

On the X9D, INPUTS page, I made "mode" set to SF.

Input Name mode
Line Name mode
Source SF
Weight 100 Offset 0
Curve Expo 0
Modes 012345678
Switch SF(up)
Side --- Trim OFF



On the X9D, MIXER page,
CH 5 (100) I mode SF(up)
Mix Name (blank)
Source I mode
Weight 100 -100 100
Offset 0
Trim [check]
Curve Diff 0
Modes 012345678
Switch SF(up)
Warning OFF
Multpx Add
DelayUp/Dn SlowUp/Dn all set 0.0


Thanks!
Last edited by voidstar; Sep 18, 2018 at 10:12 AM.
Sign up now
to remove ads between posts
Sep 18, 2018, 08:10 AM
JohnET's Avatar
Hello,

Make sure the end points for your mode channel are set to defaults and not reduced. In other words, if you have a servo connected to that channel, it should move from one full extent to the other full extent when you move the switch. And just to be clear, you should toggle twice so if you are in the up position with the switch you should go, down-up, down-up quickly.

If you are unable to get it working, please open a support ticket.

Regards, John
Sep 18, 2018, 10:40 AM
Registered User
Quote:
Originally Posted by JohnET
Hello,

Make sure the end points for your mode channel are set to defaults and not reduced. In other words, if you have a servo connected to that channel, it should move from one full extent to the other full extent when you move the switch. And just to be clear, you should toggle twice so if you are in the up position with the switch you should go, down-up, down-up quickly.

If you are unable to get it working, please open a support ticket.

Regards, John

Well CH1-4 are connected to the motors. CH5 is the 2-position toggle switch (SF) that I'm trying to assign to MODE (it's the only 2-position switch I have on the transmitter, the rest are 3 position).


I did notice that on the transmitter (X9D) LCD, it shows a graphic of the transmitted signal -- for the motors, it animates along the full extent of the bar (-100 to +100) as I move the sticks. Yet for the switch (CH5, SF in my case), there is no similar animation. However, the OSD is indicating a mode change (in green near the top on the OSD, it will toggle between "2D NoHold" and "2D With Hold" message which is what I have configured for Mode1 and Mode3 {the rest of the modes 2/4/5 are unassigned in the Vector}).
Sep 18, 2018, 10:22 PM
Registered User
In the image below is an example for reference. I had the left control stick moved around, so it shows positive and negative values on CH3 and CH4 (they'd got to full +100 or -100, or back to -100/+100, as I move the stick across their full range).

CH5 is what I have the MODE switch connected to. "down" position for me is 0.0, but "up" position will fill in the +100 side of the graph (indicated by the red line). It doesn't show -100 or ever cross the 0 (which maybe is what the OSD menu is triggered from?)
Last edited by voidstar; Sep 19, 2018 at 06:59 AM.
Sep 19, 2018, 08:26 AM
JohnET's Avatar
Hello,

You need to have the mode channel operate just as you see channels 3 and 4 with the full positive and negative values. Until you get that corrected you will not be able to use the mode switch to activate the menu system. I recommend you contact FrSky for assistance.

Regards, John
Sep 19, 2018, 01:49 PM
Registered User
I suspected so. I've tried adjusting a few settings on the X9D transmitter, but so far no luck. I have a message out to FrSky for support.

Will report back, thanks.
Sep 20, 2018, 12:48 AM
Registered User
Got the menu to show up, just not very reliably. I mapped MODE to CH1 (same as THROTTLE), flipped a bunch of times using the stick, and the menu would eventually show up (even got the calibration to show up once, but then it disappeared before I could actually finish a calibration).

So it is a matter of tuning some parameters on the X9D I think. I've reverted everything back to the way I had it, and will try again later.
Sep 20, 2018, 07:55 PM
Registered User
Got it -- the issue was the extra Switch setting on the INPUTS page that I had for MODE. Just need to specify Source as SF, and don't put anything on the Switch setting.

On the INPUTS page (5/12), EDIT whatever Channel is set for MODE...

Input Name mode
Line Name mode
Source SF
Weight 100 Offset 0
Curve Expo 0
Modes 012345678
Switch SF(up) --------> WRONG, set this to "---" (nothing)
Side --- Trim OFF


Vector OSD menu is now showing up reliably, completed a calibration. I even also changed from using SF (2-position switch) to a 3-position switch, so I can now also try out the Cartesian mode in addition to 2D hold and no hold.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! OSD menu works, horizon and scroll does not. ToothlessRebel FPV Equipment 4 Mar 28, 2017 11:42 PM
Help! Newbie Help - Tanaris X9D w/ Frsky X8R - Not seeing receiver randmhero Beginner Multirotor Drones 2 Apr 10, 2016 11:22 PM
Discussion Newbie Help - Tanaris X9D w/ Frsky X8R - Not seeing receiver randmhero Beginner Multirotor Drones 0 Apr 10, 2016 02:08 PM
Discussion Eagle Tree Vector (Motor Test Not Working In Stick Menu) GRCT42 Eagle Tree Systems 7 Dec 28, 2015 08:51 AM
Discussion Taranis X8R will not bind to X9D TrueBuld Radios 3 Feb 14, 2015 08:11 AM