Thread Tools
This thread is privately moderated by Slider2732, who may elect to delete unwanted replies.
Aug 28, 2018, 10:39 AM
Storm Runner guy
Slider2732's Avatar
Thread OP
Discussion

JJRC H67 Santa acro firmware file ?


Update -
Huge thanks to GroundControlRC, who pointed me in several right directions and put me back on the right road like a spun out Scalextric car.

The end result was to edit Silverware files in a regular text editor.
Then 'make' in the command line and flash using the OpenOCD software.
My Santa quad now runs Silverware !






Original Blog post
-------------------------------------------------

After several days of trying to sort this out, I need some help

Short version:
Does anyone have stock TX usable firmware for the JJRC H67 Santa quad, for acro ?
Even better, firmware that doesn't check for a gyro in the first case.

The intention is to use the RX on planes, 2 motored and 4 motored. I've had a lot of success with the Peter Sripol method but the gyro often gets in the way, causing wing wobble.



Info - this is no lazy modder of a situation.

I have 2x JJRC H67 Santa quads and a semi broken RX that's been used for testing out code uploads (a trace came off the gyro chip when removing an AIO camera).
Am using the stock RX, got no Devo.
I want to remove gyro checking or verifying completely.
My PC uses Linux Mint - all the tools are Windows only. WINE doesn't like USB for the ST Link V2 and Keil bombs out during install.
The quad RX is unlocked via OpenOCD and accepts files.
Flashing is possible with OpenOCD, such as:
$ openocd -f /usr/share/openocd/scripts/interface/stlink-v2.cfg -f /usr/share/openocd/scripts/target/stm32f0x.cfg -c init -c "reset halt" -c "flash write_image erase bwhoop.bin 0x08000000" -c "verify_image bwhoop.bin 0x08000000" -c "reset run" -c shutdown

So, you see, i'm nearly there, just can't edit the parameters and have no working firmware.

If the gyro was not even looked for, the broken RX might return to life. The STM32 is fine.


Many thanks for any help
Last edited by Slider2732; Aug 30, 2018 at 09:30 PM.
Sign up now
to remove ads between posts
Aug 28, 2018, 04:35 PM
Registered User
I'm not sure if this will help but here is something I found on the Eachine E011 and JJRC H67 and it appears there's a link to the SilverWare Firmware.
I hope this helps...good luck
ACRO SANTAWHOOP JJRC H67 and Eachine E011C (5 min 36 sec)

https://www.rcgroups.com/forums/show...onstruction%29
Aug 28, 2018, 09:45 PM
Storm Runner guy
Slider2732's Avatar
Thread OP
Ahhh thanks !
I'd seen the guys video and that's where the ST software fell over on my PC, as am running Linux.
The software runs fine, but USB isn't seen and has always been an issue of WINE (Windows emulator)..
What I hadn't seen is the info in the link you posted below it...thanks very much.
I'd thought that surely everyone doesn't makes the same changes themselves every time !
It would be great to tune the settings, but have been thinking that most would just like acro or the ability to drop the altitude hold from BWhoop's.
Aug 28, 2018, 10:03 PM
Storm Runner guy
Slider2732's Avatar
Thread OP
I tried the firmware in that link and nothing happened unfortunately.
But then realised that the E011 is different to the BWhoop, with some guides saying to use the BWhoop B03 Pro firmware for the Santa quad. The chips appear to be the same, but there are a couple of traces different on the boards themselves...MOSI and SCLK (or similar) are swapped.

My test RX used to do the 3 flash error thing when first successfully flashed. Now it only briefly flashes its red light on power plug in.
But there's an untouched Santa quad out in the livingroom to try working firmware on.
All I want to do is to tilt it and the motors don't speed up
Aug 28, 2018, 11:52 PM
Storm Runner guy
Slider2732's Avatar
Thread OP
Update:
I followed this Linux example, using the OpenOCD software.
https://www.rcgroups.com/forums/show...flash-on-linux

Then flashed the bwhoop firmware again and...partial success, the RX came back to life.
It now flashes both LED's 4 times
Still doesn't bind to the stock TX though. Keeps flashing the LED's 4 times, waits a second and does it again, repeatedly.
Aug 29, 2018, 12:10 AM
Storm Runner guy
Slider2732's Avatar
Thread OP
Ah!

Keil is working, I can edit stuff.

It looks like it can't find the gyro, well that's correct cos of the missing wire trace and at least 1 component.
From hardware,h

// the error codes indicate a failure that prevents normal operation
// led flash codes - the quad will not fly / bind if flashing a code
// 2 - low battery at powerup - if enabled by config.h "#define STOP_LOWBATTERY"
// 3 - radio chip not found
// 4 - Gyro not found - maybe i2c speed
// 5 - clock , intterrupts , systick , gcc bad code , bad memory access (code issues like bad pointers)- this should not come up
// 6 - loop time issue - if loop time exceeds 20mS
// 7 - i2c error - triggered by hardware i2c driver only
// 8 - i2c error main loop - triggered by hardware i2c driver only
Aug 29, 2018, 09:47 AM
Registered User
I run Linux as well ;-) Love it ;-)
Have you tried the free version of VirtualBox with the Extensions Pack?
It has pretty good support for USB.
I typically use an old copy of Windoze XP Pro in VirtualBox for those Windoze ONLY things ;-)
Good luck.
Aug 29, 2018, 10:40 AM
Storm Runner guy
Slider2732's Avatar
Thread OP
Thanks for that advice too
You've put me back on the right track like a spun out Scalextric car lol

I hadn't thought of the Virtual Box route, but that does make a better sense.
Also, although Keil runs and I can make changes to the files, config.h etc, it says it has no 'RTE' and won't compile anyway. That would be presumably why it reported a failed install.
Virtual Box it is, with a hopefully none bit-rotted XP CD !


Quick Reply
Message:
Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-Review Stocking Stuffer Drones for Christmas (JJRC H66 X-MAS Egg // H67 Flying Santa Claus) JohnCC Gearbest.com 5 Dec 16, 2017 06:52 PM
Mini-Review JJRC H67 flight santa claus, transforming it into a piece of Tiny Fpv LTECNIC Micro Multirotor Drones 0 Nov 27, 2017 07:06 AM
Build Log FPV Santa - JJRC H67 whoop with 7mm motors QuadifyRC.com Micro Multirotor Drones 2 Nov 08, 2017 02:59 AM
Discussion JJRC H67 Santa Claus RC (15.99$) eli99 Gearbest.com 0 Oct 17, 2017 10:15 PM