Thread Tools
Aug 11, 2018, 10:47 PM
Registered User
I am the only account running on all the machines running as the Administrator.
Yes i realise the .ini will rebuild itself.
I finally sorted the problem.
Installed an older version of Xdp and Ftdi drivers wouldnt install on Win 10 so i downloaded the latest drivers from Ftdi.
Success,everything now works as it should on all my machines.
And there is a reset to defaults for the Tx module in the Xdp program on the next screen after view/change selected.
Last edited by Craig 01; Aug 12, 2018 at 12:20 AM.
Sign up now
to remove ads between posts
Aug 12, 2018, 02:53 AM
So it's a FTDI driver issue? I need to look to see what version of drivers is being installed.
Aug 12, 2018, 04:41 AM
Registered User
No,it's the current xdp program it seems.At least the ones i've downloaded last few days from your site.
Using the current Ftdi drivers from the Ftdi site worked on the Xpd version 3.9 i found buried in my files that had an outdated Ftdi driver package that wont install on win 10.
On yet another uninstall completely removing all traces i reinstalled the current Xdp exe with the latest ftdi drivers.Problem of the Xdp screen disappearing on selection of the view/change button returned as it was with the original drivers.
Aug 12, 2018, 04:04 PM
All of the XDP programs have been the same since 2009. The only difference in the versions is the firmware file that is attached to the XDP program.
Aug 12, 2018, 08:08 PM
Registered User
I can only tell you what i found Jim
The packed file sizes between the two are different
The Xdp software on your web site currently,has an issue on my Win 10 pc's.
The one running on my pc's now was downloaded from your site perhaps around 2012/13 and with a Ftdi driver update,works perfectly.
And all i can say is it doesn't matter wether it's the same, or obviously not in my case and am glad the week of stuffing around is finally sorted.
Aug 12, 2018, 09:42 PM
They are definitely different in size due to the firmware file being different in size. Glad it works for you, and I am glad that nobody has problems with the latest version of firmware.
Sep 24, 2018, 12:13 AM
Garland
Ghia's Avatar
I replaced my 2014 copy of xdp with the latest xdp and now the whole xdp program disappears when I try to connect a module to it. Rx nano has worked fine in this new version of xdp to tweak fail safes and read write to eprom etc.

I tried 2 separate A9 modules and once I search for modules in xdp, it show a A9 module pic and when I hit connect the whole xdp program disappears and tells me it IS running as a error msg.

I not sure exactly how fix this?
Last edited by Ghia; Sep 24, 2018 at 12:36 AM.
Sep 24, 2018, 04:42 PM
What version of Windows are you using?
Sep 24, 2018, 05:01 PM
Garland
Ghia's Avatar
Window 7 home edition 32 bit
Sep 24, 2018, 09:36 PM
Hmm.. that's what we use on one of our machines, so that is not the issue. How did you update to the latest version? Using the auto-update or by downloading the complete installer?
Sep 24, 2018, 10:10 PM
Garland
Ghia's Avatar
Thanks JD! I downloaded the whole new xdp program as ithought my xdp was out of date being from 2014
Last edited by Ghia; Sep 24, 2018 at 10:30 PM.
Sep 25, 2018, 01:12 AM
What version does your XDP program show you when you go to the ABOUT pull-down menu?
Sep 25, 2018, 01:56 AM
Garland
Ghia's Avatar
version 3.9 xdp. I held my Futaba 9C module button til its orange, ( 2 A9 modules and now a 9C module cant connect) the xdp did find itand showed a pic of XPS-f1 then xdp program disapeared at the connect to module software button....

every RX i own connects to xdp still....I think its a minor glitch or something
Last edited by Ghia; Sep 25, 2018 at 02:08 AM.
Sep 25, 2018, 11:44 AM
v4.0 is the latest version. Do the update from within the XDP program.

It could be that the EEPROM is not what is expected and it closes. I don't have this issue with v4.0.
Sep 25, 2018, 03:21 PM
Garland
Ghia's Avatar
Ok I re downloaded xdp program from your website and hit help button . version is 3.9. I click update, then it said, there is a new update!

ok cool update installed and I then go check the version and see it version 3.9 again.

Ok now I will admit something stupid I had BOTH my A9 xps modules installed when I did both my hitec A9 radios update with their tool hpp-22 and their radio update software.

So now both A9s radios work fine with their updated firmware which is cool.......and they show PPM signal goin into the xps modules like I had them set to before .....

both A9 xps modules have solid orange lights now that I cant change and I know they were fine before that! Im just fustrated!

Can I send the modules in for repair Jim or am I out of luck on this? I do appreciate your help so farJim!


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion XDP problem on Windows7 Smyk Xtreme Power Systems 7 Nov 14, 2016 08:54 PM
Discussion XDP Software Download Problem ChuckA Xtreme Power Systems 4 Feb 15, 2013 04:14 PM
Discussion XDP TxDiag & Range Test problem PGR Xtreme Power Systems 14 Jun 25, 2012 01:15 AM
Discussion XDP problems w/ ver.3 jcyr1 Xtreme Power Systems 8 Nov 23, 2008 04:32 PM
Discussion XDP Problem Heather Xtreme Power Systems 6 Nov 27, 2007 09:49 AM