Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Dec 16, 2004, 04:29 PM
STaNgXs is offline
Find More Posts by STaNgXs
Registered User

Elevator Trim On My Optic 6 Not Working?


when I try to tril the elevator, it doesn't move the servo.. the reeading tells me it's moving, but the servo stays still... anyone know what my problem is?
Sign up now
to remove ads between posts
Old Dec 16, 2004, 05:09 PM
rcguy01 is offline
Find More Posts by rcguy01
Permanently Banned
change the servo, maybe just a bad servo.
Old Dec 16, 2004, 05:15 PM
ivanc is offline
Find More Posts by ivanc
S.A.D. member
ivanc's Avatar
Your Tx might be in Stick Mode 1 - change it to Mode 2 as described on page 7 in the manual.
Old Dec 16, 2004, 05:31 PM
STaNgXs is offline
Find More Posts by STaNgXs
Registered User
Quote:
Originally Posted by ivanc
Your Tx might be in Stick Mode 1 - change it to Mode 2 as described on page 7 in the manual.
heh, thanks.. i'll try that when I get home
Old Dec 16, 2004, 08:21 PM
rutat is offline
Find More Posts by rutat
Registered User
Check your EPA etc. My Optic was obviously (re)set with strange numbers and NO servo movements were happening when I first got it. A quick call to Poway fixed it though!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Need expert advice on hooking up my Optic 6 with RealFlight G3 funfly123 Mini Helis 7 Nov 21, 2006 10:13 AM
Discussion want to disable the trim levers on an optic 6 geneween Hitec/Multiplex USA 6 Aug 24, 2006 04:12 PM
Optic 6 not working swa2153 Hitec/Multiplex USA 2 Aug 19, 2005 11:12 PM
Esc on my Sportster EP... not working!!!!! Awall Sport Planes 7 May 27, 2005 11:34 AM
Want to use fast charger on my Optic 6 RonJ Hitec/Multiplex USA 6 Mar 20, 2005 07:28 AM