Thread Tools
Jul 15, 2018, 07:05 AM
Registered User
Thread OP
Discussion

X-lite wont binde to R-XSR


Hello,
I have a new X-lite that wont binde to a R-xsr.
My X9D can binde to the same reciver with no problem.

The Xlite is running Open TX2.2.2 version 180528
The R-xsr are running version FW-RXSR-171009

I have used both LBT and Non LBT for both versions.
I have also tried the X-lite open tx 2.2.2 version 180622

In the radio setup I have also changced the country code to US /EU

I knowe for sure that the r-xsr is working with my x9d

BR Kai
Sign up now
to remove ads between posts
Jul 15, 2018, 08:04 AM
Registered User
Thread OP
After flashing the internal RF module to none LBT, open TX to none LBT and r-xsr to non lbt we got it to work.
Aug 16, 2019, 02:56 AM
Registered User

same problem R-XSR won't bind on X-lite


Hello, I have the same problem with R-XSR and my X-lite but i have no other controller to help.

I upgraded opentx to 2.2.4 from 2.2.2
I tried the EU and non EU X-lite internal transmitter,
but when plugging the battery while pressing FS button on the R-XSR receiver,
all the lights (red, green, blue) stay solid.

After a power cycle, the blue is solid, the red is flashing and there is no green.
which i think means it's not binding.

How do you find what firmware is on the R-XSR receiver?
Any thought on what else i can try?
Aug 25, 2019, 04:25 AM
Registered User
tomodachy did you get it sorted?


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion R-XSR will not bind jcleek Multirotor Drone Electronics 12 Sep 10, 2018 07:03 PM
Discussion Can't bind r-xsr to my taranis! PLS HELP! tooth pain Beginner Multirotor Drones 1 Jul 04, 2018 05:38 PM
Discussion Binding r-xsr akabowman Beginner Multirotor Drones 2 Apr 22, 2018 06:40 PM
Discussion Horus x10s can't bind to r-xsr Matrix1000 FrSky 1 Mar 27, 2018 11:48 PM
Help! Taranis X9D+ (EU) and FrSky R-XSR binding issues 1Smug_Bastard Multirotor Drone Electronics 5 Jan 18, 2018 02:38 AM