Thread Tools
Jun 20, 2018, 06:08 PM
Registered User
Thread OP

How to charge LiFe rx batt that has no balance cable


I have an iMax B6 AC v.2 charger. I recently bought a couple Reedy '307, 250 mAh LiFe rx batteries that do not have balance cables. I have tried to charge the batteries on both the LiFe Charge (not Balance Charge) and Fast Charge programs and always get the error message "Balance Connect Error." My Charger manual says ther is also an error message "No Balance Cable Detected" and "... if your battery comes without balance lead, push enter to start." Pushing enter with the Balance Connect Error does not start the charging program. I think I'm getting the wrong error message, but have no idea how to get the right one. Does anybody have any ideas, short of buying a different charger, how I can charge these batteries? Neither SkyRC nor Reedy have responded to my inquiries to them.i

Thanks for any help you can offer.

Gnichopd
Sign up now
to remove ads between posts
Jun 20, 2018, 07:24 PM
Bombs away! Err...landing
Ira NZ's Avatar
Quote:
Originally Posted by Gnichopd
Pushing enter with the Balance Connect Error does not start the charging program. I think I'm getting the wrong error message,
What does it do when you push enter?

And you've tried pushing and holding for a few seconds?
Jun 20, 2018, 08:32 PM
Registered User
Thread OP
Pushing enter does nothing. The error message remains, but nothing else happens. I've tried pressing long, short, and repeatedly. Generally this charger requires a 3 second push on enter to start a charging program; I have tried that too. No difference. Nothing happens.
Jun 21, 2018, 03:37 PM
Registered User
Zeeb's Avatar
Are you trying to hook up the brown/orange lead to charge? It's possible that the battery has a balance circuit in the pack. Normally, if you have brown/orange wires, the brown will be ground.
Jun 22, 2018, 03:58 PM
Registered User
Thread OP
PROBLEM SOLVED!

Damian Liu of SkyRC followed up on the question I left on their site. First, he said to go into System Settings in the charger and "Load Factory Set". See pp. 08, 17, Owners Manual. When that did not work, he said to go back into System Settings and progress through the menu to "Bal. Connection" and manually turn it off. You will then get a warning that it is off. None of this appears in my user manual, but the Bal. Connection menu item is immediate after the Load Factory Set referred to above. After successfully charging the battery, I disconnected it and powered down the charger, and then restarted it and returned to the Bal. Connection in System Setting; it was still off. So, I you need to do this, be sure to turn the Bal. Connection back on before doing a balance charge.
Jun 22, 2018, 04:01 PM
Registered User
Thread OP
Many thanks to Damian Liu for sticking with me and solving this problem. Well done, Damian!


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
How to charge charge Fatshark pack with iCharger 4010 duo with only the balance plug. Turbinetester Batteries and Chargers 9 Apr 08, 2016 02:33 AM
Idea No Factory Prop Balancer > How to Balance Props? supercellkid Beginner Multirotor Drones 4 Jan 22, 2016 12:43 AM
Charging Li ion (18650) with no balance cables? TheNiceGuy Batteries and Chargers 1 Apr 23, 2015 05:53 PM