Thread Tools
Dec 08, 2004, 09:14 PM
Registered User

problem using esc with hitec 5x


I am trying to use a phoenix 35 brushless esc with my hitec 5x and 555 reciever. I cannot get the esc to arm, yet it works ok with a standard futaba radio and receiver.
I tried adjusting the end points to +-100 and +-125 , reversing the servo direction, and 0 trim, but I cannot get the esc to arm.
Any suggestions?
Sign up now
to remove ads between posts
Dec 09, 2004, 11:26 AM
Hitec / Multiplex USA
Hi ECOFLIGHT,

Try setting both endpoints to 125% and have the trim at zero. Then make sure the stick is in the down postion when you turn the ESC on. It should arm now.

Tony Ohm
Hitec / Multiplex USA
Dec 09, 2004, 04:38 PM
Registered User
I tried that, but it still won't arm. Bad esc?
Dec 09, 2004, 04:59 PM
Hitec / Multiplex USA
What mode are you in? Is it ACRO or GLIDEACRO?
Dec 09, 2004, 05:05 PM
Hitec / Multiplex USA
What mode are you in? Is it ACRO or GLIDEACRO?
Dec 10, 2004, 01:11 PM
Registered User
Quote:
Originally Posted by TOhm
What mode are you in? Is it ACRO or GLIDEACRO?
ACRO MODE!
Dec 10, 2004, 03:39 PM
Hitec / Multiplex USA
Sorry about the double post.

Have you tried to operate channel 3 with a servo? Does the servo seem to have full range? I'm hesitant to say the ESC is bad since it does work with your Futaba.
Dec 12, 2004, 02:16 PM
Registered User
Quote:
Originally Posted by TOhm
Sorry about the double post.

Have you tried to operate channel 3 with a servo? Does the servo seem to have full range? I'm hesitant to say the ESC is bad since it does work with your Futaba.

I tried channel 3 with servo and I got nothing.
Must be a bad reciever!
Dec 12, 2004, 05:29 PM
Havin FUN
Gonnacrash's Avatar
Eco.
Change TX to different model, if its programmed for model 1, go to model 2 or 3 and see if problem still there... Just a thought.
Don-Basehor, Ks
Dec 13, 2004, 06:16 PM
Hitec service
BRENDAN LUGO's Avatar
If your radio is set to mode 1 that could also be causing your problem. Double check to make sure the radio is set to the proper mode. This can be found on page 11 part B of your manual.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion using ESC with BEC cyclonite Power Systems 16 Nov 19, 2006 03:27 AM
Using NiMHs with Hitec Eclipse 7 Krason Hitec/Multiplex USA 2 Nov 17, 2003 12:29 PM
Help Needed: Can I plug-in a receiver battery while using a ESC with a BEC? CheeseWing Parkflyers 3 Sep 26, 2003 07:22 PM
CC Dragon 35 ESC with Hitec 3SS FM JeffD Electric Plane Talk 0 Jan 28, 2002 07:14 PM
Training with Hitec Flash 4/5X WAR Beginner Training Area (Aircraft-Electric) 2 Jul 27, 2001 12:02 AM