Thread Tools
Apr 19, 2018, 12:36 PM
Registered User
Kfab1202's Avatar
Thread OP
Discussion

Horus X10S, OpenTX 2.2.1, SxR Lua script issues


I'm trying to get my S8R working with my X10S.

I've searched and searched the forums but can't find anything that seems to be applicable. There is a lot of info on the SxR series, quite a few issues with getting them to work correctly and such but I find nothing along the line of what my issue is.

X10S is running OpenTX 2.2.1

I've downloaded and installed the Lua scripts (https://www.frsky-rc.com/s8r/ - firmware version 171018) that are supposed to fix everything (S8R_FCC_171018.frk & S8R_LBT_20171018.frk) and it works "better" than before they were installed but it's still no bueno.

Prior to the installation of these two scripts if I run SxR.lua I get an error message of:
/SxR/SxR.lua:270
bad argument#1 to 'open' (string expect
and then it gets truncated on the screen so what the full message says is a mystery to me.

Quick run thru of my steps:
Sys button
page forward to the SD-HC Card
Select the SxR option
Run SxR_Calibrate.lua - does this successfully and I've done both run thru this and not run thru this as I've tried to make things work. Doesn't make a difference regardless.
(with patch installed) Run SxR.lua and when I execute it, it pops up page 1 of 2 showing Wing Type and Mounting type. The issue is that the little boxes with the three hash marks don't do squat. It won't let me do anything other than toggle between the two selections. I can't enter either of the options.

I can move to page 2 of the selections and it shows SxR functions, quick mode, Ch5 mode, etc., etc. but I cannot enter any of them. Can toggle among them but cannot select/enter

I've tried reloading the scripts, loading the other patches and fixes and such all with the same results. "Here's the stuff you want, but you can't play". Drats.

So what am I missing? What did I do wrong?

I'd like to get this receiver up and running - have an Avios BushMule showing up in the next day or so and would like to use the (correctly working) S8R in it.

Thanks in advance for any help I may receive.
Sign up now
to remove ads between posts
Apr 21, 2018, 10:38 PM
Registered User
Kfab1202's Avatar
Thread OP
Beuller?
Hello?
No thoughts at all?
Apr 22, 2018, 07:50 AM
Registered User
Jet_Flyer's Avatar
Don't know if this helps any, but with FrOS the SXR configuration feature will not function until the receiver is bound and active with the X10S.

Mike
Apr 23, 2018, 11:18 AM
Registered User
Kfab1202's Avatar
Thread OP
Quote:
Originally Posted by Jet_Flyer View Post
Don't know if this helps any, but with FrOS the SXR configuration feature will not function until the receiver is bound and active with the X10S.

Mike
Receiver has been bound and is active - works just fine as a receiver on the six channels I set up to experiment with. It's the radio that's having issues running the lua script (or so it appears).

I appreciate the reply.
Aug 24, 2018, 04:26 AM
Registered User
I have exactly the same problem.
Did you fix it?

Marco
Sep 15, 2018, 10:10 AM
Registered User
I'm having a similar issue with the calibration and setup luas working intermittently, the calibration particularly driving me nuts as it keeps looping on the second or third orientation in. Press enter and instead of changing to the next receiver position it stays on the same stage. I've had this happen on three freshly bound receivers in and out of models, I've reloaded the latest S6R/S8R firmware, I've tried fresh batteries, I've charged the transmitter (X12S) - I'm out of ideas! It did work once for an S6R but then one of the stupid thin aerials broke so I swapped receivers for a new S8R, now I can't configure it!

I figured it out, I'm impatient. The receivers show an orange LED flash when you press enter, but that first long flash isn't to say that it's saved that orientation. There are 4 more shorter flashes that you need to wait for and when I held the model in position until after these 4 short flashes it all worked ok. Where do I apply to get the wasted day back?
Last edited by BrumBob; Sep 15, 2018 at 03:01 PM.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion L/D and Sink rate LUA script for OpenTx FabFlight Sailplane Talk 3 Mar 21, 2021 02:39 PM
Discussion Qx7 SXR setup using LUA script Kevalino Radios 1 Feb 16, 2018 06:02 AM
Question OpenTx Horus LUA Scripts sten1860 Multirotor Drone Electronics 1 Nov 05, 2017 08:13 AM
Question OpenTx Horus LUA Scripts sten1860 Radios 0 Oct 31, 2017 04:11 AM
Discussion OpenTx Lua Script Lap Timer RcRav Radios 0 Jan 10, 2017 02:08 PM