Thread Tools
Apr 08, 2018, 02:45 AM
Slow builder
_AL_'s Avatar
Thread OP
Discussion

D8RII plus & D6FR sudden range issues


A couple of months ago I dusted off my old Pitts Python after a 12 or so month period of not flying it.
As the last flight had been uneventful I checked the controls & launched into the wind. About 5 seconds after take off & got the RSSI warning of low signal so turned back for an unplanned but straight forward landing.
Tests at home showed the D6FR receiver was losing signal after around 10 paces in range mode. I fitted a new RX which fixed the issue & I've flown it several times since with no issues.
I put it down to a dud receiver despite 2 odd years of flying with no issues prior.

Today I took my Bixler to the field which is flown regularly. D8RII Plus RX.
I took off & made a gentle turn to come back across the field when I noticed the motor cut out for a second & then came back to life. I shut it down & glided in for a landing thinking a motor or ESC issue.
Instead, I've found the same thing as the Pitts. In range mode I get 5 paces away before control gets choppy & at 10 paces it's in failsafe.

I use a Taranis x9 rev B but tested with an X7 this afternoon with the same results so it's not a TX issue.

Neither aircraft has been crashed prior to this & I can't find any reason why 2 different RX would suddenly go bad. Both are electric so I wouldn't think vibration would be an issue.
I've taken both RX out of the case & can't see any signs of heat or corrosion. I wiggled the antennas around to see if there was a connection issue but no change.
Has anyone experienced similar issues? Any suggestions as to the cause?
Replacing an RX is not the end of the world but not knowing the cause is concerning given it's happened twice now.
Thanks.

Al
Sign up now
to remove ads between posts
Apr 10, 2018, 02:55 AM
Slow builder
_AL_'s Avatar
Thread OP
So no one has had a similar issues?
Apr 14, 2018, 01:14 PM
mdv
mdv
Registered User
I am seeing this now with XM (which probably has short range anyway) and D6FR using XJT in the back of a Taranis. I have used the D6FR years ago with good results. I haven't tried another transmitter yet. Sorry I can't help.
Jul 12, 2018, 02:25 PM
Registered User
Quote:
Originally Posted by _AL_ View Post
So no one has had a similar issues?
I just had my d6fr quit on me after a number of years. I had it in storage for two weeks after a successful flight and the next time out my plane kept losing signal and nosedived. A range test proved I couldn't get more than a yard away in range test mode. A second D6fr I have range tested to 35 yards with the same conditions.

I just found another post which hypothesis; "LNA (low noise amplifier on the frontend chip) is destroyed by ESD." See this: https://www.rcgroups.com/forums/show...87&postcount=6
Last edited by ricknoon; Jul 12, 2018 at 03:54 PM.
Jul 13, 2018, 07:45 AM
Slow builder
_AL_'s Avatar
Thread OP
Interesting...

I replaced the aerials on the D6 with no improvement in range. I haven't tried the D8 as it doesn't look like that's the issue.
I've relegated both RX to bench test duty now but not knowing the cause is a worry. They work fine but lose connection at 10 paces in range check mode.

I've had Hitec, Futaba & Spektrum RX/ TX go bad but those simply died. I've never had them work but reduce range before.

Al
Sep 17, 2019, 08:55 PM
Registered User
Gregco10's Avatar
5My d6fr has the same issue. The transmitter started to complain while the plane was in the air and it actually lost signal. It was an epp wing so no biggie. Same as above 15 feet in range check and signal is lost.
Sep 19, 2019, 01:03 AM
Slow builder
_AL_'s Avatar
Thread OP
I've had a d6 & d8 do the same thing but no idea why.
The 40 odd other RX seem to be fine. Perhaps the are just Friday afternoon builds.

Al
Sep 19, 2019, 07:59 AM
Oh you pull BACK on the stick?
RingoVarr's Avatar
I just recently had the same with two brand new V8R4s. Certain areas in fields caused signal loss. Places that have never had dead zone issues before, with my Taranis and any other systems. Antennas were in the recommended positions. Weirdest thing. Made me lose trust in my system.
Sep 19, 2019, 09:48 AM
ErskyTx Developer
Mike Blandford's Avatar
For information, all these receivers use a LNA (Low Noise Amplifier) between the antennae and the RF chip. If that chip has failed, or no longer soldered, then you will see the loss of range described.

Mike
Sep 19, 2019, 05:37 PM
Registered User
Gregco10's Avatar
To be fair it was in a wing that has taken more than a few rough treatments. I have another in a sport plane with an easier life that is about the same age and still going good.
Sep 20, 2019, 08:16 PM
Slow builder
_AL_'s Avatar
Thread OP
Quote:
Originally Posted by Mike Blandford
For information, all these receivers use a LNA (Low Noise Amplifier) between the antennae and the RF chip. If that chip has failed, or no longer soldered, then you will see the loss of range described.

Mike
Interesting. I wonder if re flowing the solder might fix it then.
Both mine that failed had never been in a crash but nothing to say they didn't have bad solder joints.....


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Dx6i plus orangerx range issue? Or not? Clarksongli Multirotor Drone Talk 0 Feb 19, 2017 05:17 PM
Discussion Taranis plus range issues HeliOlly FrSky 0 Aug 07, 2016 07:40 AM
Discussion Frsky DJT & V8FRII & D8RII Plus mkes Radios 9 Mar 31, 2016 02:42 PM
Help! Frsky D8RII plus and Naze32 dlearnt Multirotor Drone Electronics 13 Feb 27, 2015 08:32 PM
Discussion Understanding STOCK FrSky telemetry (D8RII-plus) Conscious0ne Radios 3 Jul 12, 2014 05:24 AM