Thread Tools
This thread is privately moderated by StevenLawyer, who may elect to delete unwanted replies.
May 04, 2018, 09:18 AM
Registered User
Dear Steven,

Thank you very much for such great tutorial!

I had some problem in the step "STEP 6: Test Root with ADB"
When I type "adb shell" in the command prompt, it just showed "error: no devices/emulators found"
I put the ADB in drive E: and the Mavic Pro was connected to the computer with the previous root steps finished.
(There is also a problem in the hardware manager, the device "DJI" cannot be installed with error code 28)

Then I skipped the ADB related steps, and couldn't find the parameters in DJI assistant such as "g_config_flying_limit_height_limit_enabled"
Does this relate to the previous ADB step ?

Thank you very much for the help!

Wah!
Last edited by Wah!; May 04, 2018 at 10:46 AM.
Sign up now
to remove ads between posts
May 05, 2018, 12:31 PM
Registered User
I figure out he missing parameters are from older firmware, I am trying to flash to FW700...

But I still get ADB error after reboot my PC.
May 07, 2018, 04:49 AM
Registered User

Install mod on crystalsky


Hi Steven, could I know how to install DJI Go v. 4.1.22-mod.apk on crystalsky? I tried to install but not successful. Since my drone is P4P and I heard DJI Go v4122-mod is support P4P. Due to I was sucessfullly installed the DJI_Go_Boost_V2 .apk on my crystalsky, but this version not support P4P. Now only one of the way to improve my drone.
Anyway u do a great job!!THANKS
May 08, 2018, 03:06 AM
Registered User
Hi Steven

Very detailed how-to tutorial. Many thanks.

One question, how to make go 4.01.22 work side by side with latest Dji Go app like DJI Go Boost version? I have problem when install it on Crystalsky screen.

Thanks again.
May 15, 2018, 11:31 PM
Registered User
Does anybody have the FCC Boost running on a CrystalSky monitor?
I installed the GoBoost app but there is no "Files" Folder to put the Config files in
May 16, 2018, 01:24 AM
Registered User
Quote:
Originally Posted by TheNavigator818
Does anybody have the FCC Boost running on a CrystalSky monitor?
I installed the GoBoost app but there is no "Files" Folder to put the Config files in
You have to run the GoBoost app once then the app will create a folder as far as I experienced.
May 23, 2018, 07:46 PM

Mavic build date 15 Sept 2017


My Mavic has the same date as the how to says the cutoff was for SD card inside and mine did not have one but it did downgrade to 700 but when I tried to fly it said cannot takeoff and the error was SD card so the newer ones will downgrade but will not fly without the internal SD. It just had me thinking I had a problem till I opened it up.. May help out another guy. Also the unit has 2.3 watts out with the boost app measured with the immersion RF Meter.
Great Job this is awsome.
May 24, 2018, 11:22 PM
Registered User
Hello, and what changes have been made to 4.1.3 Boost other than the package name change.

how to check up picks up the 4.1.22 boost settings
Last edited by denn73; May 24, 2018 at 11:52 PM.
May 25, 2018, 09:15 AM
YANN AIRWOLF YP

Debug mavic


hi Seven
I saw your post and I am interested in the FFC BOOST; I live in COTE D'IVOIRE in Africa and I do not know the regulation here (like CE or like USA !!)
my MP is in version 1.03.700 with modified flight and battery settings (see photos).
what should I do now just to install the FFC BOOST?
thank you,
yann
May 27, 2018, 10:20 PM
Registered User
the author happens?
May 28, 2018, 11:30 AM
Anyone having problems with 4.1.22 APK loading. I can load boost apk but not the 4.1.22 as it just says not loaded??
Jun 08, 2018, 11:53 AM
Registered User
Among the many threads about this topic this one seems the best detailed and tidy.

I need to read it slowly but I still have a question.

You (and most other threads) suggest to remove modules 305, 306 and 905 from the .700 firmware.
But you don't say anything about removing modules from the latest firmware when upgrading (1.4.xxxx).

Here
https://mavicpilots.com/threads/mavi...wngrade.27531/
it says we nee to remove the ESC modules 1200, 1201, 1202, 1203.
Should we or not?

Some other threads advise not to upgrade beyond 1.4.000.
Is the problem solved?
I think it was related with not being able to downgrade again.
Would I need it any time to downgrade to .700?
Does "DUMLRacer.jar" solve any possible problem? and then I shouldn't to worry?

Thanks
Jun 08, 2018, 11:59 AM
Registered User
How serious is the "well-documented in connection with using the FW 700 controllers with the newer firmware versions (mixed modding)--namely, that precision return to home may be off by a few feet, instead of the normal tolerance of a few inches." problem?
Can it be solved?
Jun 08, 2018, 03:46 PM
Registered User
I don't understand something.
Why do we need to root and remove the NFS related files?
Isn't enough to modify the "Remove No Fly Zone restrictons" from DJI assistant?
Jun 09, 2018, 05:53 AM
Registered User
How can I force FCC 1W?
I've read than 1.5W could be too much and damage our RC.
0.4W seems to low.
1W would provide better range without taking our devices to the limit.

I'd like to use my drone on the 2.57GHz band and 1W.

Are there several ways to modify these settings?
The one I've seen is adding a file called dji.configs_force_fcc_and_25 in the folder \Android\data\dji.go.v4\files

Using that file forces you to use only thoses settings or it just enables that option among others and you can change from one to other?


Quick Reply
Message:
Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion DJI SDK Apps - Spark-P3-P4P-Mavic Pro-Air-Pro2-Inspire1 & 2-M100-M200-M600-A3-N3 MultiRotR Multirotor Drone Talk 2234 May 19, 2020 07:59 PM
Discussion Spektrum Vario Query with latest DX9 1.11 firmware colonel.uk Radios 11 Jan 12, 2017 06:32 AM
Help! Updated to latest Firmware V. 3.1.44 but no luck in running. BobsQuad Aerial Photography 21 Oct 05, 2011 05:23 AM