Thread Tools
Jan 25, 2018, 10:52 PM
Registered User
Discussion

Multiplexe evo FW upgrade


i just got my Evo back from Hitec with FW 2.62. I had left the XPS 2.4GHz module in there.
unfortunately when i tried to bind it to my receiver no lights come on the XPS module. i pulled off the connector to the evo and measured the voltage between the red and blue wire to by around 7.2V, which is same as my Evo battery voltage, what am i missing. all worked before i did send it in.
i also realize that my connector from the XPS module has 4 wires - one additional yellow one, which is not shown in the XPS manual.
thanks Erhard
Sign up now
to remove ads between posts
Jan 25, 2018, 11:02 PM
You have the latest hardware (which has the extra yellow wire). The module should just work as long as it has power. Does the EVO actually power up?
Jan 25, 2018, 11:12 PM
Registered User
wow thanks Jim for the wonderful quick reply.
yes Evo powers up and seems to work as usual - i mean the menus etc. just no light on on the XPS module. i unplugged and reseated the plug back in but no change

just checked again the voltage directly on the top of the plug and it reads 7.2V. still no LED on. also teh binding process does not work. could it be the module was destroyed when the flashed the new FW and the module was left inside?
Last edited by schrecke; Jan 26, 2018 at 12:57 AM.
Jan 26, 2018, 10:36 AM
Registered User
Hi Jim or others, any suggestion or should i just assume module is dead and buy a new one. not great but what can do in the end i want to fly
Jan 26, 2018, 12:33 PM
Try holding down the button on the module WHILE powering on the EVO. Keep holding the button to see if the LED eventually turns on. If it does, then the problem is there is no signal from the EVO to the module (check the blue wire). If there is no LED then the XtremeLink module is has no power or is defective. We offer a lifetime warranty on our electronics, so you don't have to buy a new module. You would just need to pay for the return shipping. See the link at the top of the home page of our website for details.
Jan 26, 2018, 09:28 PM
Registered User
thanks Jim
i described my problem to Hitec and here i their response

"Sorry to hear about the issues. From what I understand (now,) there is a update (mod) that XPS will have to do for the new firmware. So contact them and they will be able to help you."

does this makes any sense to you?
anyway i tried your above procedure but still no LED. look like i need to send it in
should i scope the blue wire?

thanks Erhard
Jan 26, 2018, 09:29 PM
Registered User
Jim forgot to mention. i do have the XDP controller, could i use that if an update is needed. but of the LED is not coming on the module is not working i guess.
Jan 26, 2018, 10:13 PM
The "mod" that Hitec is referring to is the extra yellow wire, which you already have.

If the LED is not coming on when you hold the button while powering on the EVO, then either there is no power to the module or the module is bad. You might want to check to see if there is power to the module through the cable.
Jan 26, 2018, 10:26 PM
Registered User
i did already check power - same voltage of 7.2V as the evo indicates is on the black and read wire on top of the connector to the XPS module. so power should be there
Jan 26, 2018, 11:33 PM
Well, sounds like someone/something killed the module. It needs to come back for replacement. See the link at the top of our home page for details on getting things repaired.
Jan 26, 2018, 11:38 PM
Registered User
and i thought i can fly this weekend with that transmitter - oh well i'll send it off tomorrow, thanks
Jan 26, 2018, 11:46 PM
Registered User
i got the multiplex data cable and from i was reading on that forum i can upgrade to FW v3.5 and the functioning XPS module will work?
Jan 27, 2018, 10:51 AM
The module will work with ANY firmware version automatically. So, it wouldn't matter if you had v1.0 or v3.5, the LED would come on and the module would work. The extra yellow wire is required only for v3.0 and later EVO firmware.

V3.0 and later firmware does give you M-Link compatibility. Which means that an EVO12 will now magically have 16 channels (instead of 12) and you will have telemetry info available in the display, along with the ability to do the range check and binding from the button on the front of the EVO instead of having to open it up each time.
Jan 27, 2018, 04:20 PM
Registered User
Jim
oh that is great. is there a description available which button then to use on the evo 12? for the other 4 channels i still need some additional buttons or sticks - are these binary or full proportional channels? i did send out my module to XPS today. do you think they could have damaged the module by reflashing the FW? it is too weird to be a coincidence
anyway thanks for your very responsible suport and have a nice weekend
Jan 27, 2018, 06:28 PM
You need to download the M-Link manual from Hitec. It describes the M-Link system and what buttons do what. You have 16 servos now in the servo assignment menu. No, you can't damage the module by flashing the v2.62 firmware on it. We have had a LOT of customers have their EVO's upgraded while our module was installed.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Multiplex Evo 9 Upgrade Doug_J Xtreme Power Systems 18 Sep 09, 2017 10:09 PM
Discussion MultipleX EVO 9 and Spectra Module firmware upgrade sportflyer Hitec/Multiplex USA 0 Sep 16, 2014 02:27 PM
Help! Multiplex Launcher Installation Runtime Errors with Upgraded EVO TX dbflier Hitec/Multiplex USA 0 Dec 24, 2011 04:16 PM
Discussion Any advice for upgrading Multiplex Royal EVO 12 to 2.4 with Weatronics? yyz Scale Sailplanes 18 Dec 16, 2010 11:58 PM
Discussion Multiplex Evo - worth the upgrade to 2.4 ssphoenix Radios 10 Feb 06, 2008 09:53 AM