DPL-8 And Bump Controller - "Lost Data Link" - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Dec 07, 2017, 11:29 AM
Registered User
Discussion

DPL-8 And Bump Controller - "Lost Data Link"


Hello,
Have a new DPL-8 with a Bump Controller that was previously used on a PL-8.
Setup works great, but it acts weird at times with strange screen activity and many (most) times after starting a charge on side 2 it will turn red and show 'lost data link'. The screen usually freezes before this and data does not update.

Any ideas?
Sign up now
to remove ads between posts
Apr 07, 2018, 02:42 AM
Tragic case
davidleitch's Avatar
I just bought a new dual PowerLab 8 touch with integrated bump controller and right now I dislike it.

I get the “lost data link” error message on channel 1 regularly.

It won’t charge my brand new 12v 40 amp hour life field batteries giving me a bad cell count message. Yet the same battery charges fine on a cellpro 10xp as a 4s unbalanced a123 pack.

Maybe I’m new to it but it’s bugging the heck out of me. At this rate I’m going back to the less wonderful no longer in production but works every time thunderpower dual charger.
Apr 07, 2018, 09:11 AM
Registered User
JMynes's Avatar
Just a shot in the dark, but maybe some noise filtering would help?
Apr 08, 2018, 05:14 AM
Tragic case
davidleitch's Avatar
Can’t see why there should be much noise from a DC battery power supply.

Same thing happened at the field today. 4s 5000 pack gets the lost data link on channel 1 but charged on channel 2. I’ll do some more tests as time permits.
Apr 09, 2018, 06:39 PM
President, FMA, Inc.
Tim Marks's Avatar

Error 55


Hi Everybody:

I wanted readers of this thread to know that we are aware of the "Lost Data Link" issue in the PowerLab 8 Touch and Dual PowerLab 8 Touch models and we are working diligently to find the best solution at this time. The issue is related to input supply V and/or charge current settings. As a workaround until we have a solution available, you may find that reducing your input supply V to 24VDC or lower may help.

Sincerely,

Tim Marks
President
FMA, Inc.
Revolectrix Partner
Apr 12, 2018, 07:07 AM
Registered User
winter1's Avatar
I have the same problem with DPL8T. I hope you can manage it as soon as possible.
Mostly the first channel. Occasionally, it skips data views for example (CellV-CelIR)
A yellow alert screen will appear and then red (code - 55, Lost Data Link)
Attached Images
*** winter ***


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! DPL 8 and NiCad charge problems steve51 FMA Direct 4 Feb 15, 2017 09:45 AM
Help! New DPL 8x2 and Bump Controller user with a question chorchie FMA Direct 5 Jun 15, 2016 09:28 PM
Discussion DJI New A2 Flight Controller and DJI 900 MHZ Data Link dulanto Multirotor Drone Electronics 1 Feb 01, 2014 03:31 AM