New X10+ coming... - Page 5 - RC Groups
Thread Tools
Feb 24, 2018, 07:04 PM
Registered User
MrMPX's Avatar
Dumb Question just got my new RFU and new super cool handy dandy 10+ board,
MPX Profi 4000 TX PPM Uni Mode
RFU bound HAD green light on both RFU and 10+
10ch Board Green light
All Ch. work

After a few cycles why is the RFU led red now not green?
everything still works.
Sign up now
to remove ads between posts
Feb 24, 2018, 11:05 PM
It's not red, it's orange - as in you have a low voltage problem!
Feb 25, 2018, 02:35 PM
Registered User
MrMPX's Avatar
Thanks Jim!!! Used a battery that has been sitting around for set up. Been in surgery the last two days will get a fully charged pack.
Feb 25, 2018, 08:17 PM
Registered User
MrMPX's Avatar
Put in a fresh charged pack, now blinking (Orange / red) all is working. Brand New Multiplex Heron RR plane and ESC. Weird. I know it has to be something I did. All servos snappy like a fresh pack would be.
Feb 25, 2018, 08:21 PM
Blinking means that the receiver rebooted... as in you removed power to it and plugged it back in without the transmitter being turned off. Orange means that the voltage dropped below 4.5v. What are you powering this with? If you are power it from a BEC that is built into a ESC, then that is not too shocking. BEC's just don't provide enough current for most applications.
Feb 25, 2018, 08:40 PM
Registered User
MrMPX's Avatar
Just tried a fresh charged 4 cell pack same result.
The ESC is just your normal MPX ESC.
Feb 25, 2018, 09:43 PM
What pack is this? Are you using a BEC that is built into the ESC or a separate 4 cell NiMH or NiCd pack? Is the LED green until you move a servo?
Feb 25, 2018, 10:05 PM
Registered User
MrMPX's Avatar
To test I used a very fresh charged 4 cell a Nimh. Direct to the 10+ not through the esc. Was green until I wiggled the sticks a second. Also tried fresh charged flightbpacks through esc. Same results.
Feb 26, 2018, 01:20 AM
I see in your picture that the X10+'s LED is green. Does it stay green or does it change too? If the voltage drops, the low voltage warning indicator changes the LED color.
Feb 26, 2018, 08:47 AM
Registered User
MrMPX's Avatar
Remains bright solid green when powered with the ESC or when powered by receiver pack only no ESC.
Receiver goes green fir a few seconds when power on then changes.

Note I have tried 5 cell rx pack, 4 cell rx pack to power system. I have tried three diffrent flight packs same results. All packs fully charged.
Feb 26, 2018, 12:04 PM
Try your other RFU. The X10+ would also be turning yellow if the voltage dropped too low. So, either the RFU's voltage detection is too sensitive or there is an issue with the cable that connects the X10+ the RFU.
Feb 26, 2018, 12:08 PM
Registered User
MrMPX's Avatar
Will do. Thanks
Feb 26, 2018, 08:56 PM
Registered User
MrMPX's Avatar
Got home did as you said... Green, green for 30 minutes.

For comparison purposes I put the other RFU back in the plane with the same battery pack that I had been using with green - green and I got, green from the 10+ and Orange on the RFU. Then I switched back to the other RFU and green - green so you are right in your assumption the one RFU is set too voltage sensitivere a field update I can do or need to send it back?
Last edited by MrMPX; Feb 26, 2018 at 09:04 PM.
Feb 26, 2018, 09:25 PM
Unfortunately, that is a hardware issue so it has to come back to us.
Feb 26, 2018, 09:30 PM
Registered User
MrMPX's Avatar
No worries.. Ordered another one today and this one on the way back... Thanks for the great service!


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion FrSky - New - Horus X10 and X10S Jet_Flyer Radios 8781 Jul 14, 2018 02:35 PM
News Bro RC Bodyboarder Coming 2018 Jason Cole Dock Talk 14 Jul 10, 2018 07:49 PM
Discussion New multicoper regulations in Germany (soon to come) CyberCrash Model Aircraft & Drone Advocacy 44 Apr 11, 2017 03:10 PM