GT1000 Unable to update firmware - RevoFong You there? - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Nov 21, 2017, 05:00 PM
I have no friends
Discussion

GT1000 Unable to update firmware - RevoFong You there?


I have a new GT1000 charger that isn't recognized by the firmware update utility so I am unable to update the firmware.

I have tried following the instructions over and over again with no success. My GT1200 will update just fine with the GT1200 utility, same USB cable, and USB port. Also tried reloading the driver and re-downloading the GT1000 utility.

Tried different cable, different USB port, everything. Contacted Revolectrix and Howard said he hadn't seen it before and would need to get in touch with Fong to find out what is going on. The GT1000 utility is set to Auto for the COM port and there is no other port listed unlike the GT1200 utility when I update that charger which has COM8 in the list.

Has anyone else had this?

A bit annoyed by this since this GT1000 is brand new and a replacement for the GTEight that died after only two months of owning it.
Sign up now
to remove ads between posts
Nov 21, 2017, 08:17 PM
Registered User
Hi,
In Windows Device Manager, do you see the COM port with the charger connected and powered up? Try plugging /unplugging the USB cable a few times to see if Windows is able to recognize the charger. If the COM port is not listed and no "Un-recognized Devices" is shown, then the USB circuit in the charger could be faulty. If this is the case, I would suggest you try another USB cable just to be sure before you contact Howard for an exchange.
Nov 21, 2017, 08:44 PM
I have no friends
Nothing shows up in device manager. It's like the charger isn't even connected. My GT 1200 works just fine and shows up in device manager like you are saying but the GT 1000 doesn't seem to exist.

I've tried multiple USB cables multiple computers multiple USB ports it will not see the GT 1000.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion GT1000 firmware update not working kenelder FMA Direct 10 Sep 23, 2017 03:07 AM
Question Unable to update REX10 firmware exfokkerflyer Jeti USA 2 Jan 21, 2017 06:12 PM
Discussion Flash firmware for internal modules for Taranis X9D Plus FIRMWARE UPDATE ERROR baptist FrSky 2 Jan 25, 2016 04:58 AM
Mini-HowTo Update Firmware for Devo TX - Import/Export Devo TX Models - Update Devo RX Firmware Tom Z Micro Helis 22 Jun 28, 2015 01:20 AM
Help! Firmware update error with OSD pro ONLY Data Logger and Gardian firmware update works whosthebaddest Eagle Tree Systems 10 Mar 17, 2012 06:26 AM