A9x voltage telemetry problem - RC Groups
Thread Tools
Nov 16, 2017, 09:39 PM
Registered User
Discussion

A9x voltage telemetry problem


I'm having trouble with the voltage sensor on my HTS-SS. I'm using an A9x with an optima SL receiver. I bought the optima SL specifically so I could use the sensor station and get telemetry for the 12s flight battery and the 2s receiver battery at the same time.

The red twisted pair wire with the alligator clip is connected to the positive side of my 12s battery.

My heli has an opto isolated esc and a separate 2s battery to power the receiver and servos. This voltage appears on the screen as battery voltage, or the voltage directly connected to the servo bus. About 8v on a fresh charge.

The voltage sensor on the sensor station doesn't register a voltage. My guess is that there is no ground connection between between the sensor station and my main flight battery. The voltage sensor is open circuit.

Am I correct in assuming this? Is there any safe way to fix it?
Sign up now
to remove ads between posts
Nov 17, 2017, 03:12 PM
Hitec/Multiplex USA
MikeMayberry's Avatar
That is correct... the circuit needs to be grounded which the Opto ESC is preventing. The best thing to do is tap off the negative battery lead and attach it to the negative power lead going into the sensor station. This will ground the system and not effect the ESC.

Mike.
Nov 18, 2017, 08:35 PM
Registered User
That worked nicely, thanks.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Hitec A9X with USB interface - more than 4 channels possible? BernardW Radios 4 Oct 11, 2016 05:26 PM
Discussion clone apm 2.8 voltage regulator/i2c voltage problem claudiu.toby Multirotor Drone Electronics 0 Mar 22, 2016 01:19 PM
Discussion Does the FrSky FLVSS voltage meter/telemetry work with LiFePO4 batts? GAZ082 Batteries and Chargers 1 Oct 09, 2015 01:08 AM
Discussion Quanum battery voltage telemetry - and 'voltage under load' question ... JJJNYC Batteries and Chargers 51 Oct 22, 2014 12:55 PM
Help! X6R telemetry incorrect voltage problem icedomin8r FrSky 1 Feb 25, 2014 12:07 PM