Flashed SPRACINGF3 firmware to Omnibus - Whoops! - RC Groups
Thread Tools
Nov 10, 2017, 07:53 PM
Registered User
Discussion

Flashed SPRACINGF3 firmware to Omnibus - Whoops!


Good evening,

don't ask me how, but in short: 2 boards in front of me, one SPRACINGF3, other Omnibus AIO, wanted to flash both on to BF 3.2.1, and mixed up the firmwares. After flashing successfully (interestingly), my Omnibus now does not connect any more to the computer. No green light in bootmode, no response on the PC. When connecting the battery, it does not complete ESC boot sequence; then only a red light appears. Still no connection to the computer.

Did I just brick my FC?

Thanks, best, Phipo
Sign up now
to remove ads between posts
Nov 10, 2017, 09:46 PM
Don't call it a drone!
flyandride's Avatar
I flashed the wrong firmware once. The boot pads had to be shorted to connect for a flash to the correct firmware. Once the board had the correct firmware, it worked fine.
Nov 11, 2017, 09:35 AM
Registered User
Yes - you have to force the board into BootLoader mode and reflash with the correct FW. This should work.
Nov 11, 2017, 11:23 AM
Registered User
Solved: While i could not force the board into bootloader by pressing the designated button - no response whatsoever - i could by jumping the two pads the button is soldered to. Dont ask me why, after putting on the right firmware, the button works again.

thanks for your input!
Nov 11, 2017, 11:24 AM
Registered User
Normally, you have to hold the boot button while plugging in the battery to get it into bootloader mode if the board is bricked. Glad you got it working again.
Nov 18, 2017, 06:20 PM
Registered User
thanks again!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Omnibus F4 Pro Firmware upd never finishes joel07 Beginner Multirotor Drones 2 Jun 14, 2017 08:34 AM
Discussion help needed with my cx 20 fatshark version after flashing firmware to version 149 idouglas Beginner Multirotor Drones 2 Nov 14, 2016 08:06 AM
Discussion Flash firmware for internal modules for Taranis X9D Plus FIRMWARE UPDATE ERROR baptist FrSky 2 Jan 25, 2016 04:58 AM
Question Minimosd firmware flash trouble maarset Beginner Multirotor Drones 5 Sep 16, 2015 08:44 PM