Lipo charged an buggy wont work!! - RC Groups
Thread Tools
Nov 10, 2017, 12:00 PM
Registered User
Discussion

Lipo charged an buggy wont work!!


Hi All - I have a Kyosho Half eight buggy with a quark 33 esc and a wraith brushless motor. I have a turnigy cell lipo that works fine and am having an issue with the 3 cell. The battery is fully chrged across all three cells however when I plug it in the car does nothing, as if the barrery is dead, no throttle or steering. Does anyone know why this could be, is the battery too large/powerful for the esc to recognize? Thanks
Sign up now
to remove ads between posts
Nov 10, 2017, 02:38 PM
Here to just enjoy the hobby
Rhea's Avatar
Maybe someone would know in the Cars forum.
https://www.rcgroups.com/cars-45/
Nov 10, 2017, 03:33 PM
Registered User
Your battery isn't the problem, the ESC can be powered by a 2 cell to 5 cell battery.
Nov 11, 2017, 07:00 PM
Frankenstein recycled packs
rampman's Avatar
OR a failed battery plug or he shorted it and did not tell us and has an OPEN within the pack.

Rick
Nov 11, 2017, 10:49 PM
Registered User
scottc39's Avatar
is this buggy new and never ran and you did not turn on the on/off switch for the esc.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Charging an individual cell on a multiple cell LiPo pack Zerts Batteries and Chargers 6 Jun 03, 2017 09:06 AM
Question Help *Lipo Charge board* will it work? BigNBeardy Batteries and Chargers 5 Apr 12, 2017 02:35 AM
Discussion LiPo charging inside an Ammo box partnerinflight Batteries and Chargers 21 Oct 17, 2016 09:30 AM
Discussion Charging an 8S lipo J328 Batteries and Chargers 3 Apr 13, 2016 07:54 PM
Discussion Reaktor 300x2 wont charge lipos, main port error and low volts? Other questions markm75 Batteries and Chargers 6 Nov 09, 2015 05:39 PM