Trouble connecting to Omnibus F3 in iNav - RC Groups
Thread Tools
Nov 09, 2017, 05:04 PM
Registered User
Help!

Trouble connecting to Omnibus F3 in iNav


Hi All,

Firstly, please be patient with me, I'm very new to all this!

I have an Omnibus F3 Flight Controller and I'm trying to use iNav to get started.

I've manage to flash the board ok - indicates this has been done successfully. But I keep getting "No configuration received within 10 seconds, communication failed"

I've down loaded the CP210x, STM and Zadig drivers but to no avail.

Tried two different PC but still no joy.


HELLLLLLPPPPP!

I've tried
Sign up now
to remove ads between posts
Nov 09, 2017, 05:54 PM
Registered User
Omnibus F3 isn't supported on iNav, but that's a different story.

The configurator for all of the flavors is kind of finicky, in my experience. Try variations of closing out of the Configurator, with the USB cable connected, then launching the Configurator; or launching Configurator and then attaching the USB cable; with autoconnect selected; without autoconnect selected.... You'll find the pattern eventually. You get what you pay for


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product OMNIBUS AIO F3 and F4 and clones (also FLIP 32 - F3 - OMNIBUS ) sevet Mini Multirotor Drones 783 Yesterday 11:44 PM
Help! Tilt-rotor-setup in INAV with Omnibus F4 Pro V3 AlexM82 Multirotor Drone Electronics 6 Sep 19, 2017 04:12 PM
Discussion Racerstar 4 in 1 ESC w/F3 - OMNIBUS V2 - 130MM Questions rcmark127 Beginner Multirotor Drones 6 May 18, 2017 05:49 PM
Help! INAV trouble - no stick movements showing mapsurfer New Forum Requests 0 Apr 28, 2017 01:02 PM