MultiWii General Help and Questions - First time building Quad - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Nov 07, 2017, 01:14 AM
Registered User
Discussion

MultiWii General Help and Questions - First time building Quad


Hello, quick introduction since this is my first post:

Currently an electrical engineering student who is wanting to build a quad-rotor drone for my school project. I have had no prior experience with controllers, Arduino, etc, so excuse my ignorance. I have been trying to figure things out myself but there aren't a lot of resources out there.

This is my first time using a flight controller and Arduino, and am wanting to make sure everything I'm doing is moving in the right direction.

Some technical specs:
Using ATMEGA2560 Processor
Using the Witespy EZ3.0 Pro Board with no GPS Option
Running Windows 10 x64
Don't know what MW firmware my board is using but it's on a dropbox here on my product page:
https://www.dropbox.com/sh/tt3pa4tzdq7wif5/fnsdcnMPPl

First question:
I am not sure if I my board is connected to the right serial port. On my port devices, I am using COM5 which is the Silicon Labs CP210x USB to UART bridge. I believe this is right however since I was able to upload my sketch/code to the board successfully. However, is this all I need to do? Do I need to make sure that the port that I am using corresponds to the physical USB port on my laptop?
i.e COM5 on my laptop is the corresponding USB connection on the right side of my laptop?

Second question:
Now when I am using the MultiWiiConfig (windows64 version), my board does not turn or move with the 3-D figure available on the GUI. It looks like it's just spinning in free air with no direction. I am assuming this is because the gyro + accel, baro, and magnometer are not being supplied with the 3.3V in order to drive them, thus the MultiWiiConfig cannot get data from them?

Third question:
Could there be some issues between the MultiWii code from the Dropbox and the version of the MultiWii config I am using? I thing the Dropbox code using MW 2.3, and I'm using a MW 2.4 Config,

Attached are some related pictures that could possibly help.
Thanks in advance
Sign up now
to remove ads between posts
Nov 08, 2017, 03:45 PM
Registered User
Ace12GA's Avatar
Ummm... I bought one of these boards more than 3 years ago. Seriously old school. It's a good flight controller for old school. You should absolutely use the correct version of the MultiwiiConf util. There are big differences between 2.3 and 2.4. You could probably configure 2.4 to flash onto your FC without too much trouble. I did, 3 years ago.

Can't answer your first question. I have no idea what COM port would come up on your computer. Safe bet, check com ports before connecting it, and after. This is in device manager. The new COM port that shows up when the board is connected is the correct one.

Second question, you have to actually tell the MultiWii Conf to read data from the board. Once connected, you have to click the "Start" button over the graph area to read telemetry data from the board.

This flight controller is completely no good in anything smaller than a 450 size quad. It is also not really great for anything more than sport flying. You're not going to be doing aerobatics, or racing with it.

I still have mine, and it still works, 3 years later. It's in a F450 frame. I fly it LOS, and FPV, but at this point just for fun casual flying. In general I'm flying my ~220 and 180 sized racers, running F3 and F4 Betaflight powered FC's.
Nov 08, 2017, 06:11 PM
Team AlienWarpSquad
As Ace12GA said "old school' and not many being used here.

There is a MWii web site and Forum so may get answers there.


Thread Tools