DIY Tri with Ardupilot - does not fly well - RC Groups
Thread Tools
Oct 28, 2017, 09:45 AM
mr1
mr1
Registered User
Discussion

DIY Tri with Ardupilot - does not fly well


Hi all,
i changed the flight controller at my tricopter from MultiWii to Ardupilot (Pixracer).

Since then it does not fly well anymore. With full throttle, the tail always stays below the rest and the copter moves backwards. So I trimmed the copter nose-heavy by changing the battery position but it did not make any difference. With MultiWii I did not have that problem.

Another thing is that it yaws left and right also in level flight. And when I yaw left or right and center all my sticks, it oscillates a little bit instead of staying in position. So I deactivated internal compasses and now I use only the external mounted next to the GPS receiver. But it did not change that behaviour.

I haven't tried Autotune so far but I think at least the first problem should be solved before doing that. Any suggestions how to fix that?

Components:
-Self made tri with glass fiber center plates and 10x10mm aluminiuim arms
-orig. Pixracer, mounted on M3 rubber damper
-Neo-7m GPS with compass
-HP2217-930kV
-12x4,5" carbon props
-20A BlueSeries (Alexmos flashed)
Sign up now
to remove ads between posts
Oct 29, 2017, 12:13 AM
OCD
Wright's Avatar
Sounds like yaw rate P is too high. Once you have the yaw solved and altitude hold working. I’d run auto tune. Good luck.
Oct 30, 2017, 06:03 AM
mr1
mr1
Registered User
Okay and the full throttle problem? It seems that ardupilot does not correct the lower thrust of the tail motor because of it's tilt angle for torque compensation. Calibrating ESCs did not help. With MultiWii I didn't have that problem.
Oct 30, 2017, 07:06 AM
OCD
Wright's Avatar
Never had that problem. Id go to ardupilot.org and go to the community discussion and ask. They will want to see the logs off the SD card. You have to make sure it is logging the correct parameters. Not sure which are the best to log.

Does it do this in stabilize and loiter?
Oct 30, 2017, 07:13 AM
mr1
mr1
Registered User
In loiter maximum vertical speed is limited by code so it does that only in stabilize and acro. I'll try to find the parameter for vertical speed and also check logs for ardupilot forum.
Oct 30, 2017, 07:46 AM
Registered User
ariaAQ's Avatar
i use mini apm on my tricopter, fly really well in stabilized and loiter..
How about your motor configuration? All CCW or 2 CCW + 1 CW?
Oct 30, 2017, 09:55 AM
mr1
mr1
Registered User
Front motors spin in opposite direction so that I don't loose so much thrust at tail motor.
So 2 CCW and 1 CW


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! G62 does not want to run - tried everything scoobiemario Engines 33 Jul 11, 2016 10:18 PM
Discussion 328P 450 QuadX does not fly well. N8LBV Beginner Multirotor Drones 2 Jun 23, 2015 10:44 PM
Discussion Need help with NAZA, does not hold height well kdrcguy Multirotor Drone Talk 5 Jul 07, 2012 04:38 PM
Question Why does my heli not work so well with 8 cell over 7 cell? shark7000 Micro Helis 9 Jun 04, 2007 09:58 PM
A Lucky Moment.... or.... How well does an Axi 2808 fly with no airplane attached? Martin Hunter Parkflyers 38 Jul 10, 2004 12:38 AM