Hitec ePowerBox 30A - RC Groups
Thread Tools
Oct 28, 2017, 06:33 AM
MaineFlyer
jpgilbert's Avatar
Discussion

Hitec ePowerBox 30A


I have two of these power supplies and they worked well for a time. Some months ago, one started jumping the voltage up and down. I normally set them to 13V to power my CellPro Multi4 chargers. Now I was getting undervoltage and overvoltage warning. Just very erratic. Stopped using the one. Well, months later, the second powerbox started doing the same. Not reliable to use.
I tried rotating the adj pots to see if that would help. Nope. They will work fine as long as no load is on the chargers.

Any ideas? Hate to scrap both these power supplies.

Joe
Sign up now
to remove ads between posts
Oct 31, 2017, 11:18 AM
Xpress..'s Avatar
Usually when this happens it's the transformers going out, this can happen if the power supplies are taxed to their limit often.
Nov 03, 2017, 01:45 PM
MaineFlyer
jpgilbert's Avatar
Thanks for the reply.
Do you think they are worth repair?

Joe
Nov 03, 2017, 07:10 PM
Xpress..'s Avatar
If they are outside of the warranty period then there may be a service charge, worst case scenario is you're just out shipping if you send them to us. In any manner, we never charge the retail price of the units to repair them (and generally we don't even charge that).
Nov 04, 2017, 04:10 PM
MaineFlyer
jpgilbert's Avatar
Thanks for the response. I believe they are probably worth getting repaired so I'll probably do so.

Joe


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
News Hitec ePowerbox 50A Power Supply Jason Cole Batteries and Chargers 22 May 22, 2017 11:03 AM
New Product Hitec X1 Pro Charger and ePowerBox 17 ServoCity ServoCity.com 0 Aug 20, 2014 09:23 AM
New Product NEW ePowerBox 50A Power Supply from Hitec ServoCity ServoCity.com 0 Jun 17, 2014 11:51 AM
New Product In stock! Hitec ePowerBox 30A Switching Power Supply ServoCity ServoCity.com 0 Jan 24, 2013 05:28 PM