Bricked Horus X12S ? - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Oct 14, 2017, 03:43 AM
Registered User
Discussion

Bricked Horus X12S ?


Hi Guys.
Was updating OpenTX on my Horus X12S and after the firmware write In companion 2.2, the Tx is just dead, nothing happens with the power button just a black screen, no response at all.

Tried disconnecting the battery, flash to FrOS from the sd card, re writing the firmware, just nothing, it's as if it has blown fuse !!

The only thing I think I may have done wrong, is to have left it on charge while I was doing the firmware write, but can't see why that would have caused any trouble.

Think I may have an expensive door stop, any ideas ?

Cheers.
Sign up now
to remove ads between posts
Oct 14, 2017, 05:42 AM
Carbo (-nator) ;-)
Did you measure the TX battery voltage? Do you hear a recognition signal from your pc when you plug in USB to Horus with disconnected battery?
Oct 14, 2017, 07:16 AM
No bounce, No play.
davidmc36's Avatar
The manual does say to turn off while charging. SJ radios have a fairly dire warning about overloading power input circuit if running and charging at the same time.

Any chance there was an issue........?
Oct 14, 2017, 03:27 PM
Registered User
Allerhop.
The battery monitor was at about half when started trying to flash, the tx was switched off during flashing, after it died the pc would only see it with the battery disconnected, if plugged the battery in, the pc does not see it.

After it bricked, I was able to do successful write firmware to tx, but when all re connected still black screen nothing, the only light that shows, is charge light, when on charge.

David.
The tx was off when I was trying to flash it, but on charge.
Oct 14, 2017, 03:33 PM
AKA 8178 - MIke Dailey
Jet_Flyer's Avatar
Quote:
Originally Posted by futaba1024
Allerhop.
The battery monitor was at about half when started trying to flash, the tx was switched off during flashing, after it died the pc would only see it with the battery disconnected, if plugged the battery in, the pc does not see it.

After it bricked, I was able to do successful write firmware to tx, but when all re connected still black screen nothing, the only light that shows, is charge light, when on charge.

David.
The tx was off when I was trying to flash it, but on charge.
Silly question, but are you sure you flashed with the correct X12S firmware? Or sometimes (very seldom) the flash might not work correctly and you will need to flash it again. Leave the battery disconnected during the flash process.

Mike
Oct 15, 2017, 12:29 PM
Registered User
Hi Mike.
Thanks for your input.
Mmmm yes it is possible, I have only been using Companion 2.2 for about two weeks, same applies to OpenTX, when I purchased a Tarranis QX7 , then just fell in love with the Horus X12S and had a good deal on a slightly used one on Wednesday last week.

The Horus had the March 2017 OTX build installed and was working perfectly, but I wanted to first update it to the May 2017 build and then try FrOS on it, however it all went horribly wrong on Friday afternoon when I tried to update OTX.

The thing that really worries me is that the tx is completely dead and that I may have damaged it by leaving the charger on whilst the X12S was running and doing the firmware write, although tx was switch off while writing the firmware.

Think this could be a case of a" little knowledge is very dangerous" !!!

Have to admit, I am confused in the "build options" on Companion 2.2 which box/boxes to check (see attached shot)

Thanks.
Oct 15, 2017, 01:05 PM
AKA 8178 - MIke Dailey
Jet_Flyer's Avatar
Quote:
Originally Posted by futaba1024
Hi Mike.
Thanks for your input.
Mmmm yes it is possible, I have only been using Companion 2.2 for about two weeks, same applies to OpenTX, when I purchased a Tarranis QX7 , then just fell in love with the Horus X12S and had a good deal on a slightly used one on Wednesday last week.

The Horus had the March 2017 OTX build installed and was working perfectly, but I wanted to first update it to the May 2017 build and then try FrOS on it, however it all went horribly wrong on Friday afternoon when I tried to update OTX.

The thing that really worries me is that the tx is completely dead and that I may have damaged it by leaving the charger on whilst the X12S was running and doing the firmware write, although tx was switch off while writing the firmware.

Think this could be a case of a" little knowledge is very dangerous" !!!

Have to admit, I am confused in the "build options" on Companion 2.2 which box/boxes to check (see attached shot)

Thanks.
You have FrSky Horus selected that is a key thing. Part of the options are covered by a pop-up in your image, but having none selected at the point is OK.

With the the X12S battery disconnected is it possible to download the firmware again and flash the system again? You've updated the SD card and have it installed?

Mike
Oct 15, 2017, 02:11 PM
Registered User
Ok let me get this right, I put the sd card contents 2.2v0010 back on the card (had taken it off while trying to flash FrOS and low on sd cards) and mount it in the tx.

Think I have tried it but think it came up with no updates available, but it's all a bit vague now, by this time I was panicking !!

Can you just talk me through what I should do having , mounted the sd card, plugged in the usb with tx off and battery disconnected , where should I go on Comp 2.2 then, not sure I have been doing that right.

Martin.
Oct 15, 2017, 02:24 PM
AKA 8178 - MIke Dailey
Jet_Flyer's Avatar
Quote:
Originally Posted by futaba1024
Ok let me get this right, I put the sd card contents 2.2v0010 back on the card (had taken it off while trying to flash FrOS and low on sd cards) and mount it in the tx.

Think I have tried it but think it came up with no updates available, but it's all a bit vague now, by this time I was panicking !!

Can you just talk me through what I should do having , mounted the sd card, plugged in the usb with tx off and battery disconnected , where should I go on Comp 2.2 then, not sure I have been doing that right.

Martin.
Martin,

My suggestion would to be download the flashing instructions here and start fresh https://www.rcgroups.com/forums/show...&postcount=950 Skip the stuff about FrTX and just focus on the OpenTX installation process. Use the SD card reader in your computer to put the files on the card. I prefer to use a dedicated SD card for OpenTX and one for FrTX.

Mike
Oct 15, 2017, 02:31 PM
Registered User
Mike.
Will do, have just noticed a mistake I made on my disastrous attempt, I had loaded the QX7 card contents onto the card I put in the X12S ! Have now downloaded the correct files and writing them to the card, could that have caused my crash ?

Martin
Oct 15, 2017, 02:35 PM
AKA 8178 - MIke Dailey
Jet_Flyer's Avatar
Quote:
Originally Posted by futaba1024
Mike.
Will do, have just noticed a mistake I made on my disastrous attempt, I had loaded the QX7 card contents onto the card I put in the X12S ! Have now downloaded the correct files and writing them to the card, could that have caused my crash ?

Martin
Martin,

I don't know, I've never done that before.

Mike
Oct 15, 2017, 03:06 PM
Registered User
Mike.
Have just followed your instructions to the letter............. It's alive !!!!!!

Going mad at me at the moment for low tx battery, so have switched off and will put on charge, is it true that you should not run one of these whilst on charge ?

Thank you so much for your help, you made me go through things methodically which is how I found my sd card mistake and I think I was checking too many things in the build options.

Thanks again.
Martin
Oct 15, 2017, 03:16 PM
AKA 8178 - MIke Dailey
Jet_Flyer's Avatar
Quote:
Originally Posted by futaba1024
Mike.
Have just followed your instructions to the letter............. It's alive !!!!!!

Going mad at me at the moment for low tx battery, so have switched off and will put on charge, is it true that you should not run one of these whilst on charge ?

Thank you so much for your help, you made me go through things methodically which is how I found my sd card mistake and I think I was checking too many things in the build options.

Thanks again.
Martin
Martin,

As you must know by now the X12S is a pretty amazing radio system, so great news that you have recovered.

Mike
Oct 15, 2017, 03:45 PM
Registered User
mike.
Yes, I was under the impression they were brick proof and I obviously had a good try !!

Still want to try FrOS but think I will leave it for a bit, when I do I will follow your instructions closely, I haven't got a back up of it but presumably the FrOS I downloaded from f Frsky will be ok.

Martin.
Oct 15, 2017, 03:57 PM
AKA 8178 - MIke Dailey
Jet_Flyer's Avatar
Quote:
Originally Posted by futaba1024
mike.
Yes, I was under the impression they were brick proof and I obviously had a good try !!

Still want to try FrOS but think I will leave it for a bit, when I do I will follow your instructions closely, I haven't got a back up of it but presumably the FrOS I downloaded from f Frsky will be ok.

Martin.
Martin,

Not knowing what the last FrTX was used on the system and what is on the internal flash memory drive could get tricky. You might want to contact the seller and see if they know.

Mike


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Horus X12S Bricked nutz245 FrSky 5 Sep 02, 2017 10:00 PM
News FrSky - Horus X12S Jim T. Graham Radios 744 Apr 29, 2017 02:00 PM
New Product FrSky Horus X12S Radio Hobbo FPV Racing 5 Nov 01, 2016 07:03 AM
Alert $0.99 Frsky Horus X12S Transmitter? W0tw0t Banggood.com 6 Apr 06, 2016 04:08 AM
New Product Frsky Horus X12S Texture Version 16 Channels Inbuilt GPS Module Transmitter @Banggood W0tw0t Multirotor Drone Talk 4 Mar 13, 2016 10:14 PM