My Radiolink AT9 is acting up, need help! - RC Groups
Thread Tools
Sep 25, 2017, 06:41 PM
The master of trees.
Fishy Tree's Avatar
Help!

My Radiolink AT9 is acting up, need help!


So here's what's going on. I took a short hiatus from RC. I left my AT9 in working order when I last used it about a month ago. I had built an FT F22, flew it for a few days and destroyed it in a crash. Disgruntled, I just set the controller on my shelf and didn't come back to it until yesterday when I decided to make a new plane. First thing I did was pull the electronics off the F22 and hooked up the motor to make sure it still worked... well, it didn't, neither did the servo I plugged in, well it did. But it only worked with some of the knobs on top. Can't fly anything like that.

I've done some trouble shooting and it appears there's something wrong with the sticks. Both seem to work fine on the "servo" screen in every direction. but when I bring up stick calibration, only the "center" points register as being moved. Also, when I move the left stick to the right, channels 5 and 7 also move with it. I'm not sure if it matters or not.

I have found that replacing the sticks is possible, I took the back of my remote and it seems to be just plug and play components. I also found replacement sticks online for a "reasonable" price. Should I do that? Just buy a new remote? Or am I overlooking something simple? Or maybe not so simple?

Below is a link to a video I found on YouTube where someone else is having the same problem.

RadioLink AT9 stick calibration problem! (3 min 50 sec)
Sign up now
to remove ads between posts
Oct 26, 2017, 08:43 AM
jimbo42

Radiolink AT9s


i have a similar problem,,, my throttle stick does not work,, monitor says it is but cannot get it to function,,, all other servos work just fine,,, any ideas ?,, have calibrated my sticks many times,,, ole fart Jimmy