GT1000 firmware update not working - RC Groups
Thread Tools
Sep 20, 2017, 09:24 PM
Registered User
kenelder's Avatar
Discussion

GT1000 firmware update not working


Folks, I'm trying to update my new GT1000 and the usb driver is not recognizing anything when I plug it in. Followed instructions exactly. Any ideas?
Sign up now
to remove ads between posts
Sep 21, 2017, 10:48 AM
Registered User
Hi,
Please follow the sequence below to get a reliable detection each time.
1) Connect the USB cable first.
2) Power on the charger.
3) Click open the update utility. If the serial number appears on the screen, then the utility has detected the charger.

Are you using a PC and earthed power supply to do the update? If both the PC and the power supply has an earth connection, then it could have activated the protection device inside the charger. This will prevent the update from continuing. The solution would be to either use a laptop to do the update or use a battery as power source to power the charger.
Sep 21, 2017, 02:42 PM
Registered User
kenelder's Avatar
Thank you for the reply. I did the instructions just like you said- connect USB cable, then power charger, then open gt500 software. I have now tried on 2 different laptops. Have tried battery power for the charger and laptop. Still no serial number showing. So it is not a grounding issue as both were on battery.

I have tried multiple USB cables- none work. The one I am using now works just fine with all my other USB devices including my Taranis transmitter. I think the cable is fine.

I can see the USB Com port using the Microchip driver as COM4 when connected to the charger. It shows a Microchip driver date of 10/6/2014 and says it is functioning normally. When I disconnect the charger, that port disappears. I'm guessing the usb driver and port are fine.

Is it possible that the GT500 software has a bad build? I get no installation errors. Thoughts?

Thanks,

Ken
Sep 21, 2017, 08:55 PM
Registered User
Hi Ken,
I think you may have downloaded the wrong utility from our website. When I tried to access the GT1000 utility, it sends me to the GT500 utility installer instead.

Sorry for this mistake. Please download the appropriate utility from the link below:
http://www.revolectrix.com/applicati...ware/setup.exe

Fong
Sep 21, 2017, 08:57 PM
Registered User
kenelder's Avatar
Thank you, will give it a try.
Sep 21, 2017, 09:10 PM
Registered User
kenelder's Avatar
Thank you RevoFong that worked. Yes, I downloaded from the website and it did say GT500 software, I didn't realize that there was separate software for the GT1000. Again, thank you!
Sep 21, 2017, 09:19 PM
Registered User
kenelder's Avatar
One issue remains: on channel 1 the fan continues to run even when I set it for 50 deg C. Channel 2 the fan turns off after it starts regardless of the fan setting. Is it supposed to operate like that?
Sep 21, 2017, 11:59 PM
Registered User
This is how the fan is supposed to operate -
During power up, the fan turns on for a few seconds as part of the initialization sequence. During charge, if the charge power is above a limit, the fan is always on. For GT1000, this power limit is 150Watts. Below this limit, the fan turns on when the temperature setting is reached. There is a small hysteresis below the setting where the fan will turn off.

Hope this helps.
Sep 22, 2017, 12:00 AM
Registered User
Forgot to mention - for discharge, the fan is always on.
Sep 22, 2017, 07:33 AM
Registered User
kenelder's Avatar
RevoFong, the fan on channel 1 stays on all the time even when not doing anything. Channel 2 operates like you said. I would expect them both to operate the same.

Thanks for your help.
Sep 23, 2017, 03:07 AM
Registered User
If the fan runs continuously then it's most probably a hardware fault. Check for a few minutes though, after a charge /discharge has stopped, it's programmed to run a further two minutes. But if you noticed this during the power up stage when it's supposed to only run briefly, could you please do another firmware update to conclude it's a hardware issue?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! MultiWii 328P Barometer not working after firmware update VaxoN Multirotor Drone Electronics 2 Aug 23, 2013 07:59 AM
Discussion HELP needed. NAZA firmware update, motors not working SpeedieA Multirotor Drone Talk 0 Jul 05, 2013 02:14 PM
Help! Firmware update error with OSD pro ONLY Data Logger and Gardian firmware update works whosthebaddest Eagle Tree Systems 10 Mar 17, 2012 06:26 AM
Discussion V3 not working after firmware update clintski Eagle Tree Systems 7 Feb 21, 2012 04:48 PM
Help! Flycamone2 firmware update not working czechyour6 Aerial Photography 22 Jul 16, 2011 06:16 AM