Thread Tools
Sep 05, 2017, 03:29 AM
Registered User
Thread OP
Help!

ProBoat Recoil 17" Reception Issue


Hiya, its Newbie here!!!!

I thought I'd give a big 'HI 5' and what a great forum I've found here. Plenty of helpful tips, great videos and lots more.

So, I'm hoping someone out there can help me. I bought the ProBoat Recoil 17" from Horizon Hobby due to great reviews and took it to our summer house in Finland. Following the simple instructions:

Battery fully charged and installed
New batteries in the transmitter
All knobs and dials set to default as per pics on the transmitter
Switched on transmitter, then the boat

Day 1: At this point, all I get is 3 bleeps, then a single bleep every sec continuously. After several attempts checking and rechecking, I gave Horizon Hobby a call. It was found that I had to sync the transmitter to the boat using the dial (now set to West or 9 on a clock face).

Now at this point, my 3-year-old was going mental with excitement, so we rushed down to the lake, did a quick check and put the boat into the water. Off she went, whizzing around here and there, then to my surprise.... I lost reception and the boat just kept going and going. I could hear the motor and see no boat, then silence.

I decided to head out on the rowing boat, boy included with his life jacket on. Luckily for me, the boat is coloured bright RED and we managed to retrieve it without any damage occurring.

Day 2: Batteries fully charged, instructions re-read and did the Range Check test (approx. 80mtrs). All set again with the throttle toned down. Once again, off she went whizzing around here and there and then.... yep you guessed it…the same again, lost reception and there she goes, out my sight. I managed to find the boat again and called it a day until the root cause is found.

So, my question to you all is.... Have you had a similar reception problem? as on both days, sun was shining, no interference from anywhere, loss of reception was probably at max 35mtrs.

I'm happy for any advice, improving reception etc.


Thanks in advance and apologies for the long Thread, but I wanted to share my experience
MRaghvani
Sign up now
to remove ads between posts
Sep 09, 2017, 07:58 AM
Registered User
I had some similar problems. It turns out in my case the failsafe wasn't set correctly and goes at full throttle if it loses signal . The boat would occasionally dive underwater (and lose signal) if it flipped on a wave and then would stay underwater for a minute or two (presumably at full throttle) before finally coming back up luckily. There are a couple of buttons on the receiver. I would suggest you rebind the receiver to the transmitter and then set the failsafe. Don't run it without the failsafe working correctly or you'll likely get another run away and possibly lose the boat. The way to test is to just turn the transmitter off with the boat plugged in and on the bench. It should stop and not go into full throttle. The instructions aren't to helpful and neither was Horizon Hobby tech support. I had to figure how to do it on my own through trial and error. Good luck.
Sep 11, 2017, 06:22 AM
Registered User
Thread OP
Hi GigaRC,

I appreciate your response and will take your advice onboard. A couple of questions for you or anyone else who wishes to share their expertise, as the instructions and HH Tech support are not very helpful. Plus you did mention that you figured it out yourself

1) Whats your best method of re-binding the receiver to the transmitter ?

2) How would you set the failsafe to work correctly ?

Thanks in advance
M
Sep 13, 2017, 09:21 AM
Registered User
I honestly don't remember exactly what I did. I know there are two buttons on the receiver. One is for binding and one is for the failsafe. I believe the instructions for rebinding are in the included manuals. As for the failsafe, you'll know you've done it right if you can turn the transmitter off and the throttle goes to zero on the test bench then you should be good to go.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Recoil 17 trim issues Randizzle Racing Boats - Electric 6 Jun 10, 2016 06:48 PM
Discussion proboat recoil battery issues help spencer911 Racing Boats - Electric 10 Oct 21, 2015 07:15 PM
Discussion proboat recoil shaft issues help spencer911 Racing Boats - Electric 19 Sep 19, 2015 12:55 PM
Discussion Proboat Recoil 17 or Barbwire help RCScott Racing Boats - Electric 3 Jul 07, 2015 09:04 AM
Question Proboat Recoil 17 or Quanum Aquaholic scubapro Racing Boats - Electric 0 May 17, 2015 10:10 AM