binding maxima receivers - RC Groups
Thread Tools
Aug 04, 2017, 07:03 AM
Registered User
Question

binding maxima receivers


I bought a maxima SL receiver today, and I can't get it to bind. The manual is chinglish, but it seems like it should be a simple procedure. Set A9X to maxima bind mode, hold rx button down and connect power .

I've tried many times, and can't get a result.

Am I doing something wrong, or have I got a faulty receiver?

When I power on with the button pressed, I get a red LED flashing very slowly.

When I power up normally, I get a blue LED flashing very slowly.

Also, if I scan for clean frequencies before binding the Tx gets stuck there. It hangs on that screen and I have to power off to get out of it.
Last edited by the_crack_fox; Aug 04, 2017 at 07:10 AM.
Sign up now
to remove ads between posts
Aug 04, 2017, 08:16 AM
Registered User
Firmware update fixed it! Too bad if you don't have a hpp22. I bought the receiver from a LHS today, and that firmware update came out 2 years ago. I guess the receiver has been on a shelf somewhere for a very long time. Hobby shop guy didn't even believe me that it existed, he'd never heard of maximaSL but promised me he would get me one if he could.

Someone needs to give the aussie distributors a kick in the pants, they're hopeless at marketing hitec product.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Bind DSMX SAT receiver to KISS without full receiver? phazeshifta Beginner Multirotor Drones 2 Dec 02, 2016 12:30 PM
News Hitec Maxima SL 9-Channel Micro Receiver Low Latency Receiver for Flybarless Systems ndfly700 Electric Heli Talk 12 Apr 27, 2016 03:54 AM
Discussion PB Mini Mustang/ Maxima _AL_ Car Talk 2 Jan 01, 2016 03:53 AM
Discussion Hitec Aurora 9X telemitry with Maxima Receiver? Barnaby01 Radios 0 Jan 13, 2015 06:06 AM
Discussion 9x bind problem, is 9x receiver bind/batt still labeled wrong? xjz Multirotor Drone Electronics 3 Jan 29, 2014 10:48 PM