PL 8 not charging - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Jul 22, 2017, 11:36 PM
Registered User
GeorgeC's Avatar
Help!

PL 8 not charging


I sent an email to Revolectrix support 3 days ago but I didn't hear back. Then I found out that there is a process through My Account on the Revo website whereby a support ticket can be raised and because I didn't do this, maybe that is why I hadn't received a reply? I then completed the online ticket. However, I thought that it was worth a try asking here. This is what I wrote on the support ticket.

Hi,

I am having trouble using my new PL8. I am getting various errors and whilst charging, the charger is reporting Current = 0mA despite being set at 1.0A or higher. The charger then terminates with a "Safety Code 96 - PWM Ratio too high". This happens whether I use my Powertech MP3090 power supply or a 12v Gel Battery?

When starting a charge on a new 5s 5000mAh battery that is around 47% storage charge when I start the charge, after about 5min the charger then reports 90% Fuel and cells still at 3.83v and Capacity IN = 0.0 mAh?

Something seems wrong. Your early reply would be appreciated as I cannot charge any of my batteries with the new charger.

(I have an iCharger, Orbit Microlader Pro and Elprog Pulsar also).

Kind regards,
George


I gather the 96 error is saying something is wrong with my power supply (PWM ratio too high. Check the power supply and output wiring). I have checked all the cables and all seems well and everything works with my other chargers. I only received the charger in January and due to a long stint in hospital, I am only using it now for the first time. I did have a couple of successful charges initially but now this problem has arisen. I also note that the charger reports the power supply as xx.x volts but a negative amperage e.g. @ -4.8A?

Any help is greatly appreciated.

George
Sign up now
to remove ads between posts
Jul 25, 2017, 11:51 PM
Registered User
GeorgeC's Avatar
Looks like I'm alone with this problem but here is an update for those interested.

Today (July 26), I eventually received a reply to my email of July 20 from Revolectrix support. The advice was to check the current limits on the charger to ensure it wasn't set too low. I have only just started using the charger and had left the factory defaults at 40A so I knew this would not be the issue. There was worse to come.

I had ordered a new power supply to try to maximise the power of the PL 8. I received this yesterday, a Chargery S1500. I checked all the settings, plugged the PL 8 in and commenced a charge at 5A (5S 5000 LiPo). No change in the charge rate with 0.0A still showing as the charge current. Next thing some sparks inside the case of the power supply just near the AC power cable and now a brand new inoperable power supply.

The time difference between MD USA and Australia doesn't help with communication but I'm now waiting on a further reply from Revolextrix whilst looking at a charger that doesn't charge and a brand new power supply that has now failed.

FWIW I have been flying electrics for 20 years and I've used chargers from the first AstroFlight chargers, through to my current stable of chargers - Orbit Microlader Pro, Elprog Pulsar and iCharger 208B. I've never had any major trouble with any of them.

Here's hoping Revolectrix can help me out soon.

George
Jul 26, 2017, 05:53 AM
Registered User
Best option would be to open a ticket here:

http://www.revolectrix.com/support_options.htm
Jul 26, 2017, 06:00 AM
Registered User
GeorgeC's Avatar
Quote:
Originally Posted by Ohmic
Best option would be to open a ticket here:

http://www.revolectrix.com/support_options.htm
Hey, thanks Ohmic for the reply. As per my post, I did this on the 20th and received a reply today. I'm hoping Revolectrix will have a solution. The charger seems to be the problem. (to me)

George
Jul 28, 2017, 12:01 AM
Registered User
GeorgeC's Avatar
Sadly, the PL 8 is on it's way to Batam Indonesia. A fairly expensive trip


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Pl 8. Limited amps CDignition FMA Direct 14 Feb 09, 2017 08:16 PM
Discussion Nimh glow ignitior charge settings on Pl 6 wickkerr82 FMA Direct 2 Aug 04, 2016 05:48 AM
Discussion Reality check: charging 6s 10ah w/PL-6 in car pchaplo Batteries and Chargers 19 Jun 24, 2016 01:05 PM
Discussion PL Dual 8 -Code 100 Dansy FMA Direct 9 Jun 18, 2016 03:50 PM
Discussion PL 8 V2 will not charge NiMh or NiCd packs Lost_Dawg FMA Direct 7 Jan 17, 2014 06:52 PM