Guardian harness up in smoke - RC Groups
Thread Tools
Jun 29, 2017, 04:24 PM
Registered User
Discussion

Guardian harness up in smoke


Brand new, was just installing in my fms 1700mm p51. Hooked it up according to manual, plugged the battery in and a big plume of smoke, so i disconnected the battery and found the aileron cable fried and melted the neg wire.

I disconnected the guardian and plugged everything back into the rec. and everything works fine, nothing fried.

Hooked up the guardian to computer and everything works. Only damage i see is the pos. , pin on guardian is a tad discolored. I checked the pin and the area it connects to inside the guardian and dont see any issues or melted solder.

Im thinking the cable must have had a short in it, what do you guys think?
Sign up now
to remove ads between posts
Jun 29, 2017, 04:50 PM
I'd be mad without a Taranis!
I know that I would be opening a support ticket with Eagletree requesting a replacement.
Jul 01, 2017, 10:30 AM
Registered User
Wintr's Avatar
Yeah, support ticket time. It could be the cable, but could also be a solder splash across the connector on the circuit board. I'd let them have a look, if only for quality control info.
Jul 04, 2017, 03:56 PM
Registered User
Quote:
Originally Posted by Wintr
Yeah, support ticket time. It could be the cable, but could also be a solder splash across the connector on the circuit board. I'd let them have a look, if only for quality control info.
I sent it back.
Jul 17, 2017, 07:40 AM
Registered User
Update; eagle tree replaced complete unit, said they didn't find anything wrong with old one. But, I installed new one, hooked up same way and with same plane, servos etc. And it works fine. I still think there was a short in the old unit that cause the harness to melt even though they said it was fine.
Otherwise, great service even though I was without for awhile.
Jul 17, 2017, 06:58 PM
Registered User
Wintr's Avatar
I'd guess that the short melted with the harness.
Jul 20, 2017, 02:15 PM
Registered User
Quote:
Originally Posted by Wintr
I'd guess that the short melted with the harness.
Yeah, be hard to find out with it melted, my opinion is that there had to be a short in the harness itself.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! My Motor went up in smoke, can I trust my ESCs? tobimai Multirotor Drone Power Systems 3 May 15, 2017 12:13 PM
Discussion Shockwave 26 went up in smoke silencespr Racing Boats - Electric 26 Oct 12, 2016 01:08 PM
Discussion Icharger 106b up in smoke wildpede Batteries and Chargers 6 Jun 19, 2016 10:53 AM
News The Smoking Pike: Pike Precision up in Smoke! awagar Sailplane Talk 2 Jul 18, 2013 07:57 AM
Discussion Lama V4 4 in 1 up in smoke within 30 secs ouroboro Coaxial Helicopters 2 Mar 24, 2010 01:19 PM