Yaw servo does not move - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
May 14, 2017, 03:18 PM
Registered User
Help!

Yaw servo does not move


Hi everyone,

I build a tricopter and there is everything ok but the servo does not move.
I using
SP Racing F3 EVO Flight Controller
Radiolink AT9S with R9DS Radiolink Receiver connected SBUS to FC

The 3 motor works but the servo does not move.
The motor's are connected to 1,2,3 pins on FC
I have try the servo on all other pins, but I have not been successful
I try on Betaflight and Cleanflight
In Motors page on servos section the numbers of servo number 6 are changing if I move the tricopter.

Can anyone help me
Thanks

Sorry for my bad english.
Sign up now
to remove ads between posts
May 18, 2017, 04:07 AM
Registered User
Hi,

I suggest you could use PWM mode and do not use controller firstly to test each channel of R9DS is compatible with your servo.
May 22, 2017, 02:31 PM
SAC
SAC
Registered User

Tricopter Yaw Servo Issues


Tricopter Yaw Servo Not Responding in 2.0.x #2775

Check this out. It seems that there really is a problem with Cleanflight and Betaflight in the tricopter programing. Looks like there are problems setting up the yaw servo. So far a lot of chat but no real fixes.

I was actually glad to see this as I had been having major issues setting up another tricopter. I had used Cleanflight before with great success. I thought the problem was me. Actually kind of wish it was me, I'm easier to change than a computer program.
May 23, 2017, 03:01 PM
Registered User

No servo re sponse


I haven't built a tri in some time but was considering a Rcexplorer mini. So i watched the videos, looks simple right. Nowhere in his videos does he tell us how to get the tail servo to work. Flashed an F3 and a naze can't get servo response with triflight betaflight or clean flight. In the old versions of clean flight tri copters were as easy as setting it up on the configuration tab.
May 23, 2017, 03:27 PM
Registered User
For a Naze32, with the newest versions of betaflight or triflight, you need to map the resources in the cli with the following commands:

resource MOTOR 4 NONE
resource MOTOR 5 NONE
resource MOTOR 6 NONE
resource SERVO 1 A08
resource MOTOR 1 B06
resource MOTOR 2 B07
resource MOTOR 3 B08

This mapping supports the servo on channel 1, rear motor on channel 3, right motor on channel 4, left motor on channel 5. Might have the left and right reversed, I'm going from memory here. But at any rate this works on my Naze32 board with triflight 0.7 release. Should also work on latest betaflight, but haven't tried that.

Without knowing what F3 board, can't help there, but it's most likely the resources have not been properly mapped.
May 23, 2017, 07:55 PM
Registered User
Above, I gave a link to the post where all this was detailed. First you need to use the resource command, to find the desired output, and only then re-assign it! For example, assign servo to output 6:
May 23, 2017, 11:44 PM
Registered User
jihlein

thanks for the help I'll tri that on the naze32! The f3 FC I was trying to get working was an SPRACINGF3

thanks again

jilein
that got the Naze working thanks
Last edited by augerN; May 24, 2017 at 10:58 AM.
May 26, 2017, 06:29 PM
SAC
SAC
Registered User
jihlein

Thanks a bunch for the info about changing the cli. I have been going round and round with this since the programs were updated. I thought for sure I must be doing something wrong. Now I have my tricopter in the air with my favorite Naze board.

At first I was afraid to do it but I finally figured out I had tried everything else with no luck. I guess feeling I had nothing to loose got me over the hump.

Thanks Again!!!!!
May 26, 2017, 08:01 PM
Registered User
No problem, glad it worked out!
Aug 30, 2017, 05:51 PM
Registered User
nicnaimless's Avatar
The Yaw servo is responding to stick input but is not compensating for the movement of the tricopter. Do I need to make adjustments in the SERVO tab of Betaflight?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion aileron stick does not move ailerons in wizard WillGl Eagle Tree Systems 3 Apr 06, 2017 04:47 PM
Discussion HK Blueseries 40A and Multistar Elite 2204-2300 does not move past 50% Throttle MarcusCouceiro Multirotor Drone Power Systems 0 Mar 18, 2017 06:03 PM
Discussion yaw does not remain level when applying yaw? Yowge Beginner Multirotor Drones 8 Aug 21, 2016 05:00 PM
Question ZMR-250 want to Yaw left and trimming does not help Blacky's Boy Beginner Multirotor Drones 8 Apr 11, 2016 08:37 AM
Help! Why does my gimbal ROLL move when my Tri does YAW movements? SwissBoy Multirotor Drone Electronics 12 Oct 11, 2015 11:10 AM