Binding Problem - RC Groups
Thread Tools
May 13, 2017, 12:58 PM
Shadetreeflyer
Shadtreeflyer's Avatar
Discussion

Binding Problem


I get an alarm and voltage display when I try binding my Aurora 9 to a Opitima 7 receiver? Help please
Sign up now
to remove ads between posts
May 15, 2017, 12:58 PM
Xpress..'s Avatar
What are you using as a power source to link your Optima receiver?
May 15, 2017, 04:08 PM
Shadetreeflyer
Shadtreeflyer's Avatar
At first I tried a 2 cell 7.4 volt lipo then I tried a 6 cell lipo. The alarm sounded using either battery.
May 15, 2017, 06:23 PM
Shadetreeflyer
Shadtreeflyer's Avatar
I called tech-support and they were able to help me fix it. Big thumbs up to Hitec' customer service and their tech Billy. He was able to trace it down to a bad new model template. Thanks Billy and customer service at Hitec.
May 16, 2017, 12:20 PM
Xpress..'s Avatar
Glad to hear you were able to get the issue resolved.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Binding problem. 420TEE Dock Talk 3 Sep 16, 2015 09:21 PM
Discussion FrSky Binding Problem - RX wont go into bind mode squishio2 Radios 6 May 11, 2014 10:26 AM
Discussion Problem binding Spektrum TX and RC - no bind plug Nate0624 Multirotor Drone Electronics 0 Apr 29, 2014 08:51 PM
Discussion 9x bind problem, is 9x receiver bind/batt still labeled wrong? xjz Multirotor Drone Electronics 3 Jan 29, 2014 11:48 PM
Discussion Binding problem with Twister Quad (lost binding) Hecxa Mini Multirotor Drones 1 Dec 27, 2013 05:45 AM