Thread Tools
Oct 07, 2019, 08:37 AM
65 years of RC flying
Daedalus66's Avatar
The module requires that you used Multi as the protocol. This requires that it be selected in the firmware you flash to the Tx.

Not all versions of OpenTX support Multi. What version are you using?

Maybe someone familiar with the specific Tx (X-lite) can chime in here.
Last edited by Daedalus66; Oct 07, 2019 at 08:44 AM.
Sign up now
to remove ads between posts
Oct 20, 2019, 01:04 PM
Registered User

Binding issue E Flite Radian iRangeX Module


Searched the web but still no love with binding.

The Radian has a DS2/DSMX AS3X Reciever/ESC

OpenTX 2.3.1
Taranis X9D plus

Current settings:
Radio Controls to AETR

Mixer:
CH1:  
CH2: El 100%
Ch 3: Thr 100%
Ch:4 Rud 100%

Throttle Source: Thr

Protocol: Multi
DSMX 22ms
Channel 1-8 (have also attempted 1-5 + 1-6)
Bind on startup: checked (have also attempted unchecked)

Would love any input/advice to help me get this bound!
Oct 20, 2019, 06:07 PM
65 years of RC flying
Daedalus66's Avatar
I presume the receiver has the bind plug in place and that the light is flashing to indicate bind mode.

Turn on transmitter. Go to Setup, internal RF, select Mode OFF.
Go to External RF, select Mode MULT DSM
Select Subtype X 22ms
Select Channel range 1-8
Set RxNum to, say, 01 (not 00).
Check Autodetect (telemetry)
Make sure Low Power is NOT checked.
Go back to [Bnd] and press Menu button. It should chirp several times to indicate bind mode.
Watch receiver. Flashing should stop, then go to slow flash, then light should come on solid.
When light is on (no flashing or flickering) receiver is bound. Test servo action.
Remove bind plug. Power down.

If you see Bind on startup, do NOT check.
Oct 20, 2019, 08:27 PM
Registered User
Hi Thanks for the input @daedalus66

There is no bind plug on this model UMX Radian:
https://www.horizonhobby.com/umx-tra...ology-eflu2980

I followed your steps precisely, but it still won't bind. (keeping a 6ft distance between tx and rx per advice on other threads)

The only other oddity I have is an SD card splash screen warning (declaring that it expects 2.3 v022). I'm going to try updating that in the am and see if that does the trick.
Oct 20, 2019, 10:14 PM
65 years of RC flying
Daedalus66's Avatar
UMX models go into bind automatically. The question is still was the receiver light flashing?

It sounds as though the content of your SD card doesn’t match the version installed.

Did you check the Multi box when selecting options for the version you installed?
Oct 22, 2019, 03:32 PM
Registered User
@daedalus66
The receiver light is flashing yes.
I updated SD card and tried to bind again, but no go.
When installing 2.3.1 there is no multi box (from what I'm reading in threads this is now included)
Here's a screenshot of my settings: http://cloud.dobell.ca/9d19951b83b1 Are there any obvious issues there that you can see?
Oct 22, 2019, 08:34 PM
Registered User
Also something I’m noticing is that when I create a new model and transfer it from open to to the Taranis, it doesn’t transfer the protocol settings. It remembers that I want to use the external tax but doesn’t save dsm or sub protocols. I have to set them on the radio, from that point on the radio retains them. Is this typical? Also does anyone know if OpenTX 2.3 is supported? Thinking perhaps I need to down version my radio as the next avenue of investigation
Oct 23, 2019, 07:11 AM
Registered User
I have the same issue as above trying to bind several different Blade products. No joy at all. None will bind and I updgraded OpenTx and the Firmware with the Multi option enabled.

Don't know what else to try
Oct 23, 2019, 08:47 AM
65 years of RC flying
Daedalus66's Avatar
I’m going to try upgrading my QX7, currently working on 2.2 with MPM, to 2.3.2. Will report on results later.

Meanwhile, you might want to try a request for help on the OpenTX 2.3 thread.
https://www.rcgroups.com/forums/show...cussion-Thread
Nov 03, 2019, 07:53 AM
Registered User
@daedalus66

Thanks for your help.
Yesterday I discovered that it was in fact a connection issue. doh.
The TX pins/female headers were offset from one another by about 1/2mm so it slid in and felt seated, but it was not. I tested it with some jumper cables and had immediate success. A bit of fiddling (read: bending) of the pins and i was able to get it to seat properly and work.
Nov 10, 2019, 11:57 PM
Registered User
RC/DC's Avatar
Hi All,

I've just installed the IrangeX to my Taranis X9D plus LE, and can't get it to bind to a simple Lemon RX 6Ch at all.

I'm running open tx 2.2.4, and don't see any sign of a "multi" option in the controller. Do I need to update to 2.3.1?

If I list my settings, I've got:

Internal RF off.

External RF I've got the following functions:

OFF, PPM, XJT, DSM2, CRSF, R9M, SBUS.

I've been using the DSM2 mode, which then allows me to select from the following submenu:

LP45, DSM2, DSMX.

I'm not really good at this, and a bit stuck on a plane that's literally ready to fly other than this.

I would really appreciate some "for dummies" explanation, cheers in advance for any help.
Nov 11, 2019, 10:51 AM
Registered User
RC/DC
You should have a DIY Multiprotocol Module choice under the External module protocol to use the iRange. If you do not it is because your firmware was downloaded without that checked under the Settings.
Just plain DC
Nov 11, 2019, 12:03 PM
Registered User
Then you will be able to select DSM and DSM2 or DSMX and timing.
Nov 11, 2019, 02:16 PM
Registered User
RC/DC's Avatar
Cheers mate,

I got it to work by updating my firmware to 2.3.1

Don't know about the check boxes you've pictured, as they weren't presented or offered to me, but I had the multi option on the radio and added the DSMX/22 settings myself.

Bloody handy to have the option of using cheap Lemon rx's with my Taranis!

Seems I've got all the settings/options/adjustments on my radio too, which is good as I like to set up individual ailerons with differential etc. Hope the range is all good.
Nov 11, 2019, 05:26 PM
Registered User
Multimode is standard in in 2.3, but was an option in 2.2


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-Review iRangeX IRX4 2.4G 4-in-1 Multiprotocol JR-type Module Datos Radios 337 Yesterday 07:40 PM
New Product iRangeX IRX4 Plus CC2500 NRF24L01 A7105 CYRF6936 Multiprotocol TX Module--FREE TEST BG Tobey Radios 712 Oct 23, 2019 08:53 PM
New Product iRangeX R4X Pro 2.4G 4IN1 Multiprotocol External TX Module w/Battery BG Tobey DIY Electronics 60 Jun 18, 2018 02:06 PM
Discussion Multiprotocol modul 4 in 1 and MJX lolocaledo DIY Electronics 0 May 06, 2017 01:49 AM
New Product iRangeX R4X Pro CC2500 NRF24L01 A7105 CTRF6936 Multiprotocol External TX Module Drra Radios 0 Apr 17, 2017 09:50 PM