Motors don't spin until 50% - RC Groups
Thread Tools
May 04, 2017, 01:25 PM
DroneShotFPV
arcaine25's Avatar
Discussion

Motors don't spin until 50%


I am having an issue with my EagleTree Vector. I bought this specifically for use with my new MTD build. I have searched through here and didn't see an answer exactly, so maybe someone could help. I noticed last night while trying to finish my MTD build and maiden it this weekend, that when applying throttle, the motors do not spin until they reach 50%. Obviously this isn't normal, but I have no idea what could cause this unless somehow the ESC calibration didn't go as planned.

Anyone else have suggestions before I start doing drastic things? I will recalibrate tonight and test again, but hopefully there is a magic answer.

Thanks in advance.
Sign up now
to remove ads between posts
May 05, 2017, 03:40 AM
because rust never sleeps....
HugoRogers's Avatar
Quote:
Originally Posted by arcaine25
I am having an issue with my EagleTree Vector. I bought this specifically for use with my new MTD build. I have searched through here and didn't see an answer exactly, so maybe someone could help. I noticed last night while trying to finish my MTD build and maiden it this weekend, that when applying throttle, the motors do not spin until they reach 50%. Obviously this isn't normal, but I have no idea what could cause this unless somehow the ESC calibration didn't go as planned.

Anyone else have suggestions before I start doing drastic things? I will recalibrate tonight and test again, but hopefully there is a magic answer.

Thanks in advance.
What do you mean when you say the motors dont spin until *they* reach 50%.
I presume you mean that the motors dont spin until you reach 50% throttle input on your transmitter ?

I would have thought the first thing to try would be bypass the vector and see what happens when you drive the ESCs from the receiver. If it still behaves in the same way then this has nothing to do with the vector.
May 05, 2017, 05:46 AM
Registered User
... I think you must repeat the RX Wizard and pay attention to the throttle
May 05, 2017, 06:50 AM
DroneShotFPV
arcaine25's Avatar
Thanks for the input guys. I followed my instincts and re-calibrated my ESC's and it was fine (on the bench anyway, too much rain to fly and test). But a side note is one of the ESC's was also bad and I removed it from the splitter, re-calibrated the good one and tried again, so it could have been the bad ESC playing a role as well, but I won't know for sure until the new ones arrive.

This is my first twin motor plane build, and I was confused on connecting the motors to the vector. I assumed you use a splitter just like with ailerons, and everything I read suggested such, but I can't test until my new ESC's arrive. SO for now I am going to consider this resolved.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Quadcopter motors arm but don't spin up Skytop Multirotor Drone Electronics 2 Aug 19, 2017 07:17 PM
Discussion Slow arming / motor nervously spinning if i don't set a weirdly low min throttle Cellux Beginner Multirotor Drones 4 Jan 27, 2017 04:28 PM
Help! Skai Deng K70C motors don't spin Joukel Multirotor Drone Electronics 0 Oct 14, 2016 09:18 AM
Question Betaflight Hex layout 5&6 motors don't spin shadowjig Multirotor Drone Electronics 2 Sep 25, 2016 12:01 PM
Discussion Motors don't spin until 30% throttle CADQuad Multirotor Drone Electronics 1 Nov 22, 2014 07:24 AM