Thread Tools
Nov 06, 2017, 02:59 AM
Registered User
Can I drill out the BS15a 4in1 mounting holes to 3mm safely? They are M2 and the F4 mini is M3 which makes it hard to mount. Bit silly as they are designed to stack.
Sign up now
to remove ads between posts
Nov 24, 2017, 10:42 PM
HBS
HBS
Registered User

BeeRotor F4 Mini telemetry problem


I went through this discuss thread a couple of times, but couldn't find a solution for my problem, i.e., NOT getting telemetry on my Taranis.

Here is my setup:
- BeeRotor F4 Mini
- FrSky XSR receiver (S-Bus)
- I run a extra wire from XSR to get uninverted SmarPort signal, which is connected to RX3 on BeeRotor F4 Mini. I also soldered the SP pad (bridge the pad).
- In BetaFlight 3.1.7, typed in "set sport_halfduplex = OFF" in CLI

Several several attempts, still NO telemetry on my Taranis. Did I do something wrong? Any suggestions for getting telemetry?

Thanks!!
Nov 27, 2017, 06:25 PM
Registered User
Billj747's Avatar
Quote:
Originally Posted by rctimer

Our engineers always doing an amazing job, making all of our BeeRotor electronics more compact and stable! We pride ourselves on our service to EVERY customer, choosing only the best manufacturing processes and materials. I think we did once again! Meet our brand new BRF4MINI, it's smaller size, with an integrated PDB, 5V BEC, BFOSD - it's the perfect combination with the BS15A 4-1 MINI. We optimised it’s size, shrinking while maintaining the best quality money can buy - a tiny 4.1 grams!

Products link: http://rctimer.com/product-1771.html

Features
∑ Optimization for Betaflight/iNAV firmware
∑ STM32F405RG with 32bit/168MHz/1024KB Flash/192KB SRAM
∑ MPU6050A gyro and acc sensors via SPI bus
∑ On board BFOSD
∑ 1-wire signal receiver supported and smartport ready (on board diodes)
∑ 3 serial ports and 8 motors outputs
∑ Built-in BEC 5.3V/1.2A with 2~5S input
∑ Built-in PDB with up to 60A current supported, each esc pad up to 20A
∑ 6 layers with 3oz copper PCB designed
∑ Dimension 27x33mm
∑ Fixing hole spacing 20mm
∑ Weight 4.1g

MCU: STM32F405RG
IMU: MPU6050A (SPI) with Interrupt (this is the new name of ICM-20689)
BARO: no
VCP: yes
OSD: BFOSD
Hardware ISP: 3
Hardware uarts: 3
Blackbox: no
PPM/UART share: UART2
Frsky/smartport: UART3, integrated diode for smartport
Voltage sensor: on board voltage divider
Current sensor: no
Transponder/led-strip share: yes
Transponder driver: no
Bottons: 1-dfu
Status leds: 1






For the BeeRotorF4Mini Flight Controller with BFOSD / PDB

It says FrSky Rx SBUS connects to RX2, FrSky Telemetry (or smartport) to RX3. Does that leave RX1 open to use smartaudio?
Nov 30, 2017, 10:23 AM
Registered User
Billj747's Avatar
Or can you use smartaudio on RX3 (and solder SP pad) and use TX/RX1 for telemetry?

Anyone? @rctimer ?
Last edited by Billj747; Nov 30, 2017 at 10:30 AM.
Nov 30, 2017, 11:08 AM
HBS
HBS
Registered User
Quote:
Originally Posted by Billj747
Or can you use smartaudio on RX3 (and solder SP pad) and use TX/RX1 for telemetry?

Anyone? @rctimer ?
I started by using RX2 (solder SP pad) for SBus and RX3 for FrSky smartport telemetry on a 4' build with 1407 motors. But, the +5V right next to RX2 was providing only 2 - 2.5V, and XSR receiver couldn't be bound to my Taranis. So, I ended up having to use RX1 for Sbus. Unfortunately, even with this setup, either the 4in1 15A ESC and/or the FC burned after a few hovering flights. I will be replacing BeeRotor 4in1 ESC and FC with something else.
Jan 01, 2018, 03:12 AM
Registered User
Quote:
Originally Posted by rctimer
Hi gerdfranzm,

BRF4 no soft serial, if you want to use LED, there are two ways.
Any questions please talk with me.

Thanks.
Frank



Hi RCtimer,
I just got my new BRF4 board. I would like to install INAV 1.80 and enable barometer and M8N GPS with Mag . The receiver is Frisky XSR and plan to enable s.port . Can you tell me how to arrange UART port? Thank you!
Jan 02, 2018, 04:55 AM
Registered User
Hi,
sport_halfduplex = OFF isn't working with BF3.2.3
So I have tried set tlm_halfduplex = OFF
Connected the Smart Audio to RX+TX3 (with the diode) but it's still not working.

Is there a way to make Smart Audio work with UART3?
I need UARTs1+2 for GPS+Crossfire.

Thanks,
Gil.
Last edited by mrgilchen; Jan 02, 2018 at 06:14 AM. Reason: Edit
Jan 02, 2018, 11:17 AM
Registered User

s.port problem


Same problem with smartport and rctimer dissappeared
Jan 03, 2018, 07:02 AM
Registered User

Solution to these problems


As the manufacturer does not give solutions, I have been looking for and found another FC that I have not yet tested but has more features than this one: Matek F405 Mini
https://www.banggood.com/Matek-Syste...r_warehouse=CN

Bye, BeeRotor. I do not waste any more time with this controller.

MATEKF405 Target for Betaflight and iNAV.
Feb 05, 2018, 04:47 PM
Registered User
Hi,

BRF4 supports DShot 1200? I have installed BRF4 + Hobbywing Micro Esc 32bit DS1200 and my frame is unstable.

Do you any trick to configure this board with Betaflight?
Mar 10, 2018, 12:27 PM
Registered User
Can this board run 32KHZ?

I'm able to activate 32KHZ sampling and set 32KHZ Gyro and 16KHz PID Loop with DSHOOT600 but the quad won't arm. Any ideas why? CPU load is at 47%, also lower the cpu load with overclocking isn't helping.
Mar 29, 2018, 08:50 PM
hyperscorpic's Avatar
Bought this flight controller with high hopes. Tried to get smart audio working, but impossible. Tried RX3, TX2, RX2, cli commands...all not helping. Time to look for another flight controller....
Apr 07, 2018, 05:15 AM
s1m
s1m
Registered User
s1m's Avatar
In my case, I was mounting a 5" GEP TSX5 Viper with FRSky's AIO F4 controller-board-receiver combo, but was caught by surprise when the rectangular shaped board would not fit the frame standoffs.

Then I decided to use the BeeRotorF4 I had seating in a drawer.

After including a separate Smartport receiver the wiring was still clean as well as the build. (pic1)

First flights presented a severe Yaw twitch which I was not able to eliminate through PIDs or filters. Considering that my setup included a 1000uF cap, I discarded "electronic noise", and went for a new board fixation with softer mounting. From pic1 you will note that I already had softmounted the board.

A softer mounting reduced, but did not eliminate the Yaw twitch, but made me point in the right direction.

A third attempt isolating any possible frame feedback with custom silicone tubing allowing the controller board to "float" between absorbers totally eliminated the Yaw twitch. (pic2)

Regarding the build, I need to say that I was shocked to discover that the pinout instruction leaflet has wrongly identified the +5v input for the board, swapping them with the ground. Attached you will see the leaflet and the actual connection feeding the board (right side red cable). Latest instructions in RCTimer's web page are correct, but not the ones included in my board. Following the leaflet diagram would have burnt the +5v circuit of my 4xESC-PDB. (pic3)

Considering the discussions of the board recognizing the Smartport signal fed into a UART, I need to say that I got it running in the first attempt using the specific cable the board includes, that allows to feed the inverted signat of FrSky Smartport into the un-inverted UART that the F4 has (as all F4 boards do).

Defining UART3 as Smartport and introducing "set sport_halfduplex = OFF" in CLI, as instructed in the manual, allows me to have full telemetry out of the board.

The board has been flashed with Betaflight 3.3 and flies as a champ.
Jun 21, 2018, 08:03 AM
Registered User
Quote:
Originally Posted by s1m
I need to say that I was shocked to discover that the pinout instruction leaflet has wrongly identified the +5v input for the board, swapping them with the ground.
It's now Jun21, 2018; and those docs are still wrong . The product sales web page is correct as you noted, but the downloadable PDF manual is still wrong (the colour wiring diagram - bottom side). The manual shows it correctly in the first drawing of the bottom side (the one without wiring).

So it seems that to get DSHOT600 running on all four motors, you have to have LED STRIP turned off. That's unfortunate - my frame had multicolour leds designed into the bottom plate.. With the leds turned on, only 2 motors will spin. The manual does not say this. It does say to turn off leds for hex usage (6 motors).

Guess I'll test with DSHOT and no leds, then revert to multishot with leds for normal usage.. meaning no turtle mode.
Aug 15, 2018, 09:59 AM
Registered User
Iím using the Beerotor F4 Mini stack and experiencing the same issue as ďamisoftauĒ descript. When LED feature is turned on, only motor 1&2 spin. This issue only happen when running Betaflight v3.2.5 above. (3.2.5 works fine with LED and motor)

Informed Beerotor about the issue and they confirmed that it is a software (Betaflight) issue. However, they donít feel responsible to follow up the issue with Betaflight developers.

It is a very stable stack and IMO the best so far for small builds. Without support of latest software, too bad I have to give it up.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Protocols between flight controller and remote controls Slimmons UAV - Unmanned Aerial Vehicles 5 May 03, 2016 03:36 PM
Discussion Autonomous flight path opensource flight controller Titan33 Multirotor Drone Electronics 3 Nov 20, 2015 01:26 PM
Discussion HKPilot Mega 2.7 Flight Controller or DJI Naza-M Lite Multi-Rotor Flight Controller dsouza Multirotor Drone Electronics 3 Sep 08, 2015 10:25 AM