Frsky Vantac Q100 Quad - RC Groups
Thread Tools
Feb 11, 2017, 10:52 AM
Registered User
showmaster's Avatar
Discussion

Frsky Vantac Q100 Quad


A place to discuss the new Frsky comparable Vantac Q100 quad.
Tips on ch and SW setups, flight modes, as well as eepe's for the new Qx7.

Emphasis on the Qx7 and Q100 setups using Frsky or Otx 2.2, but Taranis and Horus is welcome.

Some helpful links
Modes
http://www.miniquadclub.com/naze32-f...des-explained/

Cleanflight setup, one of many out there

how to setup flight mode switches in cleanflight (7 min 32 sec)



Cleanflight CLI dump of working Q100


# dump



# version

# Cleanflight/ALIENFLIGHTF1 1.13.0 Jun 6 2016 / 00:06:24 (a77bc76)

# dump master



# mixer

mixer QUADX

mmix reset

mmix 0 1.000 -0.414 1.000 -1.000

mmix 1 1.000 -0.414 -1.000 1.000

mmix 2 1.000 0.414 1.000 1.000

mmix 3 1.000 0.414 -1.000 -1.000

mmix 4 1.000 -1.000 -0.414 -1.000

mmix 5 1.000 1.000 -0.414 1.000

mmix 6 1.000 -1.000 0.414 1.000

mmix 7 1.000 1.000 0.414 -1.000

smix reset





# feature

feature -RX_PPM

feature -VBAT

feature -INFLIGHT_ACC_CAL

feature -RX_SERIAL

feature -MOTOR_STOP

feature -SERVO_TILT

feature -SOFTSERIAL

feature -GPS

feature -FAILSAFE

feature -SONAR

feature -TELEMETRY

feature -CURRENT_METER

feature -3D

feature -RX_PARALLEL_PWM

feature -RX_MSP

feature -RSSI_ADC

feature -LED_STRIP

feature -DISPLAY

feature -ONESHOT125

feature -BLACKBOX

feature -CHANNEL_FORWARDING

feature -TRANSPONDER

feature RX_SERIAL

feature MOTOR_STOP

feature FAILSAFE

feature BLACKBOX





# map

map AETR1234





# serial

serial 0 1 115200 57600 0 115200

serial 1 64 115200 57600 0 115200





# led

led 0 15,15:ES:IA:0

led 1 15,8:E:WF:0

led 2 15,7:E:WF:0

led 3 15,0:NE:IA:0

led 4 8,0:N:F:0

led 5 7,0:N:F:0

led 6 0,0:NW:IA:0

led 7 0,7:W:WF:0

led 8 0,8:W:WF:0

led 9 0,15:SW:IA:0

led 10 7,15:S:WF:0

led 11 8,15:S:WF:0

led 12 7,7:U:WF:0

led 13 8,7:U:WF:0

led 14 7,8:WF:0

led 15 8,8:WF:0

led 16 8,9::R:3

led 17 9,10::R:3

led 18 10,11::R:3

led 19 10,12::R:3

led 20 9,13::R:3

led 21 8,14::R:3

led 22 7,14::R:3

led 23 6,13::R:3

led 24 5,12::R:3

led 25 5,11::R:3

led 26 6,10::R:3

led 27 7,9::R:3

led 28 0,0:::0

led 29 0,0:::0

led 30 0,0:::0

led 31 0,0:::0





# color

color 0 0,0,0

color 1 0,255,255

color 2 0,0,255

color 3 30,0,255

color 4 60,0,255

color 5 90,0,255

color 6 120,0,255

color 7 150,0,255

color 8 180,0,255

color 9 210,0,255

color 10 240,0,255

color 11 270,0,255

color 12 300,0,255

color 13 330,0,255

color 14 0,0,0

color 15 0,0,0





# mode_color

mode_color 0 0 1

mode_color 0 1 11

mode_color 0 2 2

mode_color 0 3 13

mode_color 0 4 10

mode_color 0 5 3

mode_color 1 0 5

mode_color 1 1 11

mode_color 1 2 3

mode_color 1 3 13

mode_color 1 4 10

mode_color 1 5 3

mode_color 2 0 10

mode_color 2 1 11

mode_color 2 2 4

mode_color 2 3 13

mode_color 2 4 10

mode_color 2 5 3

mode_color 3 0 8

mode_color 3 1 11

mode_color 3 2 4

mode_color 3 3 13

mode_color 3 4 10

mode_color 3 5 3

mode_color 4 0 7

mode_color 4 1 11

mode_color 4 2 3

mode_color 4 3 13

mode_color 4 4 10

mode_color 4 5 3

mode_color 5 0 9

mode_color 5 1 11

mode_color 5 2 2

mode_color 5 3 13

mode_color 5 4 10

mode_color 5 5 3

mode_color 6 0 6

mode_color 6 1 10

mode_color 6 2 1

mode_color 6 3 0

mode_color 6 4 0

mode_color 6 5 2

mode_color 6 6 3

mode_color 6 7 6



set looptime = 2000

set emf_avoidance = OFF

set i2c_highspeed = ON

set gyro_sync = ON

set gyro_sync_denom = 1

set mid_rc = 1500

set min_check = 1100

set max_check = 1900

set rssi_channel = 0

set rssi_scale = 30

set rssi_ppm_invert = OFF

set rc_smoothing = OFF

set rx_min_usec = 885

set rx_max_usec = 2115

set serialrx_provider = SBUS

set sbus_inversion = ON

set spektrum_sat_bind = 5

set input_filtering_mode = OFF

set min_throttle = 1000

set max_throttle = 2000

set min_command = 1000

set servo_center_pulse = 1500

set motor_pwm_rate = 32000

set servo_pwm_rate = 50

set 3d_deadband_low = 1406

set 3d_deadband_high = 1514

set 3d_neutral = 1460

set retarded_arm = OFF

set disarm_kill_switch = ON

set auto_disarm_delay = 5

set max_arm_angle = 25

set small_angle = 25

set fixedwing_althold_dir = 1

set reboot_character = 82

set gps_provider = NMEA

set gps_sbas_mode = AUTO

set gps_auto_config = ON

set gps_auto_baud = OFF

set telemetry_switch = OFF

set telemetry_inversion = OFF

set frsky_default_lattitude = 0.000

set frsky_default_longitude = 0.000

set frsky_coordinates_format = 0

set frsky_unit = IMPERIAL

set frsky_vfas_precision = 0

set hott_alarm_sound_interval = 5

set battery_capacity = 0

set vbat_scale = 110

set vbat_max_cell_voltage = 43

set vbat_min_cell_voltage = 33

set vbat_warning_cell_voltage = 35

set current_meter_scale = 400

set current_meter_offset = 0

set multiwii_current_meter_output = OFF

set current_meter_type = ADC

set align_gyro = DEFAULT

set align_acc = DEFAULT

set align_mag = DEFAULT

set align_board_roll = 0

set align_board_pitch = 0

set align_board_yaw = 0

set max_angle_inclination = 500

set gyro_lpf = 188HZ

set gyro_soft_lpf = 60

set moron_threshold = 32

set imu_dcm_kp = 2500

set imu_dcm_ki = 0

set pid_at_min_throttle = ON

set yaw_motor_direction = 1

set yaw_jump_prevention_limit = 500

set tri_unarmed_servo = ON

set servo_lowpass_freq = 400.000

set servo_lowpass_enable = OFF

set failsafe_delay = 2

set failsafe_off_delay = 0

set failsafe_throttle = 1000

set failsafe_kill_switch = OFF

set failsafe_throttle_low_delay = 100

set failsafe_procedure = 0

set acc_hardware = 0

set baro_hardware = 0

set mag_hardware = 0

set blackbox_rate_num = 1

set blackbox_rate_denom = 1

set blackbox_device = SERIAL

set magzero_x = 0

set magzero_y = 0

set magzero_z = 0



# rxfail

rxfail 0 a

rxfail 1 a

rxfail 2 a

rxfail 3 a

rxfail 4 h

rxfail 5 h

rxfail 6 h

rxfail 7 h

rxfail 8 h

rxfail 9 h

rxfail 10 h

rxfail 11 h

rxfail 12 h

rxfail 13 h

rxfail 14 h

rxfail 15 h

rxfail 16 h

rxfail 17 h



# dump profile



# profile

profile 0



# aux

aux 0 0 1 1300 2100

aux 1 1 0 900 1300

aux 2 2 0 1300 1700

aux 3 0 0 900 900

aux 4 0 0 900 900

aux 5 0 0 900 900

aux 6 0 0 900 900

aux 7 0 0 900 900

aux 8 0 0 900 900

aux 9 0 0 900 900

aux 10 0 0 900 900

aux 11 0 0 900 900

aux 12 0 0 900 900

aux 13 0 0 900 900

aux 14 0 0 900 900

aux 15 0 0 900 900

aux 16 0 0 900 900

aux 17 0 0 900 900

aux 18 0 0 900 900

aux 19 0 0 900 900



# adjrange

adjrange 0 0 0 900 900 0 0

adjrange 1 0 0 900 900 0 0

adjrange 2 0 0 900 900 0 0

adjrange 3 0 0 900 900 0 0

adjrange 4 0 0 900 900 0 0

adjrange 5 0 0 900 900 0 0

adjrange 6 0 0 900 900 0 0

adjrange 7 0 0 900 900 0 0

adjrange 8 0 0 900 900 0 0

adjrange 9 0 0 900 900 0 0

adjrange 10 0 0 900 900 0 0

adjrange 11 0 0 900 900 0 0



# rxrange

rxrange 0 1000 2000

rxrange 1 1000 2000

rxrange 2 1000 2000

rxrange 3 1000 2000



# servo

servo 0 1000 2000 1500 45 45 100 -1

servo 1 1000 2000 1500 45 45 100 -1

servo 2 1000 2000 1500 45 45 100 -1

servo 3 1000 2000 1500 45 45 100 -1

servo 4 1000 2000 1500 45 45 100 -1

servo 5 1000 2000 1500 45 45 100 -1

servo 6 1000 2000 1500 45 45 100 -1

servo 7 1000 2000 1500 45 45 100 -1



set gps_pos_p = 15

set gps_pos_i = 0

set gps_pos_d = 0

set gps_posr_p = 34

set gps_posr_i = 14

set gps_posr_d = 53

set gps_nav_p = 25

set gps_nav_i = 33

set gps_nav_d = 83

set gps_wp_radius = 200

set nav_controls_heading = ON

set nav_speed_min = 100

set nav_speed_max = 300

set nav_slew_rate = 30

set alt_hold_deadband = 40

set alt_hold_fast_change = ON

set deadband = 0

set yaw_deadband = 0

set yaw_control_direction = 1

set 3d_deadband_throttle = 50

set throttle_correction_value = 0

set throttle_correction_angle = 800

set default_rate_profile = 0

set gimbal_mode = NORMAL

set acc_cut_hz = 15

set accxy_deadband = 40

set accz_deadband = 40

set accz_lpf_cutoff = 5.000

set acc_unarmedcal = ON

set acc_trim_pitch = 0

set acc_trim_roll = 0

set baro_tab_size = 21

set baro_noise_lpf = 0.600

set baro_cf_vel = 0.985

set baro_cf_alt = 0.965

set mag_declination = 0

set pid_controller = LUX

set p_pitch = 40

set i_pitch = 30

set d_pitch = 23

set p_roll = 40

set i_roll = 30

set d_roll = 23

set p_yaw = 85

set i_yaw = 45

set d_yaw = 0

set p_alt = 50

set i_alt = 0

set d_alt = 0

set p_level = 20

set i_level = 10

set d_level = 100

set p_vel = 120

set i_vel = 45

set d_vel = 1

set yaw_p_limit = 500

set dterm_cut_hz = 0

set gtune_loP_rll = 10

set gtune_loP_ptch = 10

set gtune_loP_yw = 10

set gtune_hiP_rll = 100

set gtune_hiP_ptch = 100

set gtune_hiP_yw = 100

set gtune_pwr = 0

set gtune_settle_time = 450

set gtune_average_cycles = 16



# dump rates



# rateprofile

rateprofile 0



set rc_rate = 100

set rc_expo = 40

set rc_yaw_expo = 0

set thr_mid = 50

set thr_expo = 0

set roll_rate = 60

set pitch_rate = 60

set yaw_rate = 50

set tpa_rate = 0
set tpa_breakpoint = 1500

#
Last edited by showmaster; Jul 03, 2017 at 11:06 AM.
Sign up now
to remove ads between posts
Feb 11, 2017, 11:31 AM
Registered User
showmaster's Avatar
All new to me coming from fixed wing flying.
Got to start somewhere.
I could use help with cleanflight settings and screen shots. Especially the arming setting and a forced beginners flight mode.
I'm concerned about the modes being switchable in the beginning. I'm ok with "training wheels" mode to start.
One concern bench texting is the mode SW allows the motives to keep running after o flip the arm SW to off. Another mode it does kill the motor. I don't want this flying away?

What I'm having issues with is assigning the Aux modes to a channel and the 3 pos mode SW programming. Do I want 1000,1500, or 2000ms to be in the beginners mode?
I see where I can force a calibration mode in CF. Does this mean it also happens each time I power up the q100 or do I assign a SW to do that?
I've messed with the naze32 button and not sure if I've trashed the original programming!

A Vantac Q100 university would be great.
Maybe a sub to otx university?



Sent from my iPhone using Tapatalk Pro
Feb 11, 2017, 08:35 PM
Flingn' Chopstick
I'm coming from fixed wing, too.
I'm getting my feet wet with Cleanflight using a QX90. I have a FrySky Vantac Q100 in the mail. Perhaps another week. (along with a Taranis Q X7)
As for using Cleanflight, it can, (is) a bit complexed coming from fixed wing flying. I'm still new to it, (infant stage) but I like that you don't need to know how to adjust every setting to have a good experience flying. However, when I learn how to properly use a new setting, my flying experience is increased.
I've found some good info on youtube. One such place is Painless360. He does one of the better jobs in his explanations. Here's a link that includes his clmeanflight videos. https://www.youtube.com/user/Painles...ry=cleanflight
It's not easy to find info here for an old man who is new to this. Perhaps one day.
Feb 12, 2017, 10:10 AM
Registered User
showmaster's Avatar
Thanks for posting here. I think Aloft will be releasing a video soon on the site showing start up how to.
What I'm hoping, for is someone to post a working eepe for the x9d or Qx7 that can be used as a a template.
Also screen shots of a working q100 cleanflight tabs.
The mode SW option is puzzling. I find in some positions of I've programmed it correctly (3 pos SW) the motor kill/arm SW doesn't stop the motors.
I think I messed the SW assignment or the cleanflight settings up?
No idea of the stock setup as it arrived now.

Welcome to this thread, and I sure as it's discovered, we'll get the help we need.




Sent from my iPhone using Tapatalk Pro
Feb 12, 2017, 09:17 PM
Flingn' Chopstick
Thanks for the info.
I just got my Q X7 in the mail about 10 minutes ago. The Vantac Q100 will probably be here in a few more days. Then things will start to unfold... I hope.
Feb 12, 2017, 10:21 PM
Registered User
showmaster's Avatar
The issues I'm discussing in my case, shouldn't judge the product. Stupid me not knowing be XM receiver is on the under bottom of the frame ( never seen the XM receiver before) kept trying to bind using the naze32 button on the top frame board. I may have messed up its programming?

So, make sure you see that that receiver is on the of the frame.



Sent from my iPhone using Tapatalk Pro
Feb 19, 2017, 04:49 PM
Registered User

q100 firmware upgrade screw up


I'm newer than new....just received the q100 and also missed the boot button on the bottom...hence now can't load up firmware....When software access the bootloader it times out error immediately.
went through numerous videos and tried changing drivers as suggested but no work....I first tried connecting binding TX to receiver but as indicated used the wrong boot buttons both on the fc and fpv board....Did I screw the fc up as result?
Any suggestions would be appreciated!

Until then I will read on.....
Feb 22, 2017, 11:17 PM
Registered User
showmaster's Avatar
Sorry, I'm just getting back to my quad. My button pushing of the FC even at power up several times didn't keep me from accessing the FC via USB and the cleanflight pgm.
I was also able to bind to my qx7 once I used the receive bind button.
It's been a week and I'll have to go through the FC connect again to be of any help.
One issue was having to load and use chrome to run cleanflight.
Just a bother to load and run it.

My concern is I don't think the props do what they should when I tip of the quad. Also when I use the mode SW, (can't remember the ch right now) the props won't stop with low throttle it kill SW?
That's where I put it all on hold. I find that if I step away awhile and try fresh again, usually it all works out.

Tell me if you've made any progress since your post? I'll try and be more active here in the next few days.



Sent from my iPhone using Tapatalk Pro
Mar 14, 2017, 04:47 PM
Registered User
showmaster's Avatar
Getting back to this quad.
I'm pretty sure I've got the min, center, Max setting ok now. It's suggested that they be 1000, 1500, and 2000 ms in a review on Aloft's site.
I've set a SW on ch5 to be Aux 1 to arm the motors.
I've set Aux 2 to be the 3 pos mode SW but not sure what the modes are?
I'm playing with that.
I've set the gyro on a level service.

No flying yet.
What's holding me up is when trying a static hand holding test, I can vary the quads angle , but when I center the aileron/elv stick, the quad doesn't go to back to a level condition. Instead it seems to want to stay at its last angle of attack?
Being new to a more advanced FC quad vs the $40 syma type that does return to level, I'm sure I'm missing something.

Hopefully others will read this thread and reply.
I'm trying to not clutter up the Qx7 threads with this Q100 discussion.
Only as a last resort.


Sent from my iPhone using Tapatalk Pro
Mar 15, 2017, 02:57 AM
Registered User
Well I have a problem with vantac q100 and Taranis x7 as I've gone through all the setups adjusted taranis for arm switch aux1,, mode switch aux2 for angle/horz/acro them with clean flight on the FC, everything looks good in cleanflight motors calibrated and run up smoothly. But when I try to test flight no matter what I do I can't arm the motors.
Only time the motors will run is when I enable one-shot then motors just run up when battery added with no throttle control.

Would be great to get a CLI dump with a working vantac q100 to see if I can determine the problem....running F1 version 1.14.1

Any assistance would be appreciated
Mar 15, 2017, 04:32 AM
Registered User
showmaster's Avatar
Quote:
Originally Posted by JADavis
Well I have a problem with vantac q100 and Taranis x7 as I've gone through all the setups adjusted taranis for arm switch aux1,, mode switch aux2 for angle/horz/acro them with clean flight on the FC, everything looks good in cleanflight motors calibrated and run up smoothly. But when I try to test flight no matter what I do I can't arm the motors.
Only time the motors will run is when I enable one-shot then motors just run up when battery added with no throttle control.

Would be great to get a CLI dump with a working vantac q100 to see if I can determine the problem....running F1 version 1.14.1

Any assistance would be appreciated

I'm not having motor arm issues. All my stick and 3 pos SW are set to be 1000-1500-2000ms cleanflight, watching while I adjust the qx7's values.
I do find that even after arming the motors with ch 5 SW, I think I have to cycle the throttle up and back down to arm.
I'll pay more attention and report my findings.
The aux 2 angle/horz/acro you've just described is new to me and now thanks to you, I know what it's called.
Any idea what mode self levels? I thought the FC knows to do that when the sticks return to center?

I'll post my cleanflight setting and maybe we can work out our different issues.
Thanks for joining my thread. I thought I was alone and the only one struggling.






Sent from my iPhone using Tapatalk Pro
Mar 15, 2017, 11:34 PM
Registered User
JADavis and showmaster, any chance to check if the Channel Map as circled represents your radio correctly?
Mar 16, 2017, 02:16 AM
Registered User
showmaster's Avatar
I just saw your post. Too late tonight.
I'll check it tomorrow and post what I see.



Sent from my iPhone using Tapatalk Pro
Mar 16, 2017, 12:01 PM
Registered User
showmaster's Avatar
This is what I see. Not quite like your screen but the same info?



Sent from my iPhone using Tapatalk Pro
Mar 17, 2017, 04:57 AM
Registered User
Quote:
Originally Posted by showmaster
This is what I see. Not quite like your screen but the same info?



Sent from my iPhone using Tapatalk Pro
Thanks showmaster, would you pls contact our techical support @ sales4tech@gmail.com, so they can help get it fixed, thanks!


Thread Tools