X24 Integrated Flight Control System - Page 4 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
This thread is privately moderated by JimDrew, who may elect to delete unwanted replies.
Jun 27, 2017, 10:13 PM
Registered User
Quote:
Originally Posted by FlyingW
Chuck,

That is an amazing piece of work. Looking at it makes me want to be a better engineer. The Space Race must have been heaven for the technically minded.

Paul
It was! I got the assignment when the first writer ask said he didn't want another temporary assignment. I said yes before finding that it was for a six months loan to the Mercury design team.

Chuck
Sign up now
to remove ads between posts
Jun 28, 2017, 08:42 AM
Yes, there are multiples of frequnecies called "orders" due to harmonics. 915Mhz times 2 (the 2nd order) would be 1830MHz, and the 3rd order would be 2745MHz both of these orders are well out side of the range of GPS and 2.4GHz control systems.

I am little surprised that 433MHz interferes though. Typically you see a 20dBm drop in power per order (at least your are suppose to per FCC requirements). The 3rd and 4th order frequencies would be 1299MHz and 1732MHz, both of which are still outside of the GPS frequencies. You must have some horrible 433MHz radios!
Jun 28, 2017, 09:13 AM
Build more, websurf less
FlyingW's Avatar
Holybro 3DR-type 433MHz radios.

http://www.getfpv.com/holybro-500mw-...v2-433mhz.html

I noticed that if you let the GPS acquire satellites before turning on the radio, then it generally holds on to them. However if I pass the 433MHz antenna very close to the GPS antenna, it immediately drops all its sats.

Maybe these units are little monsters - I could try dialing back the power.

In the meantime I'll go with the RFU and the 100mw 915MHz telemetry radios.

Thanks for the explanation.
Jun 28, 2017, 09:15 AM
They probably output way more power than stated, resultIng in out of band bleed over. This is very common for devices coming out of China. However, in all fairness you should have a 18" separation between any co-located antenna systems, even if both are just receiving.
Jun 28, 2017, 09:39 AM
Build more, websurf less
FlyingW's Avatar
I just powered up the system with the 915MHz radios and the GPS fails to acquire sats. Disconnected the 915s and GPS came alive. Even at 18" apart. Poop.

I now think it is another problem with ArduPlane and the Navio2 - maybe with the interface setup or the hardware itself.

I'll stop filling your X24 thread with these experiences. I suppose though that when the X24 gets into the flight controller business, then there will be many similar questions in this forum. It will be fun though!

Thanks,

Paul
Last edited by FlyingW; Jun 28, 2017 at 10:47 AM.
Jul 24, 2017, 04:50 PM
Build more, websurf less
FlyingW's Avatar
Here are some plots from my OpenLRS "spectrum analyzer" that comes with the open-source software for 433MHz radios.

The first photo is the Mission Planner setup for the telemetry radios. The TX power is set for 17 on a range of 1 to 20. I found that changing this value made little difference in what the units put out.

The second picture is the spectrum analyzer with the telemetry radio off. The third is with the telemetry radio turned on. Seems like a lot of activity on either side of 433.050-434.790MHz where it is supposed to operate.

The GPS just refuses to operate with these things turned on.
Last edited by FlyingW; Jul 24, 2017 at 05:29 PM.
Jul 24, 2017, 07:25 PM
Time to put the GPS receiver on a 3' stick!
Jul 24, 2017, 10:40 PM
Build more, websurf less
FlyingW's Avatar
Now I'm depressed
Jul 25, 2017, 10:41 PM
That's what we have to for UAVs!
Jul 31, 2017, 02:01 PM
Registered User
I've got a couple of questions for you Jim. I've got a X24, and I'm having a couple of problems. One, the BEC is not shutting off with the transmitter switch. The output port E1 is set to channel 9 or off, it doesn't seem to matter. The BEC is set to channel 9 and I can see in the display that when I flip the switch I get the indicator the BEC is being turned on and off. I also see the LED go on and off as expected. It never actually shuts it off. Do you have any explanations?

Two, there are times when the pin and flag switch isn't powering the unit off. I can't re-create the problem on demand. Occasionally, the pin/flag switch has no effect, and it just won't shut off. I disconnect power and sometimes that resets the problem and other times not. Any ideas?

Three, I think it's drawing a lot of power. I'm barely getting three flights on two 3600mah batteries, and that's from 8.2v to 7.4v in three flights. The engine isn't starting well either. It will pop on choke, but then after a few flips when it should be popping and another flip or two starting, it just sputters, runs out of gas, and I have to choke it again. A couple of times with that pattern and then it starts. I don't know if that's related to the BEC or not, but I'm inclined to go back to a separate battery and see if it makes a difference. Comments?

Edited to add: I figured out the BEC part. I got it in my head that the BEC was on E1 and E2. It's actually on D2 and E2. On E1, I was just getting constant battery voltage. Hope it didn't hurt my ignition!
Last edited by brettc; Jul 31, 2017 at 02:58 PM.
Jul 31, 2017, 03:33 PM
Yeah, the BEC is on D2 and E2, not E1 or any other ports.

What pin and flag switch are you using?

The X24 itself draws less than 30mA when running, so perhaps the excessive current draw was due to the ignition box being powered by the servo bus voltage directly?
Jul 31, 2017, 04:33 PM
Registered User
Quote:
Originally Posted by JimDrew
Yeah, the BEC is on D2 and E2, not E1 or any other ports.

What pin and flag switch are you using?

The X24 itself draws less than 30mA when running, so perhaps the excessive current draw was due to the ignition box being powered by the servo bus voltage directly?
I don't know about the current draw. It's going to take a bit more to pin that down. If it's still sucking it down, I'll still bring out a separate battery and switch for the ignition and at least rule that out. Let's skip that for now.

I have the pin and flag switch you shipped me. I don't recall the brand.

When I look at it on the bench it seems to work fine. I can't duplicate the problem. Button up the canopy, and come back after a flight, and it just won't turn off. It's happened a couple of times.
Aug 05, 2017, 02:17 AM
Yes, the issues will occur at the "orders", which is the frequency multiplied. So, 433x2=866, 433x3=1299, etc. The orders are the strongest signals at multiplied frequencies.
Aug 05, 2017, 02:07 PM
Build more, websurf less
FlyingW's Avatar
Looks like 433x3=1299 is right in the middle of the GPS range.

I installed dipole antennas from Video Aerial Systems on my 915MHz telemetry radios. The new antennas more than doubled the range and solved the problem.
Last edited by FlyingW; Aug 05, 2017 at 02:23 PM.
Aug 06, 2017, 04:35 PM
Registered User
Jim,

I've been trying to pin down this problem with the main switch. I tried it all different ways at the house, and it worked perfectly. I took it to the field today, flew it, and it wouldn't shut off. I cycled the power, and it still won't turn off. After 15-20 min unpowered, I turned it on, and the switch works again. After another flight, I put in the pin, and it shuts off. Pulled the pin out, put it back in, and again, it won't turn off. Let it sit unpowered, turn it back on, and it won't turn off.

There doesn't seem to be a lot of consistency with the functionality of this switch. Do you have any ideas? Is this a failure? Do you have any ideas as to why it's doing this? Is there anything I can try that would help?


Thread Tools