Thread Tools
This thread is privately moderated by JimDrew, who may elect to delete unwanted replies.
Mar 18, 2020, 09:44 PM
Thread OP
I experimented with the X24 and I can't find any situation where when the failsafe handler is set to X24 and every channel has failsafe enabled AND set to USER, where the live-active failsafe does not work as it should. Keep your failsafe handler set to "Rx" and I will continue to look into this further.
Sign up now
to remove ads between posts
Mar 22, 2020, 08:48 AM
Registered User
Well I finally gave up trying to match my hitec servo’s. I followed all the directions and thread info but it just wouldn't work. I had zero trouble with my BLS 172’s matching so thats what I switched to.
Mar 22, 2020, 12:19 PM
Thread OP
Unfortunately, any servo that has a failsafe that can not be disabled requires quite a few steps for the matching to work.
Mar 22, 2020, 04:23 PM
Registered User
It’s all good. I’ll never have another plane without this unit.
Mar 22, 2020, 04:44 PM
Registered User
Quote:
Originally Posted by Jc71
Itís all good. Iíll never have another plane without this unit.
^^^^^^^^^
Mar 22, 2020, 09:28 PM
Registered User
Well I hope I can figure it out. I have 14 Hitec 9381’s going in a 60% cub that will need to match.
Mar 23, 2020, 01:46 AM
Thread OP
It works with Hitec servos. We have a lot of people using them. The newer Hitec servos have the option of disabling the failsafe, but I am not sure exactly when that started. I need to chat with Mike at Hitec about that.
Mar 23, 2020, 11:30 PM
Registered User
My hitec’s came in last week so they are the newest ones. I’ll give them a call when I get to that point.


Quick Reply
Message:

Thread Tools