Trouble with bound FrSky XSR receiver - RC Groups
Thread Tools
Jan 31, 2017, 07:49 PM
Registered User
Help!

Trouble with bound FrSky XSR receiver


Hello.

I purchased an XSR receiver for my Taranis X9D Plus and I was able to bind it at first. A couple of days later I repowered my quad and I get a blinking red LED on the XSR and my Taranis is going in a loop where there voice says, “Telemetry lost, telemetry recovered, rf signal critical…” every 30 seconds or so over and over again and the XSR LEDs are blinking red and very quickly blinking green. It keeps connecting and disconnecting over and over again and the radio detects the receiver for a second, then disconnects when the signal is lost. So I bought a new XSR receiver and installed it. It paired fine and worked, but after a couple of days it’s doing the same thing as the old XSR.

Any ideas?

Running a Taranis X9D Plus with v2.1.9.

Thanks!
Sign up now
to remove ads between posts
Jan 31, 2017, 09:34 PM
Balsa addiction since age 3
ScottSails's Avatar
How close is your transmitter to the receiver? Are the receiver antenna's blocked by carbon?
Has the transmitter been used before or is it new? It is possible it has a bad antenna...
Scott
Jan 31, 2017, 09:46 PM
Registered User
Scott,

I've tried it inside the house, outside the house, TX close to the RX and far away. The receiver's antennas are currently bare sitting outside the quad, nothing blocking them. This is the second transmitter (a point I inadvertently omitted in the OP), first one was used, the one I have currently is brand new (near as I can tell) from Amazon.

Is it possible that there is something wrong with the software on the TX? I ask because I can't recall if this latest failure to lock pairing occurred AFTER I upgraded the stock firmware (2.1.6) to the latest 2.1.9. The bootloader still says 2.1.6, even though the previous TX I had updated the bootloader also to 2.1.9 during the update process.

Here's a video of what happens when I apply power to the quad. You can hear the Taranis going bonkers in the background with the LEDs on the XSR blinking red with the green LED blinking ever so quickly. (The constant green glow is from an LED panel mounted right above the RX)

https://www.dropbox.com/s/dfj7hqabld...27.15.mp4?dl=0

Thanks for you help.
Jan 31, 2017, 10:21 PM
Registered User
My original reply is stuck in the clearinghouse awaiting mod approval since it contained a link to a video of my XSR being wonky. So to answer your questions in the meantime:

I've tried in near, far, inside the house, outside the house. Antenna not blocked. This is the second Taranis I've tried over the past week trying to resolve this, so probably not an antenna problem.
Feb 01, 2017, 03:58 AM
Registered User
Let's see if this works:

Here's a video of the XSR hijinks,

Problem With XSR and Taranis X9D Plus (0 min 42 sec)
Feb 01, 2017, 06:44 PM
Balsa addiction since age 3
ScottSails's Avatar
The Taranis was in D16 mode when you did the bind?
Voltage to the receiver is ok?
Feb 01, 2017, 07:57 PM
Registered User
Yes, D16, CH1-C16.

I put it on a voltmeter and it's getting 5.74 volts to the power lead.
Feb 01, 2017, 09:54 PM
Balsa addiction since age 3
ScottSails's Avatar
Ok, maybe disconnect your receiver from the ESC BEC and run direct to an appropriate battery? 4 cell NiMH or NiCD if you have one?
Do you have multiple BEC's in parallel?

As I recall, I do get RF signal low, telemetry lost if within say 1-2ish feet of receiver...
Last edited by ScottSails; Feb 01, 2017 at 10:29 PM.
Oct 31, 2017, 10:49 PM
Registered User

How is your XSR holding up?


I am having the same issue here. I got a used quad and for the first week it was bound and had good signal, but then I ran into the same issue as you. Did you end up resolving it? I saw you posted on Reddit as well and said that you got a new one and it worked. Is that new one still working? Maybe this is just a part flaw...?