E-flite UMX P-51D - RC Groups
Thread Tools
This thread is privately moderated by peterswolf, who may elect to delete unwanted replies.
Jan 30, 2017, 12:02 PM
Registered User
peterswolf's Avatar
Data

E-flite UMX P-51D


Aug 1, 2016

In the mail today I received the new E-flite UMX P-51D. It runs on 2S power system and has AS3X. I bound the plane to my DX9 and did the new model setup, setting dual rates as 70% travel and 15% expo on low settings. I also put a drop of glue on the control arm joiners as I've had some issues recently on my UMX where they slip apart from the factory. Glue will dry overnight and I hope to maiden in the morning.
Sign up now
to remove ads between posts
Jan 30, 2017, 12:03 PM
Registered User
peterswolf's Avatar

Aug 2, 2016


After reading last night about a possible range issue due to glue, before heading out to maiden at the field I thought I'd range check in my backyard. Indeed it seems my range was slightly less than expected. So I headed back into the house to open her up and check for glue as mentioned on RCGroups. Before I headed back into the house I just did a flight surface check and noticed the rudder and elevator were not responding. I turned everything off and then back on and still nothing. There was no sounds at all coming from inside the plane when trying to move rudder or elevator. The rudder wouldn't budge, and now if moving by hand, the elevator was loose as can be. The ailerons worked fine and the motor went ok. So I'm not going to bother opening this one up but rather see if I can just send it back to Horizon Hobby for a replacement.

UPDATE: HH didn't even offer a replacement, simply money back, I guess they are having lots of issues with this release?