Thread Tools
Jan 17, 2020, 07:41 PM
Ghost Rider the pattern's full
santanig5's Avatar

New owner


Well, I picked up one of these used today, this New to Me is the largest warbird in my fleet, but will go nicely with my 1400mm P-51 B and 1450mm T-28.
Now to read through this thread!
Are there any gotchas I should be aware of before my maiden?
I did purchase from a club mate and have seen it fly, not so secretly admiring it from the pits so I know she is in working order and the setup is good.

TIA
Santa
Sign up now
to remove ads between posts
Jan 17, 2020, 09:16 PM
Registered User
I purchased a used one also a few weeks ago that was in beautiful shape! I flew it a few times, before I lost orientation on base leg and cracked it up a bit. Fortunately, I got it all back together and it looks great (epoxy, CA, and money can do that) :-)

What I learned with mine from a pro who has one also, is on take off, don't use flaps, ease the throttle and use about 75% for takeoff. Otherwise, the torque will make it roll a bit on liftoff, and causes your pucker factor to increase! Once it's in the air, it's awesome to fly and looks and sounds great. When getting ready to land, ease the throttle back to about 40% on downwind and lower the flaps to the first level. Continue on downwind and just before turning base, ease the throttle back to about 20%. Depending on wind you may not even need full flaps at this point. Let it sink down and set up on final. If there is little wind, extend the flaps all the way. Crosswind however; can be a bit of a challenge. You still need just a bit of throttle all the way down. About 3 feet off the ground, ease back on the elevator and let it settle in. Keep the elevator stick all the way back once it hits the ground and stops flying to prevent it from nosing over... Expect to break the landing gear doors, so order a few sets now!! I'm thinking of painting invasion stripes on the bottom side just for increased visibility. For me, sometimes it gets a bit hairy up against a gray sky, but yellow lense sunglasses definitely helps!

I'm sure others have other procedures and tips that help them, but this is what I was taught by a pro and it works very well for me.. I also coated mine with Mod Podge to help with the hanger rash, and installed one piece connector harness for the wings (see my previous posts) Good luck with it!
Jan 18, 2020, 03:27 AM
Registered User

Elevator and Rudder pushrods


Hey does anyone have any tips on the pushrods. I have tightened the screws down but kind of worried about them coming loose. How did any of you take care of this? did you file a flat spot on the rod there or maybe locktight the screw? or both or maybe something else? Please let me know. Thanks.
Jan 18, 2020, 03:35 AM
Registered User
JPJI's Avatar
Stuart from MotionRC did a good video with take off tips:

FlightLine Spitfire MK.IX 1600mm - Flight Review - Motion RC (11 min 31 sec)
Jan 18, 2020, 09:53 AM
Retired US Navy
Evan D's Avatar
Mine has at least a hundred flights on it. Half flaps for take off and half or full landing depending on wind. At least some throttle to touchdown...
Jan 18, 2020, 03:11 PM
Registered User
Hi all, I’m about to maiden mine as well in the next few days weather dependent. Good vid by Stuart but I now have a potentially dumb question .....how do you slow down the esc ‘servo’ speed as he suggests to make the torque not quite so abrubt?

Is this normally a transmitter or esc programming card function? I take it it’s the latter as I can’t find anything in my DX6 trans programming that would suggest its done there.?.....

Cheers for the advice.
Kurt
Jan 18, 2020, 03:27 PM
Retired US Navy
Evan D's Avatar
To slow the spool up of the motor some ESCs have a soft start setting.
Jan 18, 2020, 03:32 PM
Registered User
JPJI's Avatar
Quote:
Originally Posted by Beetlemankurt
Hi all, Iím about to maiden mine as well in the next few days weather dependent. Good vid by Stuart but I now have a potentially dumb question .....how do you slow down the esc Ďservoí speed as he suggests to make the torque not quite so abrubt?

Is this normally a transmitter or esc programming card function? I take it itís the latter as I canít find anything in my DX6 trans programming that would suggest its done there.?.....

Cheers for the advice.
Kurt
Its done in the transmitter.
On Spektrum gen 2 transmitters:
Click selector roller to bring up menu
Select 'servo setup'
click on 'travel' and scroll across to 'speed'
that screen then allows you to alter the throttle servo speed. (i.e. slow down the response speed to your input)

Personally, I don't like it. I'd rather just feed the throttle in slowly with my trusty throttle thumb....
Jan 18, 2020, 03:52 PM
Registered User
Thanks guys, that’s awesome. Yeah, not too sure I’d like a delay either but thought I’d try both options. Much appreciated

Regards
Kurt
Jan 18, 2020, 07:32 PM
FPV Air Combat Nut!
turbinefancy's Avatar
Not the FL version but I thought Iíd share it for giggles. Close call at 4:30. Tried for three-pointer landing at 5:30. Enjoy!

FPV Dogfight: Spitfire vs F-14 Tomcat (7 min 5 sec)
Jan 18, 2020, 11:48 PM
Registered User
That's Gold! What an awesome video and well edited too. For the record, I thought you had em! I'd have words with whoever loaded your ammunition as it looked like it was faulty for sure.

Nice work, cheers. Kurt.
Jan 19, 2020, 02:38 AM
Registered User

Flaps issue


Hi, I was wondering if anyone experienced this problem before. I think it could be the blue box but not sure. Everything works great until I lower flaps and then the elevator goes up and the ailerons go into a left bank turn. Oddest thing I have ever seen. Does anyone have any ideas? I super appreciate any feedback.
Jan 19, 2020, 02:46 AM
Registered User
Hi there, what do you have in your flap Menu mix set up in your transmitter? I’d start there. There should be a small amount of up elevator mixed into the different flap settings as per the manual.....double check that nothing weird has accidentally been mixed with the aileron as well? Could be something simple like this if the plane flies well the rest of the time.
If you’ve got any doubts about the blue box you could always try some y leads to eliminate this from the equation.
Good luck!
Kurt
Jan 19, 2020, 03:19 AM
Registered User
Quote:
Originally Posted by Beetlemankurt
Hi there, what do you have in your flap Menu mix set up in your transmitter? I’d start there. There should be a small amount of up elevator mixed into the different flap settings as per the manual.....double check that nothing weird has accidentally been mixed with the aileron as well? Could be something simple like this if the plane flies well the rest of the time.
If you’ve got any doubts about the blue box you could always try some y leads to eliminate this from the equation.
Good luck!
Kurt
I figured it out. My receiver was automatically going into gyro on when I lowered flaps even when I had it disabled in the controller. It is a new receiver. I had to go in while flaps were lowered and configure all switch positions for gyro to off to turn it off. I normally fly without it, so all good. Thanks for responding.
Jan 19, 2020, 03:25 AM
Registered User
No worries, pleased you got it sorted. Happy flying!
Kurt


Quick Reply
Message:

Thread Tools