Thread Tools
Dec 28, 2016, 07:00 AM
Registered User
Thread OP
Discussion

Arducopter 3.4.3 - Unable to perform "ROI" or "Point camera here"


As in the object, my quad with a pixhawk running arducopter 3.4.3 stable, can't execute "ROI" or the "Point camera here".

The quad perform Loiter, alt-hold and auto mission very very well, and even guided and circle mode works with no problem at all..

In auto mode i have inserted a ROI in a simple mission and the quad completely ignore it: when it arrive at the ROI, it dosen't yaw (i have a tarot t2d 2 axis gimbal) to point in the ROI direction and the gimbal don't point down at the desired ROI altitude.

I have tested the "point camera here" too: the quad doesn't yaw in the desired direction, and the camera rotate 90 degrees up and it remains blocked in that position unitl i land and disconnect the battery.. Mission planner give an error at this point: "The Command failed to execute".


Below a link to my google drive folder with some ***.bin files of my test, the mission.txt file of the auto mission, the full parameter list of my pixhawk (parameter.param) and the screen shot of the mission planner's error.
https://drive.google.com/open?id=0B6...GJ2dmVQMm9ONWc
Sign up now
to remove ads between posts
Dec 29, 2016, 10:52 AM
KD2PBU - Fly No Evil
davidbitton's Avatar
I suggest reposting this question here.
Dec 29, 2016, 12:51 PM
Registered User
Thread OP
I have already posted in that forum ..still not tip from other users at the moment..
May be in the next few days i will try another automission with different settings..

For the moment again many thanks
Jan 02, 2017, 09:49 AM
Registered User
Thread OP
The problem is solved!!

I'd like to share with the comunity the solution: it was a my error with the configuration parameters.

My gimbal configuration was like the procedure described in the wiki, so i have used my radio channel 6 ti control the gimbal tilt connected to the aux1 (rc9) on the pixhawk.

And then, i have used my radio channel 8 to control the gimbal operation mode with another wire connected on the aux2 (rc10) of the pixhawk, but my error was to configure this part, in the gimbal setup page of the mission planner, in the "pan" section.
From the radio the gimbal work as expected, but in auto mode, the drone won't yaw itself in the ROI direction.

The solution was to configure properly the gimbal operation mode like described in the mike_kelly guide, all credits goes to him.

So i have moved the wire connected to the tarot "operation mode switch", from aux2 (rc10) of the pixhawk, to the motor output8 and then i have configured the rc8 like below:

Quote:
RC8_DZ,0
RC8_FUNCTION,1 --> passthrough of rc8 of my radio
RC8_MAX,1900
RC8_MIN,1100
RC8_REV,-1 --> inverted
RC8_TRIM,1504
With this configuration my quad execute correctly all the ROI waypoints in auto mission, as well as commands like "point camera here" from tower and after a little bit of adjustment of the pwm values on my taranis, even the control of the gimbal from the radio is perfect.
Aug 30, 2017, 06:16 PM
Ultimate Noob.
Thanks for getting back to us with your solution.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Arducopter 3.4.3 - Unable to perform "ROI" or "Point camera here" massimilianonbal Multirotor Drone Electronics 0 Dec 28, 2016 06:41 AM