Dec 22, 2016, 09:00 AM
Registered User
Quote:
Originally Posted by OctavioMaia View Post
Mine is at costums as well. Should have it tomorrow too
this was really fast at this time of year.
Sign up now
to remove ads between posts
Dec 22, 2016, 10:23 AM
Registered User
I just placed my order with Heli Nation and received a shipping notice already! I am so stocked to try this out.
Dec 22, 2016, 11:00 AM
Registered User
Quote:
Originally Posted by downloader9 View Post
this was really fast at this time of year.
Let's hope it's delivered tomorrow.
Sadly my Taranis wasn't delivered yet... 23 days have passed
Dec 22, 2016, 11:51 AM
Registered User
Chargerdude70's Avatar
Hopefully this pairs well with my RaceFlight Revolt
Dec 22, 2016, 07:06 PM
Registered User
Quote:
Originally Posted by Chargerdude70 View Post
Hopefully this pairs well with my RaceFlight Revolt
I will see that tomorrow, but should be perfect
Dec 23, 2016, 03:13 AM
Registered User
It seems this baord does not work well with 1200tvl CMOS cameras. Really unfortunate.

I've now had the V1 and V2 RROSD and both have had major issues for me. The first one has horrid noise. I've been told by others that the V2 also has bad noise issues sometimes. Now I finish my build and I have to go back to using a hugely inferior hs1177 because it doesn't like 1200tvl?
Dec 23, 2016, 04:33 AM
Registered User
Quote:
Originally Posted by eatkabab View Post
It seems this baord does not work well with 1200tvl CMOS cameras. Really unfortunate.

I've now had the V1 and V2 RROSD and both have had major issues for me. The first one has horrid noise. I've been told by others that the V2 also has bad noise issues sometimes. Now I finish my build and I have to go back to using a hugely inferior hs1177 because it doesn't like 1200tvl?
Not really, I used the v1 with the 1200tvl monster from Foxeer, no problems at all... The problem must be you don't use the recommended voltage cap low esr...
Dec 23, 2016, 08:32 AM
Registered User


Thanks Tony
Dec 23, 2016, 10:19 AM
Registered User
Chargerdude70's Avatar
Quote:
Originally Posted by OctavioMaia View Post


Thanks Tony
Wait a minute. Were we supposed to get a beeper? Mine didn't come with.
Dec 23, 2016, 12:22 PM
Registered User
Quote:
Originally Posted by downloader9 View Post
Not really, I used the v1 with the 1200tvl monster from Foxeer, no problems at all... The problem must be you don't use the recommended voltage cap low esr...
I'm using it as recommended. Please explain to me what this crap is on my screen and I would be very appreciative if you could help me remove it. I don't even care about moving the readout to the bottom of the screen. That's the lowest it goes when you go to the movement setting.
Dec 23, 2016, 12:49 PM
Registered User
Just tested the V2 on a 600tvl cam and it works perfect. It is NOT compatible with 1200tvl cameras. Such a shame.
Dec 23, 2016, 01:39 PM
Registered User
That may be NTSC vs PAL. On my v1, if I had PAL running on an NTSC camera then the readout was adjusted up, among other issues. You might just want to try the board with your 1200 tvl camera and change the NTSC/PAL settings in the RRv2 OSD to see if that fixes your issue.

Good luck.
Dec 23, 2016, 04:01 PM
Registered User
JRey's Avatar
Quote:
Originally Posted by Infernal Bill View Post
That may be NTSC vs PAL. On my v1, if I had PAL running on an NTSC camera then the readout was adjusted up, among other issues. You might just want to try the board with your 1200 tvl camera and change the NTSC/PAL settings in the RRv2 OSD to see if that fixes your issue.

Good luck.
I agree, hold down the button and switch between the between NTSC and PAL. Takes about 10 seconds.
Dec 23, 2016, 04:04 PM
Registered User
JRey's Avatar
Quote:
Originally Posted by eatkabab View Post
Just tested the V2 on a 600tvl cam and it works perfect. It is NOT compatible with 1200tvl cameras. Such a shame.
Try switching between PAL and NTSC.
Dec 23, 2016, 06:02 PM
Registered User
Thanks guys. That worked a treat. Good OSD now. Glad that was put into it.

Just for others, you need to hold the button for ~10sec while plugging in. Button pushed when you power it.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product RedRotor RROSD Pro Mini PDB bt408 Mini Multirotor Drones 1708 Mar 17, 2017 08:14 PM
New Product STRIDER 250mm - Next Generation Multirotor With Onboard RROSD Engine RedRotorRC Mini Multirotor Drones 2905 Feb 28, 2017 04:32 PM
For Sale RedRotor Lap time starter kit for RROSD Pro mini harris414 FPV Equipment (FS/W) 1 Dec 06, 2016 06:41 PM
Sold Falcon Multirotors 160 BNF SPRF3, XM20, RROSD, ZMX v2 2633kv cacjb Aircraft - Electric - Multirotor (FS/W) 1 Jul 14, 2016 01:27 PM
For Sale Redrotor Strider Qaud with RROSD engine - built in OSD and PDB (Folds too!) unitedhvy Aircraft - Electric - Multirotor (FS/W) 0 Feb 24, 2016 05:07 PM