Thread Tools
Nov 20, 2016, 03:47 PM
Registered User
Thread OP
Discussion

HELP! Hubsan 501S will not bind to 501 transmitter after Firmware update


Just updated my Hubsan 501S Quad and the matching standard TX (basic one with screen) with the latest firmware from Hubsans own website and now they refuse to bind.
I Put the Tx into "BIND WITH PLANE" power up the quad and oput theTX very close as instructed The LEDS blink purple , then Orange, Then flash once white then go around strobing red. I've tried repeating this umpteen times. I think the update just cost me a quad!
Anyone had this issue or know where I can get the old firmware to reinstall?
Thanks
Dave
Sign up now
to remove ads between posts
Nov 24, 2016, 01:31 AM
Registered User
I had the same problem. Initially I had the heli and the TX approx 20 cm apart. After actually making the TX touch the nose of the drone it paired.
Nov 29, 2016, 11:43 AM
Registered User
I had same problem. I do reflash FC firmware and that's working
Mar 30, 2017, 03:22 AM
Registered User
How do you flash your firmware back??
Aug 11, 2017, 10:58 PM
Registered User
Question from a 501s newbie.
I am new this year to quad flying and aerial video and 5.8 and all that ...

That said what is the talk of firmware upgrades for a 501s? I just started flying mine and love it.
But I can't figure out a few things. One of which is your talk of firmware. Do I need to do this regularly?
How does it all work? How do I do it? How do I know what I need? Do I need to do the same to the transmitter?
Just looking to understand.
Also is there a sport mode with flips and rolls and stuff on this quad?


Quick Reply
Message:

Thread Tools