Horus X12S - Connection to PC Lost - RC Groups
Thread Tools
Nov 08, 2016, 10:46 PM
Registered User
Help!

Horus X12S - Connection to PC Lost


The problem I am having now is-
I have no communication between the Horus and my PC's.
I used two different PC one with a Windows 10 OS and one with an Windows XP OS
I have no communication when connecting the USB cable with either the Horus turned ON or OFF.
I installed the Open TX OS using the Windows 10 PC and Open TX Companion 2.2.
The Horus is now running the Open TX OS. It seams to be running OK.
I have tried the following:
Rebooting the PC's
Re-installing the Zadig Bootloader.
Re-installing Open TX Companion
Three different USB cables
Making another SD from the OpenTX nightly and trying it.
Removing Open TX Option 1 - Flashing the FrTX Bootloader and Firmware -Using FrTX Companion Backup
Removing Open TX Option 2- Flashing the FrTX dfu - One Step Using FrTX firmware.
Normal FrTX OS Firmware Update - Using Firmware Bin Files

Other Information-
When I connect the UBS Cable with the turned Horus ON the UBS cable Symbol on the Horus main screen appears and both the computers and the Horus make connection make their binging sounds. But, the SC card and the Flash memory do not appear in the Windows File Explorer.
Also the STM 32 Bootloader appears in the Device Manager under Universal Serial Bus devices.

When I connect the USB cable with the Horus OFF the STM 32 Bootloader appears in the Device Manager under Universal Serial Bus devices. But, Open TX Companion 2.2 doesn't communicate with the Horus. Also both the computer and the Horus make connection make their binging sounds when they are connected with the Horus turned off.

Does someone know what is going on here?
Does anyone know how I can correct this?

I have had a Taranis since right after you first started selling and have managed to keep it updated and operation quite successfully sometimes with a little help from you but this now has me dead in the water as I can't revert to the FrSky OS or update the OpenTX OS.
Last edited by CJhock; Nov 09, 2016 at 04:47 PM.
Sign up now
to remove ads between posts
Nov 09, 2016, 02:08 PM
Registered User
In my description of the problem I miss stated the alternate Windows OS I tried I should have typed XP OS.
Last edited by CJhock; Nov 09, 2016 at 04:45 PM.
Nov 11, 2016, 05:58 PM
Registered User
jsparky's Avatar

can not load opentx on horus


If you ever figure it out let me know.. I am having the same problem.. the same computer I use for my taranis.. will not install the zadig stm32 bootloader.. and will not connect to my horus.. OS is win 7 .. So I got a clean new install of win 7 on a drive and still the zadig would not install.. and neither would companion 2.2.. The best I can get is to turn on the horus , plug in the cable and start zadig.. then it will show the horus as a device.. but will still not install the boot loader.. So how is it that so many have installed opentx on a horus and I am having so many problems..

BTW I just purchased this radio on Nov 9/16 ... it is the second production run to come to Canada.. so wondering if FrSky has changed something..
Nov 11, 2016, 07:11 PM
Registered User
mpjf01's Avatar
I recommend that you ask these questions in the main Horus thread here

https://www.rcgroups.com/forums/show....php?t=2727927

many Horus experts are subscribed and someone will respond to your posts
Nov 13, 2016, 05:55 PM
Registered User

FedEx has Horus X12S Now


I tried as suggested and posted it on the main thread but have only gotten replies from people who did not read the post. Everything they have suggested so far I have already tried and is explained in the origional post.
At the US distributor, Aloft Hobbies, request I have sent the radio back to them and FedEx now has it.
I can now only hope the problem is not something I missed or did or did not do.
This is the second Horus I have had. The first had the switch labels missing and incorrect. SA and SB labels were missing Switches SC and SD were labeled SA and SB. Go figure. I never tried to install OpenTX on that radio but did updated the FrTX OS using the instructions from the FrSky and OpenTX down load web sites. Aloft Hobbies sent me a new Horus. I assume from the from the next batch or radios they received. This second one is the one I now have this problem with.
Nov 14, 2016, 06:31 PM
Registered User
You are right I never said I checked the Massstorage box in OpexTx 2.2.
Although I don't have the radio now I have gone over the "OpenTx Firmware and FrTX Flashing with Windows Open TX Companion" again and can find only one reference to the Massstorage Box on page 3.
I wonder why it is not stated to check this box in the actual flashing instructions?
Now that I am aware of its significance it is probably one of my problems.
But it doesn't explain why is was unable to flash back to FrTx OS.
I tried three different USB cables All of which work with my Taranis and other numerous devices such as a remote hard drive, an Eagle Tree Guardian 2D/3D Inertial Stabilizer, etc.
I guess I should have heeded one of the other General Warnings on page 3 -" If you are not an expert user of OpenTx Companion you may have problems returning to your X12S to FrTX"

All this is kind of moot now that I sent the radio back to the distributor at their request.
Thanks for the help and information.
Feb 24, 2017, 08:25 PM
Faster pussycat
fasterpussycat's Avatar

same problem here


Quote:
Originally Posted by CJhock
The problem I am having now is-
I have no communication between the Horus and my PC's.
I used two different PC one with a Windows 10 OS and one with an Windows XP OS
I have no communication when connecting the USB cable with either the Horus turned ON or OFF.
I installed the Open TX OS using the Windows 10 PC and Open TX Companion 2.2.
The Horus is now running the Open TX OS. It seams to be running OK.
I have tried the following:
Rebooting the PC's
Re-installing the Zadig Bootloader.
Re-installing Open TX Companion
Three different USB cables
Making another SD from the OpenTX nightly and trying it.
Removing Open TX Option 1 - Flashing the FrTX Bootloader and Firmware -Using FrTX Companion Backup
Removing Open TX Option 2- Flashing the FrTX dfu - One Step Using FrTX firmware.
Normal FrTX OS Firmware Update - Using Firmware Bin Files

Other Information-
When I connect the UBS Cable with the turned Horus ON the UBS cable Symbol on the Horus main screen appears and both the computers and the Horus make connection make their binging sounds. But, the SC card and the Flash memory do not appear in the Windows File Explorer.
Also the STM 32 Bootloader appears in the Device Manager under Universal Serial Bus devices.

When I connect the USB cable with the Horus OFF the STM 32 Bootloader appears in the Device Manager under Universal Serial Bus devices. But, Open TX Companion 2.2 doesn't communicate with the Horus. Also both the computer and the Horus make connection make their binging sounds when they are connected with the Horus turned off.

Does someone know what is going on here?
Does anyone know how I can correct this?

I have had a Taranis since right after you first started selling and have managed to keep it updated and operation quite successfully sometimes with a little help from you but this now has me dead in the water as I can't revert to the FrSky OS or update the OpenTX OS.



Same problem here...is there a fix?
Jan 05, 2018, 02:02 AM
Engineer
hayataro's Avatar
Although this is a bit old issue....
I have same probrem. In my case, at Hours switched off, two or three times pull-and-plug USB connector then ding and appears "STM32 Bootloader" in device manager of my computer.

I changed the USB port USB2.0, USB3.0, via a USB-HUB,,, etc,, and found that is very similar my old job of USB device development using USB2.0. (Cypress CY7C68013 USB 1chip LSI)

My device was hard to recognize from computer, sometimes success but sometimes bad. Finally I determine the cause of this issue, two SMT resistors in series to USB data signal. They located between USB-connector with USB-controller.

These resistors protect surge/noise from USB connector, But they distort the USB waveform too. I used two 22Ohm but finally I took resistors and connect directry, then probrem was solved.
Jan 29, 2018, 02:01 AM
Registered User
Quote:
Originally Posted by CJhock
The problem I am having now is-
I have no communication between the Horus and my PC's.
I used two different PC one with a Windows 10 OS and one with an Windows XP OS
I have no communication when connecting the USB cable with either the Horus turned ON or OFF.
I installed the Open TX OS using the Windows 10 PC and Open TX Companion 2.2.
The Horus is now running the Open TX OS. It seams to be running OK.
I have tried the following:
Rebooting the PC's
Re-installing the Zadig Bootloader.
Re-installing Open TX Companion
Three different USB cables
Making another SD from the OpenTX nightly and trying it.
Removing Open TX Option 1 - Flashing the FrTX Bootloader and Firmware -Using FrTX Companion Backup
Removing Open TX Option 2- Flashing the FrTX dfu - One Step Using FrTX firmware.
Normal FrTX OS Firmware Update - Using Firmware Bin Files

Other Information-
When I connect the UBS Cable with the turned Horus ON the UBS cable Symbol on the Horus main screen appears and both the computers and the Horus make connection make their binging sounds. But, the SC card and the Flash memory do not appear in the Windows File Explorer.
Also the STM 32 Bootloader appears in the Device Manager under Universal Serial Bus devices.

When I connect the USB cable with the Horus OFF the STM 32 Bootloader appears in the Device Manager under Universal Serial Bus devices. But, Open TX Companion 2.2 doesn't communicate with the Horus. Also both the computer and the Horus make connection make their binging sounds when they are connected with the Horus turned off.

Does someone know what is going on here?
Does anyone know how I can correct this?

I have had a Taranis since right after you first started selling and have managed to keep it updated and operation quite successfully sometimes with a little help from you but this now has me dead in the water as I can't revert to the FrSky OS or update the OpenTX OS.
I have a very similar problem that I have been working on for weeks with no success. I would pull my hair out if I had any


Quick Reply
Message:

Thread Tools