Holybro Shuriken X1 **Owners Thread** - Page 3 - RC Groups
Thread Tools
Dec 20, 2016, 10:15 AM
Registered User
nitbeat's Avatar
Quote:
Originally Posted by mythek
does anyone know if the SpiroNet antenna is RHCP or LHCP?
I don't see why it would be LHCP, I bet its RHCP
Sign up now
to remove ads between posts
Dec 25, 2016, 12:44 PM
Registered User

Shuriken x1 vibration on low throttle


Since the first day I was trying to remove a severe yaw vibration of my new shuriken X1. It only happend at low throttle values around 1350 ms but it shakes all the quad.

Here you have a video with the problem:

Shuriken x1 problem low throttle (0 min 39 sec)


and here you have a black box log in debug mode if anybody can help me

https://www.dropbox.com/s/jno5wx8bop...01819.TXT?dl=0

In the picture you can see a simple forward fly just in the range of problem throttle value.
Dec 25, 2016, 01:43 PM
Registered User
nitbeat's Avatar
Quote:
Originally Posted by moriwaky
Since the first day I was trying to remove a severe yaw vibration of my new shuriken X1. It only happend at low throttle values around 1350 ms but it shakes all the quad.

Here you have a video with the problem:

https://www.youtube.com/watch?v=Kxwj_8vqR_4

and here you have a black box log in debug mode if anybody can help me

https://www.dropbox.com/s/jno5wx8bop...01819.TXT?dl=0

In the picture you can see a simple forward fly just in the range of problem throttle value.
Its very common more than you think actually, it has a few names:
Mid throttle oscillations, yaw twiches, yaw shutters ext...

it has several causes but from my own experience and research it is caused by noise and specific resonance that affect
the gyro sensor & specifically the Yaw gyro.

But, on the table without the props is not the best test, because the resonance that creates the noise to the gyro
can be different than the one in the air with props.

You need to fly and test your throttle while flying strait in different speeds, if you see twitches in the video you might need some
trouble shooting.

35V 1000uf capacitor right on the main power input on the PDB might help, and also softmounting the FC.

I had this problem and softmounting the FC and the capacitor helped a lot.

ohh and try to read this part of the betaflight wiki:
https://github.com/betaflight/betafl...-I-solve-this-

read -> # 56
I get Yaw twitches or mid-throttle oscillations. How do I solve this ?

good luck
Dec 25, 2016, 03:14 PM
Registered User
Quote:
Originally Posted by nitbeat
Its very common more than you think actually, it has a few names:
Mid throttle oscillations, yaw twiches, yaw shutters ext...

it has several causes but from my own experience and research it is caused by noise and specific resonance that affect
the gyro sensor & specifically the Yaw gyro.

But, on the table without the props is not the best test, because the resonance that creates the noise to the gyro
can be different than the one in the air with props.

You need to fly and test your throttle while flying strait in different speeds, if you see twitches in the video you might need some
trouble shooting.

35V 1000uf capacitor right on the main power input on the PDB might help, and also softmounting the FC.

I had this problem and softmounting the FC and the capacitor helped a lot.

ohh and try to read this part of the betaflight wiki:
https://github.com/betaflight/betafl...-I-solve-this-

read -> # 56
I get Yaw twitches or mid-throttle oscillations. How do I solve this ?

good luck
thanks for the sugestions, I saw the vibration in flight too. I have posted blackbox flying the shuriken where you can see the yaw vibrations in a simple forward flight. I think like you is a problem of resonating frequency of the frame affecting the gyro. I have solder a cap on the power leads and didnīt make any diference. I have add some yaw lowpass on betaflight but the vibrations still there. I have solder ground leads to the esc, change bheli s firmware, tried dshoot. multishot, oneshot125. diferents props and nothing helpme much.
The last thing I will try is to insolate the flight controller but very very dificult on this frame because of the integration all in one board.

I litte bit disapointed because this is a ready to fly quad and this kind of problems must be solve before leave factory. Anyway I still think is a great quad
Dec 25, 2016, 04:42 PM
Registered User
nitbeat's Avatar
Quote:
Originally Posted by moriwaky
thanks for the sugestions, I saw the vibration in flight too. I have posted blackbox flying the shuriken where you can see the yaw vibrations in a simple forward flight. I think like you is a problem of resonating frequency of the frame affecting the gyro. I have solder a cap on the power leads and didnīt make any diference. I have add some yaw lowpass on betaflight but the vibrations still there. I have solder ground leads to the esc, change bheli s firmware, tried dshoot. multishot, oneshot125. diferents props and nothing helpme much.
The last thing I will try is to insolate the flight controller but very very dificult on this frame because of the integration all in one board.

I litte bit disapointed because this is a ready to fly quad and this kind of problems must be solve before leave factory. Anyway I still think is a great quad
I completely understand your frustration I had this problem and tried everything to solve until finally I succeeded.
You're right they should check these issues before it leaves the factory.

The reason why not all shurikan experience this problem is that some gyro sensors on the same FC model has different sensitivities.

I really hope you'll be able to solve this, its also better to just verify its not the FPV camera, my friend had a loose sensor board,
and the shakes was from the fpv camera video.
Dec 25, 2016, 11:38 PM
And Repairs
TyFlies's Avatar
Thinking about getting one. Have been flying a Nighthawk on 3S. I don't need as much speed as this X1 is capable of on 4S yet. I've got some 3S 1800 graphene batteries - would the X1 do ok on those? (Until I step up to 4S)

Anything I should know about props, etc on 3S?
Thanks.
Dec 26, 2016, 07:26 AM
Registered User
nitbeat's Avatar
Quote:
Originally Posted by TyFlies
Thinking about getting one. Have been flying a Nighthawk on 3S. I don't need as much speed as this X1 is capable of on 4S yet. I've got some 3S 1800 graphene batteries - would the X1 do ok on those? (Until I step up to 4S)

Anything I should know about props, etc on 3S?
Thanks.
you don't need to change anything for 3S (in terms of hardware), it will feel a little "tired"
and you won't have a good thrust to do tight turns but maybe in an early stage you don't need this kind of a kick.

maybe you do have to raise the PID values a bit.

enjoy
Dec 26, 2016, 09:33 AM
And Repairs
TyFlies's Avatar
Thanks for the advice. That's exactly the info I needed.
Dec 26, 2016, 11:10 AM
Registered User
At the end I find the solution using a silent block for the motor as Joshua said the insolation the FC is not an option on the shuriken X1. Either was adjusting the notch filter because the frequency of the vibrations were too low. Now really is smooth and I can pump D a little more to remove de prop wash also I mod the esc removing the signal cap and I am using dshot600 without any kind of problems. I hope my solution will be crash resistant because now is time to fly fast and crash hard!
Enviado desde mi SM-N9005 mediante Tapatalk
Dec 26, 2016, 11:36 AM
And Repairs
TyFlies's Avatar

Replacement props?


Just ordered.
I'd like to go ahead and get some durable replacement props ordered from somewhere. I'm not looking for top performance yet - durability and flight time / efficiency would be the two main objectives.

Unless somebody recommends otherwise I will get DAL brand props. I believe it takes 5 inch props, but I'm not sure what angle to get.

Any thoughts would be great.
Dec 26, 2016, 11:41 AM
Registered User
nitbeat's Avatar
Quote:
Originally Posted by moriwaky
At the end I find the solution using a silent block for the motor as Joshua said the insolation the FC is not an option on the shuriken X1. Either was adjusting the notch filter because the frequency of the vibrations were too low. Now really is smooth and I can pump D a little more to remove de prop wash also I mod the esc removing the signal cap and I am using dshot600 without any kind of problems. I hope my solution will be crash resistant because now is time to fly fast and crash hard!
Enviado desde mi SM-N9005 mediante Tapatalk
Wow! I read that it's better to isolate the motor from the frame rather than the FC, looks like a lot of work though.

Could you share a link for the guide or the material used?
Dec 26, 2016, 12:12 PM
Registered User
Quote:
Originally Posted by nitbeat
Wow! I read that it's better to isolate the motor from the frame rather than the FC, looks like a lot of work though.

Could you share a link for the guide or the material used?
yeah of course I will post everything and the modification for the esc to running dshot600. Out of home right now.
Last edited by moriwaky; Dec 26, 2016 at 04:14 PM.
Dec 26, 2016, 05:01 PM
Registered User

solve yaw vibration


here you have all the thing I have done step after step until I have solve my yaw vibration on the shuriken.

1 First I tried playing with PID but inmediatly saw it wasnīt a PID problem.
2 Then I review a blackbox log to ensure the vibration was on yaw axis at 1350 throttle value.
3 I change the notch filter to try overcome the vibrations.. not succes.
4 I added on cli yaw_lowpass = 10 and was little bit better.
5 I figure out that the esc are this one

Racerstar RS30A V2 30A http://www.banggood.com/Racerstar-RS...p-1072073.html

so I found this post and remove the cap to use dshot protocol using blheli s 16.5

https://www.rcgroups.com/forums/show...postcount=1645

After upgrading betaflight version to 3.0.1 and select dshot600. But the vibration still there checkout the video here:
Shuriken x1 problem low throttle (0 min 39 sec)


So after some users as @Joshua and @nitbeat sugested maybe the yaw vibration was produced by resonating frequency of the frame or by electrical noise in the gyro chip. So I installed a cap 35v 1000uF on the power leads. No improvements.

So at this point the answer to my problem was elimiante or change the resonance frequency of my frame by insolate the flight controller (to dificult on the shuriken X1) or insolating the motors. So to confirm the problem I unscrew all the motor with out the propellers and a start the motos as my youtube video and Eureka!!! no vibration, so at this point is confirmed not and electrical noise, only was the resonation of the frame.

To insolate the motor I have use rubber gromets from heli canopy I had on the very botton of my desk but you can find similar ones here:

https://hobbyking.com/en_us/rubber-g...10pcs-set.html

I split then in half, I used a little bit longer screw and I put each half of the grommet as you can see on this pictures

After that the vibration on yaw axis has gone, I pump my d on the default PIDs to 40 on roll and 42 on pitch and I am running dshot600 4k/4k with no problems.

It flies amaizing And itīs very very sharps on turn and rolls. I really love the quad right know. But as I salid before I little bit dissapointed because this is a ready to fly quad and must leave the factory without this kind of troubles. I think that the perfect solution would be that the guys at www.undergroundfpv.com use gyro chip mount as the holybro shuriken 180, because there the gyro chip is insolate of the rest of the board if they do this for the shuriken v2 and add a 25 mw power mode for the VTx would be a "shut up an take my money" for sure.
Last edited by moriwaky; Dec 26, 2016 at 05:09 PM.
Dec 27, 2016, 12:37 AM
Registered User
nitbeat's Avatar
Quote:
Originally Posted by moriwaky
here you have all the thing I have done step after step until I have solve my yaw vibration on the shuriken.

1 First I tried playing with PID but inmediatly saw it wasnīt a PID problem.
2 Then I review a blackbox log to ensure the vibration was on yaw axis at 1350 throttle value.
3 I change the notch filter to try overcome the vibrations.. not succes.
4 I added on cli yaw_lowpass = 10 and was little bit better.
5 I figure out that the esc are this one

Racerstar RS30A V2 30A http://www.banggood.com/Racerstar-RS...p-1072073.html

so I found this post and remove the cap to use dshot protocol using blheli s 16.5

https://www.rcgroups.com/forums/show...postcount=1645

After upgrading betaflight version to 3.0.1 and select dshot600. But the vibration still there checkout the video here:
https://www.youtube.com/watch?v=Kxwj_8vqR_4

So after some users as @Joshua and @nitbeat sugested maybe the yaw vibration was produced by resonating frequency of the frame or by electrical noise in the gyro chip. So I installed a cap 35v 1000uF on the power leads. No improvements.

So at this point the answer to my problem was elimiante or change the resonance frequency of my frame by insolate the flight controller (to dificult on the shuriken X1) or insolating the motors. So to confirm the problem I unscrew all the motor with out the propellers and a start the motos as my youtube video and Eureka!!! no vibration, so at this point is confirmed not and electrical noise, only was the resonation of the frame.

To insolate the motor I have use rubber gromets from heli canopy I had on the very botton of my desk but you can find similar ones here:

https://hobbyking.com/en_us/rubber-g...10pcs-set.html

I split then in half, I used a little bit longer screw and I put each half of the grommet as you can see on this pictures

After that the vibration on yaw axis has gone, I pump my d on the default PIDs to 40 on roll and 42 on pitch and I am running dshot600 4k/4k with no problems.

It flies amaizing And itīs very very sharps on turn and rolls. I really love the quad right know. But as I salid before I little bit dissapointed because this is a ready to fly quad and must leave the factory without this kind of troubles. I think that the perfect solution would be that the guys at www.undergroundfpv.com use gyro chip mount as the holybro shuriken 180, because there the gyro chip is insolate of the rest of the board if they do this for the shuriken v2 and add a 25 mw power mode for the VTx would be a "shut up an take my money" for sure.
woww !! you're tha man dude ! I'm adding a reference to this detailed post of yours.
GOOD JOB
Dec 30, 2016, 11:48 PM
Registered User
Quote:
Originally Posted by moriwaky
here you have all the thing I have done step after step until I have solve my yaw vibration on the shuriken.

1 First I tried playing with PID but inmediatly saw it wasnīt a PID problem.
2 Then I review a blackbox log to ensure the vibration was on yaw axis at 1350 throttle value.
3 I change the notch filter to try overcome the vibrations.. not succes.
4 I added on cli yaw_lowpass = 10 and was little bit better.
5 I figure out that the esc are this one

Racerstar RS30A V2 30A http://www.banggood.com/Racerstar-RS...p-1072073.html

so I found this post and remove the cap to use dshot protocol using blheli s 16.5

https://www.rcgroups.com/forums/show...postcount=1645

After upgrading betaflight version to 3.0.1 and select dshot600. But the vibration still there checkout the video here:
https://www.youtube.com/watch?v=Kxwj_8vqR_4

So after some users as @Joshua and @nitbeat sugested maybe the yaw vibration was produced by resonating frequency of the frame or by electrical noise in the gyro chip. So I installed a cap 35v 1000uF on the power leads. No improvements.

So at this point the answer to my problem was elimiante or change the resonance frequency of my frame by insolate the flight controller (to dificult on the shuriken X1) or insolating the motors. So to confirm the problem I unscrew all the motor with out the propellers and a start the motos as my youtube video and Eureka!!! no vibration, so at this point is confirmed not and electrical noise, only was the resonation of the frame.

To insolate the motor I have use rubber gromets from heli canopy I had on the very botton of my desk but you can find similar ones here:

https://hobbyking.com/en_us/rubber-g...10pcs-set.html

I split then in half, I used a little bit longer screw and I put each half of the grommet as you can see on this pictures

After that the vibration on yaw axis has gone, I pump my d on the default PIDs to 40 on roll and 42 on pitch and I am running dshot600 4k/4k with no problems.

It flies amaizing And itīs very very sharps on turn and rolls. I really love the quad right know. But as I salid before I little bit dissapointed because this is a ready to fly quad and must leave the factory without this kind of troubles. I think that the perfect solution would be that the guys at www.undergroundfpv.com use gyro chip mount as the holybro shuriken 180, because there the gyro chip is insolate of the rest of the board if they do this for the shuriken v2 and add a 25 mw power mode for the VTx would be a "shut up an take my money" for sure.
great post! i cannot wait to receive my x1


Quick Reply
Message:

Thread Tools