Thread Tools
Oct 01, 2016, 05:10 PM
Registered User
Discussion

Updated to firmware 1.11 and Powerlab 6 no longer starts


Hi,

My powerlab 6 is no longer starting. Today i purchased a new 5200mah Lipo, so i went into the pc software (using USB cable) to update one of the profiles to match a 2C charge of 10.4amps.. Anyway i noticed that it said there was a firmware update from my 1.10 to 1.11, so i went ahead and did it.

Updated my profile and even charged my battery. However now it does nothing after a powerdown and power back up.

It turns on, but the LCD just stays blank, with the top row solid blocks. It doesn't beep or anything.

I've tried unplugging every cable, and using the USB cable in an attempt to get it to fire up.

Is there a reset process ? There are no errors.. Just an LCD that lights up with the top row, with black blocks ?

Please help.
Sign up now
to remove ads between posts
Oct 01, 2016, 05:31 PM
Registered User
I read somewhere that you can re-install the firmware, just make sure you have an internet connection. Well i have an internet connection, since i'm posting this off the same laptop that's running the FMA RC software. and i'm getting the following error. BTW i've removed power for well over the 30secs, and well just about tried everything now. O/S is Win10 Pro Ver 1607. FMA RC software ver is 1.22

Error with Firmware Update. Try the Following Steps

1) Remove power from the PowerLab 6. Remove the adapter from the PowerLab 6. Wait 30 seconds.
2) Apply 12-24V power to the PowerLab 6. Connect the PC adapter to the PowerLab 6.
3) Try a different Comm Port (bottom left)
4) Make sure the Comm Port is OPEN

**edit** Just want to add that i also used a windows 7 64bit laptop, incase there was a win10 compability issue, along with the latest downloaded FMA RC software, & obviously re-downloaidng the FUMI3 drivers, and its doing the same thing.

Not good.
Last edited by thedoc46; Oct 01, 2016 at 06:20 PM.
Oct 05, 2016, 09:10 PM
Registered User
i got a brand new charger that i updated to v1.11 and then charged a battery to test unit out. all was fine. put it up for dinner and then i went back to it later and had a blank screen with just a row of gray boxes. i never could get it to run again and i tried reflashing several times. called fma and talked to support and they had me send it in. my advice would be to do just that. i got mine back in about a week and it works great now.

good luck
Oct 07, 2016, 09:24 AM
No bounce, No play.
davidmc36's Avatar
Thanks for that guys. Will be leaving mine at 1.10.

What was supposed to be the advantage of the new FW anyway?
Oct 07, 2016, 11:49 AM
Registered User
Quote:
Originally Posted by krauley
i got a brand new charger that i updated to v1.11 and then charged a battery to test unit out. all was fine. put it up for dinner and then i went back to it later and had a blank screen with just a row of gray boxes. i never could get it to run again and i tried reflashing several times. called fma and talked to support and they had me send it in. my advice would be to do just that. i got mine back in about a week and it works great now.

good luck
I'm having a real hard time with FMA's customer service. They're being pretty rude to me. Telling me, that i'll probably be charged for the repair, and how dare i accuse them of saying their firmware bricked their power supply, and being all snotty saying, well if i don't want them to repair it, then they'll just send it back.. and that i need to accept the charge.. Great CS btw !!!!! Basically i'm not exactly being nice back. Why would i be? THEIR FIRMWARE BRICKED MY $175 Powerlab 6, and i just wish they'd accept responsibility, take down the firmware so others don't go thru the same... Its clear i'm not the only person this has happened too. Clearly there's a problem, and i'm going to be charged for this. Actually by the time I'm done paying what they're going to ask, and shipping, i could of just bought a different charger. BY A DIFFERENT MANUFACTURER !!!

Sorry for my rant but i'm pretty mad right this sec.

If they fix this, and have a change of heart on CS, i'll take all this back... but as it stands, do not update your chargers. Overwise you'll be in the same predicament as i am.
Apr 25, 2017, 08:01 PM
Registered User
*edit*
Last edited by fpvnoobe; Apr 25, 2017 at 08:27 PM.