Taranis Not Recognised USB Nightmare - RC Groups
Thread Tools
Sep 20, 2016, 09:33 AM
Registered User
Help!

Taranis Not Recognised USB Nightmare


I love my Taranis. I hate my Taranis.
I have two of these, a 9D and a 9E. Neither will now connect to OpenTx Companion.
By the way I've cursed Zadig a few times, and the complexity of the Taranis/USB hook up.

I'm only now learning some things that would have save a few curses.
First: The STM32Bootloader does not show in Device Manager until I USB connect the Tx with power off. It disappears when I use the “3 finger salute” power on. So I imagined a vital component was missing when I looked in Device Manager - after a three finger salute (loads of confusion)
Second: I've just noticed I get an entry under libUSB-win32 Devices, namely FrSky Taranis Radio (appears twice)

So I have a couple of devices visible under Device Manager in different circumstances, and when I use the three finger salute turn on, the Tx shows Taranis Bootloader 2.1.8, so I guess I have a bootloader in the Tx?

Notwithstanding the above, I cannot see any extra drives popping up, or get the Tx recognised by OpenTx Companion.

Should I buy a new computer and start again? Anyone familiar enough to help on this one?

Ken Barrie
Sign up now
to remove ads between posts
Sep 20, 2016, 08:35 PM
Registered User
1. Generally you do not need Zadig with the Taranis since OpenTX 2.0
2. You use the Bootloader instead... The "three finger" method...and generally you can just plug in the Taranis and it will display USB Connected and show up as two drives...

X:TARANIS
Y:Removeable Disk

where X: and Y: vary with the system. Removeable Disk is the SD card and TARANIS is a the presentation of the EEPROM that Companion read and writes to and you should not mess with. you can copy things to the SD card "Removeable Disk"

This uses the standard Mass Storage USB Driver that comes with Windows. You generally should not need to install any drivers.

In device manager you will see a "USB Mass Storage Device" show up in the "Universal Serial Bus controllers" list and two "FrSky Taranis Radio USB Device" entries in the "Disk drives" list. If you look at them they are all standard Microsoft drivers.

Once set up in the this way Companion should be able to communicate with the Taranis.

If this doesn't work the problem is almost certainly with your PC and the drivers you have installed and not with the Taranis. Basically the complexity is with your PC and what you have done to it by installing random stuff over time.

Of course things can go wrong with the Taranis. The SD card can get corrupted and that might cause the drive not to mount. Possibly it could prevent the TARANIS drive mounting also.

"Taranis Bootloader 2.1.8" indicates that at some point you updated the bootloader on the TX to OpenTX2.1.8...chances are you also upgraded OpenTX to 2.1.8. Stock it will be 2.0.9.2 or 2.1.6 I think...unless it was an Original non plus Taranis.

Since you did use Zadig, the STM32Bootloader which you used Zadig to move to the usable place will only show in the list when active...when you plug the Taranis in the USB port with it power off. This was only required for OpenTX 1.0.X but it does coexist with Bootloader mode if the installation is correct and can be useful if you can't get other things to work.

Note that if you plug the Taranis in with the power on but not in bootloader mode, it show up as a windows joystick unless you have disabled that option. If you have configured "Mass Storage Mode" then it will present the SD card instead of being a joystick.

Not sure what your specific problem might be but hopefully that explains what you should be seeing and why.
Sep 21, 2016, 05:29 AM
Registered User
Thanks for taking the not inconsiderable time to post that, and for helping firm up my ideas. The fact that it happened on two transmitters pointed to the PC. I moved the OpenTx files accross to a Notebook PC over the network , and installed OpenTx Companion and Zadig. To cut a long story short, I am now able to work with the two transmitters using the Notebook.
Having done that, I intend ripping out everything I can think of associated with my original installation, removing any relevant drivers I see, and effectively starting from scratch. I've wasted quite a lot of hours so far, so another one or two won't hurt too much. I prefer a blank canvas to trying to figure my way around the problem. The PC itself seems not to have any other problems.
Thanks again.
Sep 21, 2016, 11:26 AM
Registered User
Glad it was some help.
Sep 22, 2016, 12:24 PM
Registered User
I thought I was nearly there, but this damned thing eludes me

This with a 9D Taranis running “2.1” firmware
Notebook PC Observations: [This one WORKS, ie can connect to OpenTx Companion]
1) Tx Off. USB cabled. Device Mgr shows, under libusbk USB Devices,...SMT32 Bootloader.
No system tray USB icon and no new drives show.
Zadig lists STM32 Bootloader, USB Input Device, and two other non relevant entries.
Driver detail under STM 32 Bootloader is libusbk and libusbk

2) "3 Fingers". Device Mgr shows Taranis Radio USB Device (twice: SD Card “drives”). Two new drives pop up, and the system tray shows a USB icon for Taranis.
Zadig: at this point lists FrSky Taranis Bootloader, and USB Input Device, etc
Under FrSky Taranis Bootloader driver detail I see usbSTOR and libusbk


Desktop PC [Does not work – OpenTx won't connect]
[I don't know how many other configurations I have run through that did not work]
1) Tx Off: Device Mgr shows, under libusb-win32 Devices...STM32 Bootloader
No system tray icon and no new drives showing.
Zadig lists STM32 Bootloader, USB Storage, etc
Driver detail under STM32 Bootloader shows libusbk and libusb-win32

2) 3 Fingers. Device Mgr shows, under libusb-win32 devices, FrSky Taranis Bootloader
No tray icon and no new drives pop up.
Zadig at this point lists FrSky Taranis Bootloader, USB Storage, etc
Under FrSky Taranis Bootloader driver detail I see libusbk and libusb-win32
....................................
I've managed to frig around and change the (Desktop) last entry libusb-win32 to just libusbk now agreeing with the working Notebook version.
"3 fingers"
I cannot, cannot damned well cannot get that Taranis Radio USB Device, as in my Notebook, for the 3 finger salute, onto my desktop machine. Zadig does not give me this option. Something else is needed, such as dynamite.
Sep 22, 2016, 04:05 PM
Registered User
Do NOT use Zadig for the Taranis connected in "3 Finger" power on boot manager mode. You only need the Zadig installed driver for the powered off connection and if you use it for a powered on connection it overwrites the correct driver with a wrong one and then it will never connect.

To fix it, with the Taranis connected in powered on boot manager mode "three finger salute" go into device manager and uninstall whatever device it shows up as, and delete the driver. It is important to delete the driver as Windows has that driver associated with the device and will just keep using it when you reconnect if you don't delete it. Disconnect the Taranis and reconnect and let Windows install its default massstore driver, (DO NOT USE Zadig). Hopefully after Windows re-installs the correct drivers you will get the two drives and everything will work.

Jim
Sep 22, 2016, 06:10 PM
S.A.D. member
ivanc's Avatar
Quote:
Originally Posted by Jim Taylor
. . .

It is important to delete the driver as Windows has that driver associated with the device and will just keep using it when you reconnect if you don't delete it.

. . .

Jim
Awesome advice!!! I keep forgetting it and recently had an issue with a USB driver which was working before (not Taranis and not RC related at all). I'd reinstall the driver which used to work previously and it would work with one device only and not with the rest.

Thanks Jim!

Ivan
May 07, 2017, 10:26 AM
Registered User

connection trouble


New to rc . Was excited to get my first radio that I had researched and decided the taranis was for me. Watched many videos and read many things while waiting for it to arrive. Received it about a week ago and now am just badly frustrated . I have spent hours and hours trying to get this thing to connect to a computer. Have tried 2 laptops and am just pulling all my hair out. PLEASE HELP.

I was typing up a whole book on what I was running into. Had a lot typed up and trying things. I have spent hours on this thing and I thought well I will see if I have another usb cord and try. Found one. Hooked everything back up with new cord and bingo everything started working right. Took a break cause I was ready to tear into a bottle of jack at 8:30 in the morning. Came back and tried it again and it works perfectly. So naturally I literally took the problem cord outside and shot it with a 12 gauge shotgun and chopped it into fine pieces with my axe. Victory is definitely bitter sweet. Still trying to calm down and trying to get my wits about me.

I Hope this will help someone out there to not go through the mental break down I was on the verge of.
Jun 07, 2017, 01:26 PM
Registered User

Taranis USB recognition error WIN 10 more info


Hey Guys, So I just got a new X9D plus and had this issue with the transmitter not connecting. I ran Zadig and keep getting the FRSKY Taranis Bootloader, update driver to the WinUSB and click OK. Now the bootloader shows up in device manger as STM BOOTLOADER this part is done but still you cant connect to opentx? It is because there are 2 elements within the taranis which need to be configured, 1. the bootloader 2. the mass storage device (your sd card). Now boot up the taranis holding the trim switches together while power on. Plug in your USB cable then open Device Manager again look below in the USB devices tab and you will see the STM BOOTLOADER (greyed out inactive) and also FRSKY BOOTLOADER active right click on FRSKY BOOTLOADER and select update driver. Select from a list of compatible drivers, there should be 3 choices that come up, select the mass storage device and install the driver. Now when you open file explorer you will see both the Taranis:H and the sd card:L listed. Now you can connect to opentx and life is great. I struggled with this for weeks and never did find any help on the subject so hopefully this helps someone else out.
Jul 06, 2017, 07:15 PM
Registered User

USB device not recognized


I have a Taranis that just won't connect what so ever.

All I get is a notice that says the USB device malfunctioned or is not recognized.
It's a brand new Taranis with the latest firmware.

Please can you tell me what I need to do to use it as a controller for a simulator, or just get my Win10 PC to recognize it?
Jul 06, 2017, 07:36 PM
Registered User
What do you mean by "the latest firmware"?

If you updated it then if you chose the Mass Storage Option or the CLI option in the Build Options then the Windows Joystick feature is not available. Those 3 features are mutually exclusive. You will need to uncheck those option download the new firmware build and re-flash the TX to get it back. You can use the OpenTX Bootloader to access the SD card and the models so you don't really need the Mass Storage Option.
Jul 06, 2017, 07:38 PM
Registered User
Markran's Avatar
One general piece of troubleshooting advice. I recently had a USB cable that had worked fine with other devices in data mode cause intermittent problems with getting my Horus set up, when I switched cables things started working properly. I didn't try switching cables sooner because I *knew* it was a good data cable.
Jul 06, 2017, 09:34 PM
Registered User
I found that my Taranis would not talk to m PC over a longer than normal USB cable but works fine with a short one. I have other devices that work fine with the longer cable - I use it so that I don't have to go to the back of my PC to plug in my USB. USB cables vary in quality a lot and some cheapo ones just do not meet the USB specs.
Jul 17, 2017, 02:35 PM
Registered User
For anyone with problems connecting the Taranis to their PC, I have figured out what was causing the problems for me!

For nearly the past 2 years of owning my Taranis X9D+ I have never been able to connect it to my main PC but it worked on my older PCs. My new, main PC has USB 3.0 ports and "Intel(R) USB 3.0 eXtensible Host Controller" is what's causing the problem!

I finally figured it out when I tried the Taranis almost immediately after a clean format and a fresh Windows 7 install.

I tested it after every driver I installed. When I got to and installed the USB 3.0 drivers, I started getting "Unknown device", or "USB device has malfunctioned" when I plugged the Taranis in. If I uninstalled those USB 3.0 drivers, the Taranis worked again.
Oct 22, 2017, 09:09 PM
Registered User

The answer might surprise you...


sweet