ESC not recognized by Phx-link - RC Groups
Thread Tools
Sep 05, 2004, 02:58 AM
Gravity brings me down
Earthbound's Avatar

ESC not recognized by Phx-link


I had three Phoenix speed controls which went to Castle at the end of Aug for updating. Repair invoice 24897.

I have just tried to configure them using the Phx-link. The P-35 and P-45 both cause the Phx-link software (1.02) to give message "Internal Error - Settings not found for this controller type" and close.

What gives? Do I need to use one of the beta versions?
Sign up now
to remove ads between posts
Sep 05, 2004, 03:07 AM
zaf's Avatar
Yep, Try 1.05b. It worked for me. I couldn't even install 1.02 on two different XP pc's. 1.05 works great. Fixed the internal errror prob for me.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Phoenix 45HV not recognized by Castle Link Xnaron Castle Creations 2 Aug 05, 2006 11:40 AM
Discussion Phoenix 80 not detected by castle link... jameotron Castle Creations 5 Jul 30, 2006 10:01 PM
CC 25 Phx Link ESC not connected? mdlifcrisis Castle Creations 19 Aug 05, 2005 11:48 AM
Question Program two ESC in Parallel using Phx-Link? LexTalionis Castle Creations 4 Oct 29, 2004 06:41 PM
Question PHX-Link for brushed esc? newracer Castle Creations 3 May 10, 2004 11:23 AM