Phx45 low rpm in Gov mode on heli, what up? - RC Groups
Thread Tools
Aug 18, 2004, 02:47 PM
Registered User

Phx45 low rpm in Gov mode on heli, what up?

Background: I have a Phoenix 45 that I removed from my Eolo helicopter to use in my Corona while waiting for a Phoenix 35. With the arrival of the 35 I put the 45 back into my Eolo. The 35 is working great in my Corona but in my Eolo/phx45 I can't get the headspead I had before I moved it. Obviously I changed the programing going from collective to fixed pitch and back. While doing this I also updated to the 1.05 software. While the 45 was out of my Eolo I used a Phx 60 in it which worked as the 45 used to.

Problem: Before I was getting a head speed of about 1850 rpm with a Mega 22/20/2 and 8 cell 3300 Gp NIMH pack. Now I am only getting 750 rpm with everything else being the same. I have not changed my throttle curves on my Eclipse.

My Phx settings:
cutoff 5v
current limiting: insensitive
brake: disabled
throttle type: gov low RPM (also tried high RPM)
soft start: softest
timing: high advance (also tried standard with same results)
cutoff: soft
soft start: very soft start
PWM Switching: 11 Khz

Any thoughts on what would have changed? Or what I might have done wrong?

Thanks, Joe
Last edited by JoeR; Aug 18, 2004 at 02:54 PM. Reason: added settings
Sign up now
to remove ads between posts
Aug 18, 2004, 03:28 PM
A man with too many toys
This has been a very serious problem for quite a few months now.

I noticed the same thing Ė the current software has a much lower rpm band than the old software. The problem is that all the PhxLink software has the same problem. There are a lot of helicopters that will no longer fly in the governor mode?

I really donít know why the governor mode rpm band canít be increased to where it was before. I have asked this question before but everyone at CC seems to be clueless as to what happened.

I had to get a Kontronik ESC to get my Eolo back in the air with a governor.
Aug 18, 2004, 03:43 PM
Registered User
Darn it! And I was thinking this type of thing only happens to the other guy. I had read good things about 1.05 so I figured it was safe to update.

I have a Beat that I could use but I would rather not.

Aug 18, 2004, 04:37 PM
Always right
Hovertime's Avatar
Joe - which version worked for you?
Aug 18, 2004, 05:08 PM
Registered User
Hovertime- Whatever one was on it before. Sorry I don't know. I think I had to send this one back to Castle to make it readable by the phoenix link. When I go it back, after reading about the problems, I left it as it came back to me. On second thought that might have been the 60. Either way they both worked before updating to the 1.05 firmware. The 60 worked fine, however I just updated it at the same time as the 45 so maybe it won't anymore... I read your posts and thought all was okay now...

I just changed back to the 1.02 version of the software and kept the high advance timing and the head speed was up to 1170 rpms at 100%. Higher but still not where it needs to be to fly.
Aug 18, 2004, 06:36 PM
Always right
Hovertime's Avatar
Sorry Joe, I use hacker which is 2 pole, and works flawlessly for me...
Also razor 400 which is 4 pole motor reaches full rpm both in low gov mode (when i extend the endpoints a bit) and high gov mode (with standard endpoints.)
Have you tried manipulating endpoints in your radio?
Strangely this issue that high pole governor users are having is overlooked by CC for a while now!!!!
Aug 18, 2004, 08:14 PM
Registered User
I am not sure how many poles the Mega has. Like I said it worked fine with the old software. I guess the saying -if it ain't broke don't fix it - is true here.

The motor ran the same in low and high gov modes. I did not try playing with the end points. My idle up 1 is set at 85% and idle up 2 is at 100%. With 1.05 it reached full throttle before 85% and there was no change at 100%. The was a difference in RPM when I went back to V 1.02 but the highest RPM was 1170 at 100%.

Aug 18, 2004, 08:45 PM
A man with too many toys
The Mega is a 6-pole motor. The more poles the slower it runs?
Aug 18, 2004, 11:57 PM
Registered User
buzzsaw 46's Avatar
I'm having the same issue with a P-60 on an Aveox which I thought was a 4 pole. The Castle is sending me out a new one and I will try it out with the tried and true throttle stick set up.
Aug 19, 2004, 03:21 AM
Always right
Hovertime's Avatar
Just an observation-since I use either fixed throttle mode or governor mode (which have fixed endpoints too) in my esc's - I have noticed that endpoints to get full power at full stick (or 100% throttle for gov) are different for fixed and gov modes, and also sometimes are different from one version of software to another.
Low endpoints are different too.
Aug 19, 2004, 03:34 AM
Registered User
buzzsaw 46's Avatar
I have found the same to be true.
Aug 19, 2004, 06:59 AM
Registered User
So just to be clear. You increase end point to max and also set gov mode?

I just don't get why the updated controllers coming direct from CC are working fine but when updated with the phoenix link they no longer work.

Well, I will try to increase the end points and report back in a couple hours.
Aug 19, 2004, 07:30 AM
Registered User
Okay, I could not wait so I upped the endpoint to 125% on my Eclipse.

Still running 1.02 software since it gave me more RPM then 1.05 to start

New rpm: 1560

I gained about 400 rpm. Still not where I need to be. Need 300 more.

I am going to a fun fly on Saturday. I would really like to get this fixed. Are you finding that throttle curves give full throttle? If so I will try to set those up. Otherwise I need to dig out the beat that I have.
Aug 19, 2004, 02:00 PM
Registered User
buzzsaw 46's Avatar
I was unable to get my P-60 to work with any end points, Fixed throttle didnt help any for me with V1.05 and I was unable to revert back to V1.02 for some reason. Good luck getting it to work! I hope you dont miss the show because of this problem
Aug 19, 2004, 02:12 PM
Always right
Hovertime's Avatar
Originally Posted by JoeR
I just don't get why the updated controllers coming direct from CC are working fine but when updated with the phoenix link they no longer work.
Controllers probably had version earlier than 1.02 when you got them from CC...
Anyways you should be in high gov mode, and see a difference in rpm range between high and low modes.
I'm going to check high and low gov modes with razor 400.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
What's the max electrical rpm in governor mode? Lynxman Castle Creations 8 Sep 21, 2005 01:53 AM
Shogun / CC-35 Set-up In Gov Mode John_C Mini Helis 17 Jun 08, 2005 08:34 PM
Phoenix 10 & Razor V2 in Governor Mode on Heli Xnaron Micro Helis 5 Feb 27, 2004 03:59 PM
High or Low Gov mode on CCP-10 controller Lv2Fly Micro Helis 4 May 16, 2003 08:12 AM
Setting up gov mode on smile 40-6-12 ALVES Electric Heli Talk 7 Apr 03, 2002 08:48 AM