Thread Tools
Apr 24, 2016, 07:33 PM
Registered User
Thread OP
Discussion

rth not landing...just hovering what did i do wrong


i just tried flying fpv for my first time with my 453 quad. i started to get disorientated so i turned off my radio to trigger the rth feature. it flys to the rth located then just hovered.. i may have been ascending a little but i was to busy trying to figure out how to disengage the rth feature so i could land.... i assume this is a setting i have wrong in my vector what should i look at to fix this automatically land at home is also checked
thanks jeff
Sign up now
to remove ads between posts
Apr 25, 2016, 11:56 AM
JohnET's Avatar
Hello,

First, we never recommend that you turn off your radio for any reason while you are flying. We recommend that you use your mode switches to activate RTH.

As for it not landing, do you have "Automatically Land at Home" set to "Yes" on the safety tab in the software? If you do, and it is still not landing, please open a support ticket and provide your log and config files.

Regards, John


Quick Reply
Message:

Thread Tools